- The LaST Upgrade -

PART 31 - STE DAC & LMC FIX

Last updated November 18, 2016

 

STE DAC AUDIO NOISE FIX - BETA

I have heard many reports that the STE DAC playback has bad noise and high pitch whistles so I was asked to look into it. My own STE machine did not suffer from these problems, but the PSU is likely the first cause of noise. If the PSU hasn't been updated or one of my own branded PSU's used, then likely the STE will suffer from power supply noise which first needs to be rectified before doing the following fix. Its worth noting that the audio system likely suffers from various noise throughout the audio path, so this "fix" should help reduce the problems a great deal, but won't fix problems elsewhere in the audio path.

I have not had a audio fault on my STE's, So I was unable to test to see if this fix solves problems personally. I have however talked with 2 guys some months ago who have tried this fix, and they reported a great improvement with audio quality. So this little PCB was designed which soldered ontop of the DAC IC's which covers all previously tried modifications.

This design is a WIP (Work in Progress) modification where people who try this fix, please report back your findings. If the fix is proven to help, then I will produce some more of these boards. Currently I only manufactured a limit number (about 10 sets at the time of typing) as the final results are still somewhat unknown.

Fitting is pretty simple, though can be a bit fiddly due to both DAC IC's being very close together. Just solder the PCB pins onto the DAC as shown below and that is pretty much it. Not all pins are used on the PCB so no need to solder them all. It is probably easier to solder the pins to the DAC IC first, then solder the PCB onto the pins second as there is not much room around the DAC IC to solder.

 

First push the header pins into the PCB from the TOP side as shown. The longer end of the pin goes into the PCB. Do not solder anything yet.

NOTE: The pins are a tight fit, so you may need to press them in on something solid like a scrap block of wood etc.

 

The PCB pins sit ontop of the DAC pins and are soldered like the image above. I would suggest tinning the IC pin and first header pin with solder first. Then you can simply hold the PCB and heat up the solder to melt it onto the IC leg (obviously its going to be hard to hold the PCB, soldering iron and solder all at the same time!).

Once you have the first header pin soldered, then you don't have to hold the PCB and then can solder all 4 pins both side of the DAC IC.

I would suggest a pocket magnifier with a light such as the one in my store HERE as its difficult to see if the solder has taken to both the IC and header pin otherwise.

 

Then as shown on the left image, push the PCB down flat tot he DAC IC.

Then as shown on the right image, solder the pins and cut off the top side of the header pins.

Repeat on the other side of the DAC IC.

 

On the second DAC PCB, insert the pins as shown above. Push the top side of the pins as far down as they will go as shown.

 

As before solder the 4 pins both sides of the DAC IC. Check with magnifier that the solder joints look good.

Then when all 8 IC pins are soldered, push the PCB down flat to the DAC IC and solder the PCB side header pins. Then cut the remaining pins off as before.

 

That's it! All done!.

Please report back if this helps with your audio "noise" issues!

 

STE LMC MIXER AUDIO FIX

This work was originally done by P.Putnik and the original information can be found HERE on his forum. Other references HERE and HERE. I thought this tweak deserves its own mention on this page!

It seems Atari had a option to reduce the mix volume between DMA sound and YM sound but it never worked. Apparently P.Putnik found in games like Xenon that the YM sound was much louder than the DMA audio sounds but this little fix sorted that out. I found a video HERE of fixed Xenon sound.

People reported there simple was no audio at all on the second mixer settings. So I took to investigate this to see what was going on.. The program I used was was by Cyprian HERE.

 

 

I highlighted in red the "fault" in the Audio design as found by P.Putnik. What is going on here is the AUDIO2 channel (pins 5 & 25 on the LMC) are actaully wired to GND So no audio will ever go though AUDIO2 path. Not GND is not technically correct as there is a DC offset voltage, but in order not to confuse , just assume AUDIO2 is wired to GND.. It makes easier explanations :)

At the bottom we have AUDIOS (YM) inputs basically wired directly into AUDIO1 path (pins 4 & 26 on the LMC). So audio input to the LMC mixes gets full volume.

What P.Putnik proposed is the fix as shown below.

 

Here a new 10K resistor is in place which acts as a voltage divider (or volume control) to limit AUDIO2 to about 25% of normal volume (not that the volume was zero before!). I checked this on my scope as shown below.

 

The left scope traces shows pin4 of the LMC of 1volt (x10 probe used so scope shows 100mV) , actually same result before and after the fix.

The right image shows pin5 of the LMC. Before the fix this was basically a flat line, so I did not bother to take a capture of that. Now we have 230mV (0.23V ) on AUDIO2 which means audio now works as intended. I don't know exactly if this equates to -12dB but probably isn't far wrong even if so.

Finally a image of the fix...

 

 

The top resistor is 10K and the bottom resistor I used 47K as its a more common value. Then just a wire link as shown and thats it!

TIP: The way I solder this in, is to solder in the bottom end of the 47K to the motherboard first and the top leg solder to the top leg of the resistor to the right. Then the 10K can be soldered to the motherboard and soldered to the 47K as shown in the above image.

 

 

HOME