- The LaST Upgrade -

PART 23 - M/STE VIDEO GHOSTING FIX

Last updated August 21, 2017

 

While I was developing my replacement Atari PSU I noticed the video quality improved immensely. However, I still saw some "ghosting" on the display which baffled me for a few hours. While ghosting can be other factors, such as bad video cable, or a bad LCD TV, for me the problem was on the Atari itself.

On the left is the image before my fix, and on the right is after my fix. The left image shows ghosting to the right of the Atari Fuji and at the ends of the black box lines. While the ghosting is faint it can still be seen clearly compared to the image on the right. Thankfully the fix is a easy one..

NOTE - This mod was to fix RGB/scart issues and has not been tested with RF or Composite video signals.

 

Near the top left of the simms there is a yellow capacitor (C411) which needs more capacitance across it. The odd-ish thing is, R544 is actually a 8V regulator feed from the 12V rail. Normally I would have expected good regulation there, and it is, but its still not good enough to solve the video problems.

The results are...

1uF ceramic doesn't fully solve the ghosting problem.

10uF electrolytic probably 95% solves the problem.

47uF seems to work best, may improve a couple % with the 1uF in addition.

So a 47uF capacitor with the possible addition of a 1uF ceramic seems to fix this issue. Larger values than 47uF can be used, but I would not recommend going below 47uF. Like I keep saying over and over in other pages on my site, you NEED low ESR capacitors otherwise "any old capacitor" will not work! Look towards Panasonic FR range of capacitors. I generally have a stock of all sorts of values of capacitors in my store if anyone needs some.

That's it! Enjoy your ghost free display :)

 

Another couple of images of ghosting issues (and fixed ) on a STE I was servicing today..

 

MSTE VIDEO GHOST FIX (WIP)

I had a MSTE in for repair so I looked into solving the ghosting issue. It was only slight on this machine, so capturing a image proved difficult. However with soldering a low ESR 10uF capacitor across C506 as shown in the above image removed what little ghosting I saw.

If anyone can verify this and take images on their own MSTE then it would help.

 

 

HOME