Edward S. Baiz explores networking on his Hades060


[Photo: Edward S. Baiz]Hello everyone, Gamer here once again with yet another article about one of my many great experiences with my Hades060. When I first got my Hades060, I did not really know or care about what an Ethernet connection was. Although it had a LAN port, I never had any intention of ever using it. To this day, it still goes unused. When one of my Atari buddies explained just what an Ethernet connection was, I thought to myself, "Why would I want this and how could I use it?". My wife had a PC and loved it dearly. Me being an avid Atarian, had no intention of forming a connection to an Intel machine. That is the way it went for about four years. I would just ignore all messages concerning the subjects of LAN and Ethernet. Now I wish I had not done that.

What changed my mind? A lot of things. First of all, my wife's first PC had the hard drive wiped clean by yours truly. I downloaded a program that I thought would format a floppy, but it turned out it was intended to be used on hard drives. So, the hard drive was wiped clean and my wife had no back-ups on floppy. She was mad and I was going nuts on how I could restore her drive. It took me awhile, but I got back about 70 percent of her files. When she got her Pentium, I was determined that I would not go through that again, so I figured, why not use my Hades060 to back-up my wife's important files as she had no CD burner and I had two.

Another reason - and perhaps the biggest - was the fact that I could hook up a cable modem. This is what really sold me. With a cable modem, my wife and I could be on-line at the same time and we would not be tying up the phone line. I was also having trouble with my dial-up ISP. More often than not, I would be connected and the speed would drop down to 300 bytes/sec which is not good when you are downloading big files. I would also have trouble connecting at 56 Kb as most times I would get a 28 Kb connection which really bites. So, when Lonny Pursell, who also owns a Hades060, told me how much he loved his Ethernet/cable modem connection, I decided it was time for me to take a big step forward and do the same.

[Photo: My Hades060]

Before I could do anything I had to get two things for my Hades060. The first was an Ethernet card, and the other (and most important), the driver for that card. Enter Odd Skancke. I and other Hades060 owners owe this man a lot. He not only wrote the PCI Ethernet driver for my Hades060, he also wrote a driver that allows me to play audio CDs through a PCI Soundblaster card. I appreciate everything he has done. On his web site (, Hades060 owners will find all the information they will need to get them started on an Ethernet connection.

I e-mailed Ozk and told him that I wanted to try out his driver. He e-mailed me back with instructions to e-mail him the results of a program he had attached which would read my PCI bus. That way, the driver would be sure to work with my machine (I should mention that Ozk's driver is intended to function under MiNTnet). Now I had to get the card. The driver works with six Ethernet cards that I know of all having the RTL8139 chip. I chose the D-Link DFE-538TX RealTek card mainly because this is the same card Lonny Pursell had in his Hades060. I could not get the card locally, so I ordered it for $15 (bargain! - Ed).

When I received the card I installed it immediately and booted up the Hades060 using MiNT as the OS. The driver loaded up fine and recognized the card which thrilled me. Now, I just had to get the Ethernet connection going and I would be all set. Although the Hades060 was taken care of, I still had some other things to arrange such as choosing which broadband to subscribe to. I eventually chose AT&T as I already had their cable service for the TV and I knew some people who had their internet service. All were happy with it, so I went to their web site and found out that my area was covered. My wife then called and made the appointment for a technician to come over.

However, I still needed three more items:

  1. A PCI Ethernet card for my wife's PC
  2. A cable modem
  3. A router (gateway device)

I decided to buy my cable modem as this would save me $10 a month on my AT&T Internet service bill. The one I finally chose was a RCA digital Broadband Cable Modem as the President of our Atari club had the same one which he got from AT&T.

[Photo: RCA DSL modem]

I also chose the same router he had on his system which was by LinkSYS. The PCI card I chose for the PC was also by LinkSYS. Now all I had to do was to wait for the AT&T technician to come over and install the internet cable service.

[Photo: LinkSYS router]

From the beginning, I always thought it would be easier to get a successful Ethernet connection with the PC than it would for the Hades060 since almost everything in the computer world is made with PCs in mind. I was soon to find out it would be the opposite.

It all began when I got home and found out the technician had installed the internet service using the USB port on the PC. It seemed that my RCA cable modem could be connected either by using the USB port or via a PCI Ethernet card. My wife was supposed to tell the technician that I wanted to use the NIC (Network Interface Card) but she forgot and told me the technician seemed to know what he was doing. A USB connection would do me no good as the Hades060 did not have a USB port and neither did the router I had bought. So I quickly disconnected the modem and installed the PCI card along with the drivers.

The technician did not completely install the system and I wanted it that way. I wanted to do it myself just in case things went wrong so then I would be able to fix the problem. Too many people rely on computer technicians for simple computer problems which is a waste of good money. You will not believe how many "experienced" PC owners ask this Atarian for computer help.

Getting the PC working with the Ethernet connection took longer than expected, but as this is supposed to be an Atari related article, I needn't say any more on the subject. First of all, as far as I know, a Mac or a PC computer will be needed if one is going to have a router in the Ethernet setup. The reason is that most routers are built with PCs and Macs in mind. You need one of them to configure the router. This is done by typing the IP address of the router in a web browser like Explorer. The IP address of the router I bought was Once this is done you can access the router and can configure it to your liking using a friendly web page. I set my router for two users (the PC and the Hades060) starting at IP address: I gave the PC the IP address: and my Hades060: Adding more computers to the network would mean re-configuring the router by increasing the user number.

After configuring the router, installing the PCI network card and installing/configuring the drivers in the PC, I made sure the modem was hooked up to the router correctly and that the PC was hooked up to the router correctly. I then tried it out and to my surprise, nothing worked. I could not get past the cable modem. I was supposed to be able to get to the beginning screen at the AT&T web site so I could initialize my account. Try as I may, I could not get anything. After a week of trying, I finally called AT&T. I talked to them on the phone and did everything they told me to do and still nothing. I was then informed that a technician could come to my house to fix the problem but that it would cost me an extra $50. That did not please me, but I really wanted to be connected.

Although the technician was due to arrive at 3pm, I was still trying things out at 10am. However, I eventually gave up and shut down the PC. At 2:30pm I fired up the PC so the technician could work on it and to my surprise the Ethernet connection worked. Consequently, when the technician came, he was done in five minutes (but still charged me the extra $50). This made me wonder if something was done incorrectly their end from the start.

One last thing, when you boot up, you must remember to power up in the following order: router - modem - computer. This is because you want the modem to read the configuration of the router you have set. If you turn on the router before the modem, the PC will not have the IP address you want it to have.

Enough about the PC. With it successfully connected to the network, fully functioning and my wife happy it was time to make me happy and get the Hades060 working.

Since the driver I had for the PCI network card worked with MiNTnet, I had to boot the Hades060 with MiNT as the OS. On Odd Skancke's web site, there is a document file in which he explains how to get a Hades060 hooked up using the Ethernet connection. The file can be downloaded from the Odd's web site or Lonny's at The file assumes you already have a Hades060, MiNTnet up and running, the shell Bash (and know how to use it), know how to setup a cable-modem and gateway router as well as know how to set up any non-Atari machines connected to your LAN. I will say that even if you do not have a Hades060, this document is still useful. In my case, I was ready.

I connected the network PCI card in my Hades060 to the router I had bought which could accommodate up to four devices (it did not matter which of the four ports the devices were plugged into). Below is a diagram of my set-up. The diagram is based on the one from Lonny Pursell's LAN document file, however, I have substituted it with my own details:

[Diagram: My system]

In the diagram, CAT5 cables are denoted as '==='. CAT5 cables look like regular phone-line cable (in the US - Ed), but they are intended for Ethernet set-ups. I had to buy three such cables for my set-up.

The next important step was to configure my Hades060 to work with the PCI NIC (Network Interface Card) and MiNTnet. The first thing I did was to set my nameserver address to that of AT&T. To do this, I had to edit the file, resolv.conf, in the etc folder on my MiNT partition. I used QED to make the adjustment since it can save files in Unix format. The next step was simple. I opened Bash and typed in and executed the following three commands:

[Diagram: ifconfig commands]

The ifconfig utility is often used to define and manage IP addresses within a network. The rtk0 is the interface the NIC is installed at. So, the first statement assigns the NIC IP address while the netmask is given the standard value The last two statements add the gateway (router) to the network so that the Hades060 can use it. You do not really have to understand these statements, you only have to know that they must be executed in order for the Ethernet connection to be made.

If you do not want to type these statements into Bash every time you want to get connected, there are other ways to accomplish the same thing without all the hassle. One way is to place these same statements in an ASCII file called This file is in the folder, rc.d which can be found in the etc folder. The statements can be put anywhere in the file, but it's best to put them at the end. As the file is executed at boot-up, it means the Ethernet connection will exist all the time. However, the way I prefer to open the connection is to execute a Bash script.

To do this, I first opened QED and created a new file called "connect". I typed in the three commands and made sure the file would be saved in Unix format. I then copied the file into the same folder as the Bash program (which is in the bin folder which exists in the usr folder). I next used Thing to make sure the file was executable. Now all I have to do is to go into Bash and type "connect" and the connection is made. I also created  another script called "disconnect". What this file does is obvious. I needed this script so when I use a program like NEWsie I can read news messages off-line. The command line inside this file is ifconfig rtk0 down.

All right, after the Bash script is executed, is the Ethernet connection working? The best way to find this out is to use the ping command. The ping command is used to determine whether a particular IP address is on-line by sending out packets and waiting for a response. I first pinged my wife's PC which had the IP address by typing: ping in Bash. This is the result I received:

[Diagram: Ping results]

[Control]+[C] stopped the ping process. The 0% packet loss reported meant that the connection was fine and that my Hades060 was talking to the gateway (router) correctly. If I had gotten 100% packet loss, then I would have had to check all connections and configurations. I also pinged the Hades060 from the PC just to be sure. I thankfully got the same positive results as above, which made very happy.

Once I was sure things were OK, I rebooted the Hades060 and executed GlueSTiK, a utility that allows programs which require STiK/Sting to work under MiNTnet. I was consequently able to run CAB, MyMail, aFTP and others at much faster speeds. I was amazed at the difference. Instead of downloading files at a rate of 5,000 bytes/sec, I was downloading at 30,000-50,000 bytes/sec. However, I did notice some disturbing things. When I was sometimes downloading, the data would just stop flowing which resulted in me just getting only part of the file I wanted. The same thing happened when I was surfing the web. Data flow would get slower and slower until it stopped. Ozk did not know the reason, but I was sure I knew. I was using MiNTnet under N.AES 1.2 while most people like Lonny Pursell were using version 2.0. So, I sent in my money to Woller Systems where I originally purchased N.AES and waited anxiously for the upgrade. As I was new to MiNT, I knew my setup was a little unstable. I was sure that once things were ironed out, MiNT would prove to be a formidable OS.

While I was waiting to for my N.AES upgrade, I looked into something else that I could use which was MagiCNet. MagiCNet is a MiNTnet clone that allows MiNTnet programs/drivers to be used under MagiC. The author of the program is Vassillis Papathanassiou. I was told by other MagiCNet users that setting it up was much easier than setting up MiNTnet as less files where involved. I wanted to establish an Ethernet connection using MagiCNet since my MagiC environment was more stable than my MiNT one. Once I ironed out MiNT, I would then use it more.

Initially, setting up MagiCNet was a breeze. I first had to put the MagiCNet program in my Xtension folder. It was here that I also put Odd's driver for my NIC card. I only had to make one change. The extension on the driver had to be mif instead of xif as it was for MiNT. I then created a new etc folder and put it on a partition that supported long file names. Inside that folder were ASCII files all in Unix format that contained vital information (such as nameserver, hostname, domain name, hosts). In my Start folder for MagiC I had to put a program called MAGXCONF.PRG and an ASCII file called MAGX_RC.NET. This file is MagiCNet's version of the file for MiNTnet, so the same three commands that were executed using Bash had to be placed in there. I also had to make reference to where my etc folder was.

So I rebooted the Hades060 to see what would happen. Odd's driver loaded fine and recognized the NIC card which was installed it at interface rtk0 just like in MiNT. The problem was that I was not connected. In fact, when I tried to use the ping command, I kept getting a response from the program saying "invalid protocol". I started asking around and most people had some nice advice which I tried. However, nothing really worked. I still kept getting the "invalid protocol" message when trying to use the ping program that came with MagiCNet. The MiNT people were telling me that my problem was that Odd's driver was meant to be used under Mint/MiNTnet and nothing else. The puzzling thing about this situation was that if I ran the programs ifconfig.ttp and route.ttp (also came with the MagiCNet package), I got the same results that I had seen from other examples from the documents and other people. I showed my results to Mille Babic and he said they looked fine. Still, however, no connection and no results from doing any pinging.

I was frustrated and almost ready to give up when I had an idea. In my etc folder for MagiCNet was a file entitled protocol. It was not very big, so I wondered what the corresponding MiNTnet file looked like. I loaded up MiNT and saw that there was a file named protocols in the MiNTnet etc folder. Looking at it I was amazed at the difference in size. The MiNTnet file was huge compared to the MagiCNet file. So I copied the MiNTnet protocol file and put it in the MagiCNet etc folder. I tested the Ethernet connection and still nothing. However, when I ran the ping program and pinged the Hades060, I did get a response like I should. When I pinged the router and the PC, I did not get the response I wanted, but I did not get the "invalid protocol" message either.

I was so close now. I had everything set up the way the documentation and everyone else said it should be. There was something I was missing and I had to find out what it was. Someone had mentioned that Mille Babic had a web page describing how to connect an Atari to a network. I went there and read everything. It is a real informative web page and I learned a lot. I did notice he had a section on MagiCNet with an extensive article on the subject. I thought that would help and went there. The article was extensive, but the problem was that it was in Swedish. Mille told me he was having it translated and hoped to have it on-line soon. He recommended I look at the screen-shots since they were mainly in English. I must have looked at those pictures a thousand times before I found something that was different. It seems the nameserver address Mille was using was the same IP address as the router. I, of course, was using the nameserver address AT&T had listed in their information. Once I changed this and tried the connection, I was thrilled to finally see it work. I was able to get all my internet programs (CAB, aFTP, NEWsie, MyMail, AtarIRC, AtarICQ) running and at a much faster speed. I could download and upload files without a hitch. I could finally rid myself of the dial-up connection woes.

Now that I had a stable Ethernet connection, I had one more thing to do. I had to find a way to disconnect the Ethernet and then connect back again so I could use programs like NEWsie that offer off-line reading. Under MiNT it was simple to use the Bash scripts I had created. Then I remembered I had a little program called Simple Script (by Mark Wherry of GEMTrade fame). This program. like the name says, lets one create scripts to be used to control GemScript applications. I used QED and created two scripts just like before making use of the programs ifconfig.ttp and route.ttp that came in the MagiCNet package.

I tested them out and they worked great. Below is the script I created to activate the Ethernet connection:

[Diagram: Jinnee commands]

As you can see the commands used are basically the same as the ones used under MiNTnet.

In closing, I would like to say that it is great having a cable modem and an Ethernet network. The speed is excellent and now I can venture on the internet and talk on the phone at the same time. I will enjoy it even more when I finally have a stable MiNT/MiNTnet environment. Then I will be able to use the secured-sockets CAB.OVL file on the web and other things that are only offered if one has MiNT as their OS. I have a STE that sits next to my Hades060. Maybe someday I will get it connected to the network.

This whole thing concerning Ethernet and the network has been a wonderful learning experience for me and I hope this article offers some sort of help to those just starting out in getting their Ataris (especially Hades060) connected to a network. If you have any questions or comments, please contact me at Take care all and remember, Atari forever.

Useful links


Top of page ]

MyAtari magazine - Feature #3, September 2002

Copyright 2002 MyAtari magazine