Search found 31 matches

by qq1975b
Thu Jan 14, 2021 6:43 pm
Forum: CHAT FORUM
Topic: Videopac+ G7400 PSU
Replies: 29
Views: 1119

Re: Videopac+ G7400 PSU

The D189 was totally broken from below. I have replaced it and now the PSU works fine: 5.15V and 11.22V

Thank you all for your help!
by qq1975b
Wed Jan 13, 2021 5:41 pm
Forum: CHAT FORUM
Topic: Videopac+ G7400 PSU
Replies: 29
Views: 1119

Re: Videopac+ G7400 PSU

I have checked them and they seem wrong. Others on the pcb are OK.
by qq1975b
Wed Jan 13, 2021 7:38 am
Forum: CHAT FORUM
Topic: Videopac+ G7400 PSU
Replies: 29
Views: 1119

Re: Videopac+ G7400 PSU

The caps are all correctly placed. I have checked the two resistors and are OK too but the 5V fans don’t move and the 12V one runs too fast.
4EB19435-1D3B-4305-8D2F-03177C7C14DF.jpeg
4EB19435-1D3B-4305-8D2F-03177C7C14DF.jpeg (378.45 KiB) Viewed 304 times
by qq1975b
Sat Jan 09, 2021 5:04 pm
Forum: CHAT FORUM
Topic: Videopac+ G7400 PSU
Replies: 29
Views: 1119

Re: Videopac+ G7400 PSU

OK, I will replace all caps again. No one is fit in reverse. And check all you told me.

I’ll be back 8-)
by qq1975b
Tue Jan 05, 2021 5:47 pm
Forum: CHAT FORUM
Topic: Videopac+ G7400 PSU
Replies: 29
Views: 1119

Re: Videopac+ G7400 PSU

I focused only on the PSU that works Ok. I have replaced all the caps and now I get 5.16V and 10.86V when loaded. So I think it is OK now because they are in the admisible values you told me. I have also replaced all the caps on the motherboard, replaced the power switch and installed a switch to tu...
by qq1975b
Mon Jan 04, 2021 12:17 pm
Forum: CHAT FORUM
Topic: Videopac+ G7400 PSU
Replies: 29
Views: 1119

Re: Videopac+ G7400 PSU

So here are the news: I have attached 3 little 12v fan and 3 little 5v fans. On the psu with replaced caps the 12v fans work and the 5V fans don’t. Without them it shows 4.9V though.with them the 5V shows 1,65V and the 12V’s shows 13v then 21 then 27 and 13 again,.... On the old PSU all of them work...
by qq1975b
Sun Jan 03, 2021 11:52 pm
Forum: CHAT FORUM
Topic: Videopac+ G7400 PSU
Replies: 29
Views: 1119

Re: Videopac+ G7400 PSU

As you have also posted to a Dutch forum I hoped you would be near to the Netherlands, that would make it a lot easyér as some things seem to get lost in the translation. Yes, on a Videopac forum but it isn’t very active and the problem is about the PSU. As stated before you would be better of conn...
by qq1975b
Sun Jan 03, 2021 9:34 pm
Forum: CHAT FORUM
Topic: Videopac+ G7400 PSU
Replies: 29
Views: 1119

Re: Videopac+ G7400 PSU

Testing a PSU without a load is considerd without the Videopac mainboard connected, this has nothing to do with a game cartridge being connected or not! If the voltages are more than 10% higher than 5V and 12V with the mainboard connected then shut it down or you will most probably damage the morth...
by qq1975b
Sun Jan 03, 2021 7:46 pm
Forum: CHAT FORUM
Topic: Videopac+ G7400 PSU
Replies: 29
Views: 1119

Re: Videopac+ G7400 PSU

I will see if I can load it with a game. IMHO: I dont know the Videopac machines but lets take a look. Testing this without a load is meaningless, but to use your Videopac as a load is a gamble ofcourse. Also I would not test the PSU without load as I have seen some (bad) PSU's go up in smoke becaus...
by qq1975b
Sun Jan 03, 2021 7:45 pm
Forum: CHAT FORUM
Topic: Videopac+ G7400 PSU
Replies: 29
Views: 1119

Re: Videopac+ G7400 PSU

Yes, I have changed it but yes, it seems not good. I will replace it.

Go to advanced search