Search found 51 matches

by Globox
Sun Oct 18, 2020 3:29 pm
Forum: MONGREL H4 USER BUILDS
Topic: H4 assembly build on youtube
Replies: 4
Views: 1081

Re: H4 assembly build on youtube

I wanted to check out this video, but youtube says the channel doesn't exist anymore.
Is it still up somewhere?
by Globox
Sat Oct 17, 2020 7:15 pm
Forum: HARDWARE ISSUES
Topic: Problems with my Atari 1040STf
Replies: 30
Views: 1887

Re: Problems with my Atari 1040STf

Just checking, as we're already on page 3 now and I don't see any progress. Have you done any of the MANDATORY FIXES or BASIC TROUBLESHOOTING yet? Got a new exxos PSU so that's fixed already Not using parity SIMMS DMA pull up not needed because i'm not using a hard drive and no floppy drive (or doe...
by Globox
Fri Oct 16, 2020 9:02 pm
Forum: HARDWARE ISSUES
Topic: Problems with my Atari 1040STf
Replies: 30
Views: 1887

Re: Problems with my Atari 1040STf

It may be a bad reset switch, or may simply need the capacitors in the reset circuit changing... But he could literally be anything you would need a depth diagnostics doing. Oh so a problem in the reset circuit could maybe give me this kind of problem? Is that circuit used even when I'm not using t...
by Globox
Fri Oct 16, 2020 11:44 am
Forum: HARDWARE ISSUES
Topic: Problems with my Atari 1040STf
Replies: 30
Views: 1887

Re: Problems with my Atari 1040STf

If that happens does it then boot if you press the reset switch ? It booted, and I tried resetting as soon as the graphical glitches started appearing. Resetting the system works and it boots into TOS, but every time I pressed reset, the glitches started to appear faster and faster after the homesc...
by Globox
Thu Oct 15, 2020 9:24 pm
Forum: HARDWARE ISSUES
Topic: Problems with my Atari 1040STf
Replies: 30
Views: 1887

Re: Problems with my Atari 1040STf

I'll just wait for a bit now, and try booting with a gotek installed again to confirm that. Turned it on with a gotek drive and it went to white screen with 2 bombs right away So I turned it off, tried booting without gotek again, and got a black screen, probably waited to long for it to be able to...
by Globox
Thu Oct 15, 2020 8:48 pm
Forum: HARDWARE ISSUES
Topic: Problems with my Atari 1040STf
Replies: 30
Views: 1887

Re: Problems with my Atari 1040STf

I've found that it always boots to tos if I wait an hour in between turning it on, maybe i'll get it to boot 2 times in a row, but then it's back to black screen when I turn it on, until I've left it turned off for a while again. But this makes me think that there's some part that's not able to dis...
by Globox
Thu Oct 15, 2020 8:43 pm
Forum: HARDWARE ISSUES
Topic: Problems with my Atari 1040STf
Replies: 30
Views: 1887

Re: Problems with my Atari 1040STf

I'd think only the first time fixing the pins on the mmu socket really helped me The thing with the gotek probably had nothing to do with my problem, I probably just had to wait a bit longer before trying to boot with the gotek installed... I'll just wait for a bit now, and try booting with a gotek ...
by Globox
Thu Oct 15, 2020 8:33 pm
Forum: HARDWARE ISSUES
Topic: Problems with my Atari 1040STf
Replies: 30
Views: 1887

Re: Problems with my Atari 1040STf

I've found that it always boots to tos if I wait an hour in between turning it on, maybe i'll get it to boot 2 times in a row, but then it's back to black screen when I turn it on, until I've left it turned off for a while again. If that happens does it then boot if you press the reset switch ? Jus...
by Globox
Thu Oct 15, 2020 8:05 pm
Forum: HARDWARE ISSUES
Topic: Problems with my Atari 1040STf
Replies: 30
Views: 1887

Re: Problems with my Atari 1040STf

I've found that it always boots to tos if I wait an hour in between turning it on, maybe i'll get it to boot 2 times in a row, but then it's back to black screen when I turn it on, until I've left it turned off for a while again.
by Globox
Thu Oct 15, 2020 5:37 pm
Forum: HARDWARE ISSUES
Topic: Problems with my Atari 1040STf
Replies: 30
Views: 1887

Re: Problems with my Atari 1040STf

Just carefully inspect the pins & also on the bottom of the MCU chip you notice there are little dimples where the curled pin ends? just grab a flat head screw driver and push the curled pin-end back. It will only push back about 1mm, don't go too far. This will give more spring on the chip pins, I...

Go to advanced search