Search found 10 matches

by ZeroG1972
Wed Mar 18, 2020 4:47 am
Forum: HARDWARE ISSUES
Topic: Atari Mega ST Video Output problem
Replies: 13
Views: 1112

Re: Atari Mega ST Video Output problem

Seems like my (unresolved) issue :

viewtopic.php?f=23&t=2396

Now my screen is always black...
by ZeroG1972
Wed Dec 25, 2019 7:16 pm
Forum: HARDWARE ISSUES
Topic: Atari 1040 STE screen troubleshooting
Replies: 13
Views: 1965

Re: Atari 1040 STE screen troubleshooting

Thank you very much for your help but I think that I will not be able to go further for lack of sufficient skills in electronics and equipment (I only have a multimeter, no scope).

Happy New Year celebrations and thank you again

Thierry
by ZeroG1972
Mon Dec 23, 2019 9:49 am
Forum: HARDWARE ISSUES
Topic: Atari 1040 STE screen troubleshooting
Replies: 13
Views: 1965

Re: Atari 1040 STE screen troubleshooting

So if you disconnect monitor, power up machine for 60 seconds, connect monitor, does the video instantly not work, or take another 30 seconds to malfunction ? Same : after 60 seconds if I power up monitor, the instantly not work But regulator is ok (see ahead). And I don't have tested : removing sh...
by ZeroG1972
Sun Dec 22, 2019 8:48 pm
Forum: HARDWARE ISSUES
Topic: Atari 1040 STE screen troubleshooting
Replies: 13
Views: 1965

Re: Atari 1040 STE screen troubleshooting

tzok wrote:
Sun Dec 22, 2019 7:29 pm
So check 12V line (blue) from PSU...
Sorry for bad indication : after crash I have 12.3 v on PSU blue line and same value on regulator.
And I have made test with an other PSU, it's same problem...
by ZeroG1972
Sun Dec 22, 2019 6:34 pm
Forum: HARDWARE ISSUES
Topic: Atari 1040 STE screen troubleshooting
Replies: 13
Views: 1965

Re: Atari 1040 STE screen troubleshooting

I have used my multimeter and I obtain :

Before troubleshooting : 8,4 v (left) and 12,5 v (right)
After : 8,4 (left) and near zero (right)

I don't understand : 8,4 v after troubleshooting but in datasheet of LM78L82ACZ, it's output value ?

I'm noob in electronic...
by ZeroG1972
Sun Dec 22, 2019 1:05 pm
Forum: HARDWARE ISSUES
Topic: Atari 1040 STE screen troubleshooting
Replies: 13
Views: 1965

Re: Atari 1040 STE screen troubleshooting

Just put your finger on all the main chips.. They pretty much should be still cool after 30 seconds. Also there is a large chip under the PSU.. Take it out, look for damage and clean it. There is a small regulator to the right of the ic. Check voltages both sides before and after the screen goes bl...
by ZeroG1972
Sun Dec 22, 2019 10:47 am
Forum: HARDWARE ISSUES
Topic: Atari 1040 STE screen troubleshooting
Replies: 13
Views: 1965

Re: Atari 1040 STE screen troubleshooting

exxos wrote:
Sun Dec 22, 2019 10:24 am
Are any chips getting hot ? Is the floppy drive unplugged ?
Yes, floppy drive is unplugged, but with floppy, it's same.
I don't know if any chip is hot, it's short (< 30 sec.) between boot and issue.
by ZeroG1972
Sun Dec 22, 2019 9:51 am
Forum: HARDWARE ISSUES
Topic: Atari 1040 STE screen troubleshooting
Replies: 13
Views: 1965

Atari 1040 STE screen troubleshooting

Hello, I recently encountered the following problem with my Atari 1040 STE (TOS 1.62 - CA4003290): 30 seconds after startup, when the desktop was displayed correctly, the image gradually blurs and the screen goes blank and power off. I performed the following tests: changing the SCART cable, changin...
by ZeroG1972
Wed Oct 31, 2018 8:46 pm
Forum: ST
Topic: C070115 REV.2B (520ST 08/1985)
Replies: 7
Views: 3153

Re: C070115 REV.2B (520ST 08/1985)

This one doesn't have the CSYNC patch for non -M versions. Very interesting revision this :) No, it does not have a composite sync. It works well with a monochrome monitor SM124 but not SCART with SC1425: the screen is out of sync. I found an article of ST Magazine (in French) of October 1986 which...
by ZeroG1972
Sun Oct 28, 2018 8:55 pm
Forum: ST
Topic: C070115 REV.2B (520ST 08/1985)
Replies: 7
Views: 3153

C070115 REV.2B (520ST 08/1985)

Atari 520 ST (AZERTY / French Keyboard) without TOS (08/1985)

IMG-20180703-205820.png
IMG-20180703-205820.png (383.57 KiB) Viewed 3152 times
IMG-20180831-200730.jpg
IMG-20180831-200730.jpg (5.07 MiB) Viewed 3152 times
IMG-20180831-200747.jpg
IMG-20180831-200747.jpg (4.55 MiB) Viewed 3152 times

Go to advanced search