Search found 326 matches

by troed
Wed Sep 19, 2018 9:03 am
Forum: 3D MODELS
Topic: Atari ST Parts group on Thingiverse
Replies: 6
Views: 223

Re: Atari ST Parts group on Thingiverse

Screen Shot 2018-09-19 at 10.02.49.png
Screen Shot 2018-09-19 at 10.02.49.png (613.29 KiB) Viewed 15 times
by troed
Wed Sep 19, 2018 8:43 am
Forum: 3D MODELS
Topic: Atari ST Parts group on Thingiverse
Replies: 6
Views: 223

Re: Atari ST Parts group on Thingiverse

So, apparently it's possible to join the group without consent. All the better :) But, I can't seem to find anything pointing to your model. Did you use "+ POST A THING" inside the group and then select one of your own public models? I don't seem to have that option. I did use "Share to group" when...
by troed
Wed Sep 19, 2018 8:28 am
Forum: 3D MODELS
Topic: Atari ST Parts group on Thingiverse
Replies: 6
Views: 223

Re: Atari ST Parts group on Thingiverse

For convenience, we try to maintain the 3D models in this forum on Thingiverse. https://www.thingiverse.com/groups/atari-st-parts/things Just leave a message if you want to become a member, which would allow you to upload models to the Thingiverse group. afaik I've joined the group and then chosed ...
by troed
Wed Sep 19, 2018 7:38 am
Forum: STF REMAKE PROJECT
Topic: A thought for diagnostics
Replies: 2
Views: 65

Re: A thought for diagnostics

Well we've seen bombs. That means, I believe, CPU is working, GLUE is working, MMU is working, Shifter is working.
by troed
Tue Sep 18, 2018 7:20 pm
Forum: ALPHA USER BUILDS
Topic: Icky - Progress
Replies: 35
Views: 431

Re: Icky - Progress

exxos wrote:
Tue Sep 18, 2018 7:18 pm
Icky wrote:
Tue Sep 18, 2018 7:17 pm
Great fun - just been hunting for 2.2k resistors in my parts bins. None to be found time to start desoldering some from that donor ST I have.
4.7K, 10K should be ok as well...
Get a SIL array from the donor - they're 10 or 4.7k
by troed
Tue Sep 18, 2018 7:19 pm
Forum: STF REMAKE PROJECT
Topic: TOS startup sequence.
Replies: 13
Views: 243

Re: TOS startup sequence.

exxos wrote:
Tue Sep 18, 2018 7:17 pm
Would be all zeros for black though wouldn't it ?
No, think palette. Color 0 is white (border color) and color 15 (low res) is black. So, if all bitplanes are 1s the "graphics" is an image of all palette color 15 = black.

Unless I'm not thinking straight. Have a fever.
by troed
Tue Sep 18, 2018 7:16 pm
Forum: STF REMAKE PROJECT
Topic: TOS startup sequence.
Replies: 13
Views: 243

Re: TOS startup sequence.

exxos wrote:
Mon Sep 17, 2018 11:05 pm
It sparked my interest as if 50Hz is being set, but not the palette data (still black screen) what actually goes on in the code between those 2 things ?
Actually a white border and black screen would indicate all 1s being read from RAM, I think.
by troed
Tue Sep 18, 2018 7:14 pm
Forum: STF REMAKE PROJECT
Topic: TOS startup sequence.
Replies: 13
Views: 243

Re: TOS startup sequence.

Alright, here's a cleaned up (TOS 3.x/4.x/STBOOK stuff etc removed - I hope I got the sections right) startup.S from the TOS source code package: _main: /* disable the interrupts */ /* this is useless on cold boot, */ /* but it matters for software reset */ move #$2700,sr reset /* reset all hardware...
by troed
Tue Sep 18, 2018 6:35 pm
Forum: STF REMAKE PROJECT
Topic: ALPHA MODIFICATIONS
Replies: 26
Views: 551

Re: ALPHA MODIFICATIONS

exxos wrote:
Tue Sep 18, 2018 6:32 pm
troed wrote:
Tue Sep 18, 2018 6:29 pm
I'm confused by this being connected to BR.
Its a missing pull up resistor on BR & BGACK.
Yes. But both the pullup fixes are connected to BR, none of them to BGACK :)
by troed
Tue Sep 18, 2018 6:29 pm
Forum: STF REMAKE PROJECT
Topic: ALPHA MODIFICATIONS
Replies: 26
Views: 551

Re: ALPHA MODIFICATIONS

exxos wrote:
Tue Sep 18, 2018 6:23 pm
Bodge resistor 1..... 2.2K between the 2 circled points on back of CPU socket...
I'm confused by this being connected to BR.