Search found 78 matches

by cmorley
Mon Feb 10, 2020 7:38 am
Forum: HARDWARE DISCUSSIONS
Topic: 27C400 EPROM emulators (beta) issue D technical discussion
Replies: 36
Views: 1095

Re: 27C400 EPROM emulators (beta) issue D technical discussion

Good news. Thanks for revisiting that.
by cmorley
Sun Feb 09, 2020 7:49 am
Forum: HARDWARE DISCUSSIONS
Topic: 27C400 EPROM emulators (beta) issue D technical discussion
Replies: 36
Views: 1095

Re: 27C400 EPROM emulators (beta) issue D technical discussion

The LightningST decode is to slow for the eprom emulator. This is surprising. The Emu should be a lot faster than an EPROM ~90ns equivalent worst case with the 70ns FLASH chips and faster still with the 55ns FLASH. So I wouldn't have thought it was an access time thing - some other timing thing. I ...
by cmorley
Sat Feb 08, 2020 7:31 pm
Forum: HARDWARE DISCUSSIONS
Topic: 27C400 EPROM emulators (beta) issue D technical discussion
Replies: 36
Views: 1095

Re: 27C400 EPROM emulators (beta) issue D technical discussion

Image size? [0x]digits[K|M] [2F000] 1. What is "Load word mode? n=normal, h=hi, l=lo" I've already said swap bytes in the binary image? 2. Why "Address=040000,040001" Although the 0x40000 looks like a good start address what is "040001"? 3. I aways get "unrecognized command" 4. If I don't use K|M I...
by cmorley
Sat Feb 08, 2020 11:20 am
Forum: HARDWARE DISCUSSIONS
Topic: 27C400 EPROM emulators (beta) issue D technical discussion
Replies: 36
Views: 1095

Re: 27C400 EPROM emulators (beta) issue D technical discussion

Thumbs up. I don't know the hardware you are using so can't really comment on using it as a boot ROM. You should be able to though. How big are each ROM? If you can get a /CS and /OE which activate for both ROMs, set the module to 27C800 and hook up A18 on the module to the computer (on an appropria...
by cmorley
Thu Feb 06, 2020 8:32 am
Forum: HARDWARE DISCUSSIONS
Topic: 27C400 EPROM emulators (beta) issue D technical discussion
Replies: 36
Views: 1095

Re: 27C400 EPROM emulators (beta) issue D technical discussion

/JEDEC switches to the Commodore Amiga 500 rev3/5 pinout. Solder blob = C'dore, open = JEDEC pinout. A17 is connected to the pad and the pin. A 27C200 has NC on pin 1 so I broke it out to the pad as well. The pads are there to connect to another module or the extra address lines for 27C800 and 27C16...
by cmorley
Wed Feb 05, 2020 7:41 am
Forum: 8 BIT CORNER
Topic: 27C400/27C800 EPROM emulator
Replies: 92
Views: 15342

Re: 27C400/27C800 EPROM emulator

I can't speak for the /CS & /OE on that system. I assume you tied /byte to Vcc. Any of A18, A19 and R which are not connected should be set to pull up in the module's software. The STM32 has open-drain outputs so without pull ups (internal or external) the voltage will be floating.
by cmorley
Tue Feb 04, 2020 9:29 pm
Forum: 8 BIT CORNER
Topic: 27C400/27C800 EPROM emulator
Replies: 92
Views: 15342

Re: 27C400/27C800 EPROM emulator

Do you have anything connected on the ROM switch pin now? If no, are both modules set to pull up on ROM switch? The USB keeps the STM32 powered. Turning off the Amiga the module will see /RST go low and can perform a ROM switch depending on the length of time. Or if the input is floating with no pul...
by cmorley
Tue Feb 04, 2020 7:53 pm
Forum: 8 BIT CORNER
Topic: 27C400/27C800 EPROM emulator
Replies: 92
Views: 15342

Re: 27C400/27C800 EPROM emulator

I will assume you have the hi and low the correct way round. IIRC Chucky's ROM images are already byte swapped. 3 should be OK then. Try setting 3 as the initial ROM image from the options (+ COMMIT) then power the lot off and power the Amiga back on. Then they should be guaranteed to go to image 3 ...
by cmorley
Tue Feb 04, 2020 6:31 pm
Forum: 8 BIT CORNER
Topic: 27C400/27C800 EPROM emulator
Replies: 92
Views: 15342

Re: 27C400/27C800 EPROM emulator

Ok it appears to have flashed ok.. but no boot.. what am i doing wrong.. Command: program & verify 27C160 (2048KB) Go to the options menu "o" and run the preset "wizard" to set them to 27C400. If you've not got a reset/rom switch line hooked up yet, then you'll need to make sure the ROM switch pull...
by cmorley
Mon Feb 03, 2020 7:48 pm
Forum: HARDWARE DISCUSSIONS
Topic: 27C400 EPROM emulators (beta) issue D technical discussion
Replies: 36
Views: 1095

Re: 27C400 EPROM emulators (beta) issue D technical discussion

<edit> I just compared the "rom" contents and it is still 100% equal to what I programmed, so that is not the problem. Will have another go on the A500 board. Maybe it was not properly seated, because it was pretty hard to push it in. Some boards were made with really poor quality single wipe socke...

Go to advanced search