Search found 826 matches

by stephen_usher
Fri Oct 16, 2020 9:30 am
Forum: TF536 ST EDITION
Topic: Is anyone else seeing a huge power fluctuation?
Replies: 7
Views: 122

Re: Is anyone else seeing a huge power fluctuation?

I wouldn't be so worried if the spike wasn't showing up on at least some of the address lines on the ST's own bus.
by stephen_usher
Thu Oct 15, 2020 11:16 pm
Forum: TF536 ST EDITION
Topic: Is anyone else seeing a huge power fluctuation?
Replies: 7
Views: 122

Re: Is anyone else seeing a huge power fluctuation?

Both on the TF then it's a flat 0V, as you would expect. The spike is relative to the PSU and ST ground. The resistance between TF GND and ST GND is 0.2 ohms. P.S. I've cut the +5V trace which goes right across my board and I'm powering that line from a pin right next to the socket. That short (~2 c...
by stephen_usher
Thu Oct 15, 2020 10:27 pm
Forum: TF536 ST EDITION
Topic: Is anyone else seeing a huge power fluctuation?
Replies: 7
Views: 122

Re: Is anyone else seeing a huge power fluctuation?

Nope! Not that, it's back again.
by stephen_usher
Thu Oct 15, 2020 10:20 pm
Forum: TF536 ST EDITION
Topic: Is anyone else seeing a huge power fluctuation?
Replies: 7
Views: 122

Re: Is anyone else seeing a huge power fluctuation?

OK. Found the issue. It was my 10K pull-up on the /RESET line. I removed that and the spike disappeared, at least from the power. There's still a spike on the /RESET line.
by stephen_usher
Thu Oct 15, 2020 9:10 pm
Forum: TF536 ST EDITION
Topic: Is anyone else seeing a huge power fluctuation?
Replies: 7
Views: 122

Is anyone else seeing a huge power fluctuation?

I'm seeing this rather large power and ground spike being generated by the TF536. It's precisely 2us after /IPL2 goes low. IMG_2078.jpg (Both traces have 0V at the same level on the 'scope, the blue is +5V and yellow GND.) I know it's being generated by the TF as if the processor is idle (or if /IPL...
by stephen_usher
Thu Oct 15, 2020 8:39 pm
Forum: TF536 ST EDITION
Topic: TF536 Atari firmware
Replies: 12
Views: 212

Re: TF536 Atari firmware

OK, looking at the signals with an oscilloscope, the ground rail on the TF536 itself is even more noisy than the input. I'm amazed that it's working at all given the number of times I've seen it spike to 3V on GND! I've got the noise on the input ground rail down to <1V so this is being generated on...
by stephen_usher
Thu Oct 15, 2020 4:41 pm
Forum: TF536 ST EDITION
Topic: TF536 Atari firmware
Replies: 12
Views: 212

Re: TF536 Atari firmware

OK. I'll look into it. I may solder a power header on the TF536 so I can give it a stable +5V and GND as otherwise who knows what mayhem the noise might create.
by stephen_usher
Thu Oct 15, 2020 2:19 pm
Forum: MEMBER BLOGS
Topic: Stuff and Things.
Replies: 379
Views: 42275

Re: Stuff and Things.

If I find it I'll just send it to you. No need to think about money, it's sharing between enthusiasts, as it should be.

eBay has made people think that everything has a price (and no-one thinks of the real value any more).
by stephen_usher
Thu Oct 15, 2020 1:57 pm
Forum: TF536 ST EDITION
Topic: TF536 Atari firmware
Replies: 12
Views: 212

Re: TF536 Atari firmware

There's 3.3V from the Pi which is supposed to power the chip for JTAG, but I also tried with the board in the ST and powering it, but that stopped the ST from booting, even when the TF wasn't the selected processor and it didn't help the comms.
by stephen_usher
Thu Oct 15, 2020 12:33 pm
Forum: TF536 ST EDITION
Topic: TF536 Atari firmware
Replies: 12
Views: 212

Re: TF536 Atari firmware

I tried that as root (as pi didn't have permission) and that gave the same error.

Go to advanced search