Page 2 of 2

Re: 030 exxos RTC issues.

Posted: Fri Sep 07, 2018 8:41 am
by exxos
On one users machine, the RESET pin on the NVRAM is always low. On my machine when it is off, its 3.3V, when machine on, 5V. This one machine is 0V all the time. I tried hardwire my RESET pin to 0V, and made no odds to machine booting or corrupt settings. Though it does suggest the module is malfunctioning as there is no output on that pin. The only difference between the user having the machine and myself, is I used a recapped falcon PSU. He is using a Falcon PSU (not recapped). We are currently looking into reset issues, he generally says the machine seems to boot and store settings when the machine is "warm"...

The problem here is the second user has one of my exxos PSU's, has the same problem, BUT I think his metal shielding is shorting the battery out.. still waiting to hear back on that.

The machine I have here on test, plus the NVRAM modules are still working fine. Machine been on for hours, off for hours, had battery changed, settings set and checked.. I just can't find anything wrong here.

Re: 030 exxos RTC issues.

Posted: Thu Sep 13, 2018 9:03 am
by exxos
RTC modules still working fine here. As to why they fail when the user gets hold of the things I have no idea. The guys who I sent replacement modules and a dallas RTC haven't got back to me, so that was a waste of time.

So I will put them back in stock and mention they may need debugging in some machines. There is nothing I can do "my end" as every modules tests fine and even all the machines I have fitted them to work fine.. until the user gets the stuff. I can only assume its something PSU or RESET related, but until someone can actually help debug, or send me a problem machine, there is nothing more I can do.

Re: 030 exxos RTC issues.

Posted: Thu Sep 13, 2018 4:06 pm
by guus.assmann
Some time ago, I've replaced the RTC on a number of Falcons.
With the old RTC they still worked, also after I put a socket in the board.
However, with the new RTC-chip, they wouldn't boot, the chips being new and from Mouser.

To remidy the situation, I put the old RTC back and booted the Falcon with the test-cartridge.
Then, I removed the RTC from the socket and put in the new chip. (Falcon still powered ... )
The test-cartridge can do a RTC-test. So I used that and the chip passed.
After this, the Falcon would boot as it should.

Maybe the modules will work fine after this Test-cartridge RTC-test prior to shipment.


Re: 030 exxos RTC issues.

Posted: Thu Sep 13, 2018 4:21 pm
by exxos
What I do my end doesn't really matter though, I don't ship with battery, (to many rules and regulations and paperwork for lion batteries).

With new dallas chips you have to reset them with the key combo, or if lucky it boots so can use the nvram reset program and set.

So it's not a case of reset type issue with the module, which I believe you are seeing.

The problems which appearing are settings not being either written or read on power up. I found this fix before...viewtopic.php?f=10&t=37#p2479

Settings were actually being written, but not read on power up. I can only think that the Falcon reset circuit is not allowing the RTC time the reset before it tries to read contents.

But of course all the motherboards I have done but never failed while I have had them here. As soon as the users get them they seem to have nothing but trouble. But until someone is able to do some debugging or send me such motherboard to diagnose, there is nothing I can do about this problem.

I think its likely something the user is doing either blowing them up for plugging them in backwards or generally messing about with them in ways they shouldn't be or something. I really don't know.

Re: 030 exxos RTC issues.

Posted: Sat Sep 15, 2018 9:14 am
by exxos
One chap got back to me.. long story short, the socket seems bad, it wasn't the socket I sell in my store, so evil sockets strike again it seems. Thinking about it, there have been a few people buying the RTC without a socket from my store. The ones I sell are not cheap china knock-offs. Of course I've had epics of problems with sockets, so it could just be as simple as that..

So I am concluding there are no RTC issues known so far. Nothing has failed with the modules during all my testing. So has to be something "user end" which is causing issues.

Re: 030 exxos RTC issues.

Posted: Sun May 12, 2019 10:01 pm
by displaced
Apologies for necro’ing an old thread (it’s not *that* old - still warm?)

I’m using one of your Falcon RTCs, bought around the time of this thread, and had these exact symptoms.

It’d work fine out on the bench, and even after reassembling the machine. But then after a few reboots, I’d get the dreaded low-res Atari logo on my VGA monitor and, lo and behold, it’d behave like the NVRAM had been reset to default, or fail to boot at all. But a few more warm resets and it’d be back to normal. I was also seeing weird click drift - like losing several minutes an hour.

It was an obvious fix. I’d put electrical tape on the shielding where it might touch the RTC board. But, I noticed that the shielding had pushed down on the front edge of the RTC board. That force had lifted the back edge of the board ever so slightly out of the socket. Would never have thought it’d be enough to cause a problem, but given what I’ve read about the Falcon’s noise and electrical issues, I suppose it was enough.

With the machine disassembled, pushing the RTC back in place fixed the issue.

So I just removed the socket and soldered the RTC direct. Works a treat.

Re: 030 exxos RTC issues.

Posted: Sun May 12, 2019 10:16 pm
by exxos
Thanks for letting us know.

I think a lot of the problems people have are that the shielding is shorting out the battery. I have had a lot of machines here over the past couple years fitting this module, but I only deal with the motherboard itself as a rule, but as soon as people start assembling machine back together, they start having problems. Though trying to communicate and debug issues with people has been pretty much impossible :roll:

Aside from that, the sockets themselves have to be of good quality, I generally hate sockets as a rule as they are just constantly trouble.

What was unknown originally as well, is some of the RTC software seems to actually disabled the board, as the software is designed for a different version of the RTC chip. Though I have since updated the download thread with more information towards this.

There are of course a magnitude of issues where people destroy tracks while removing the old RTC. The amount of repairs I have done the people who have done just that is unbelievable. I will frankly never understand why people who must know they are not good at soldering, risk damaging a £1,000 machine.

There are of course issues where some falcons have bad power supplies, or random screwy issues, although such issues I have no idea about.. Some falcons do not even work with the original type of RTC replaced either. Its just generally why I have grown to hate a lot of Atari machines lately, as every machine has its own screwy faults which are never easy to debug.

Re: 030 exxos RTC issues.

Posted: Sat Jun 15, 2019 10:49 pm
by T'PAU
I recently soldered in the exxos RTC without socket, isolated the shielding in that area with two layers of duct-tape (so a quite thin isolation) and still got a little print in the tape from the lower edge of the plus-spring of the battery-holder! :o
It surely will get shorted without that tape. And as said, this is without a socket!

So don't even think of using a socket without planning to cut out the shielding or at least heavily bend it in that area.
Although it works, I will slightly bend the shielding there before I finally re-assemble my Falcon again.

Re: 030 exxos RTC issues.

Posted: Sun Jun 16, 2019 12:17 pm
by exxos
I do say in my store to use thick card (not tape) though most people I think either just leave the shielding off or some put a couple of washers under the front to lift it up a bit. If I decided to do a new batch then I may move the battery further backwards.