How to get TOS to see the 1.44MB drives

Update your old 720k to a 1.44 drive etc.
guus.assmann
Posts: 58
Joined: Sat Sep 23, 2017 8:52 pm
Location: Ede Netherlands

Re: How to get TOS to see the 1.44MB drives

Post by guus.assmann » Tue Nov 07, 2017 8:44 am

Hello Exxos,

About the disk drives, I have 4 pieces SMD380, 2 have a switch and 3 don't.
And I also have an SMD 300 (From a Falcon) that has a switch.
So far I've checked the ones with the switch. They all have the controller : SF9200-K on them.
The PCB on the SMD300 is different from the other 2 I've seen. A pity. (This has a sticker next to the connector with SMD340 on it as well)
On the SMD380 units there's a jumper JP04. One side is connecter to pin 2 of the connector.
The other side is connected to pin 74 of the controller IC.
I will investigate the other 2 as well, when I have some time.

Question: Does anyone have the data sheet for the SF9200-K?
I can't find it with Google.

BR/
Guus

guus.assmann
Posts: 58
Joined: Sat Sep 23, 2017 8:52 pm
Location: Ede Netherlands

Re: How to get TOS to see the 1.44MB drives

Post by guus.assmann » Sun Nov 12, 2017 8:40 pm

Hello,
Today I've spent some time with the floppy drives again.
My subjects were 2 Teac FT235 drives, 1,44Mb capable on a PC.
After changing the device ID to 0, they worked in 720k mode.
After some checking, I found that connecting S7 does the trick, I get an output on pin 2.
To make the HD module switch correctly, I had to use an inverter. (This is present on the STE board.)
The only thing was that a 720k disk gave a too high voltage on pin 2. (About 1,6V)
So I soldered a 9k2 resistor between pin 1 and 2. (Now I had 1,0V bearly ok but it worked.)
Now the drive works like a charm, in both densities.
So far, so good.
I decided to assemble the STE and of course put the drive in place.
Still ok, the unit works. :)
Now put the top cover in place. And test again. Floppy doesn't work anymore. :o
Same happend to the 2nd drive.
And I don't understand. :oops: :evil:
Before assembly, I formatted a couple of disks and had no problems.

Any ideas on what may have gone wrong? :?:

BR/
Guus

User avatar
exxos
Site Admin
Posts: 2887
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: How to get TOS to see the 1.44MB drives

Post by exxos » Sun Nov 12, 2017 9:27 pm

Output on pin 2 of what ? The ST knows nothing about density selects on those signals. I would hardware the floppy modules select line to 5V or 0V and try floppies that way. I don't get why you are needing resistors, you should have 5V and 0v, depend on density select switch position on the drive. If anything, you need a pull up to 5V if the switch does not pull up enough on its own.

A pull up sil array on the DMA databus may help..

I went through all sorts of this chaos 20 years ago, I don't remember much, but I know I just had endless issues with various drives. Its why I went with the MPF series and never went back to any others. I think I got one FT235 to try, supposed to be great at error correction etc, cost a lot when new, remember it hardly ever worked. I didn't spend much time working out why as I tested a lot of drives out at the time.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply