Floppy corrupted when used on ST and PC won't read it ?

Atari talk, or the life and the universe and things. Just keep it clean!
User avatar
exxos
Site Admin
Site Admin
Posts: 7425
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Floppy corrupted when used on ST and PC won't read it ?

Post by exxos » Tue Jun 25, 2019 11:53 am

So I format a 720K floppy on the PC. Copy a PRG to it. Put the floppy in my ST, I can read and load PRG fine...

If I save desktop to floppy, and then put the disk back in the PC, it refuses to read it again... ???

Does TOS104 "corrupt" the floppy when saving files to make it not work on PC anymore ?

I assume it must do, and maybe TOS206 is more DOS friendly ?!
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

stephen_usher
Posts: 312
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: Floppy corrupted when used on ST and PC won't read it ?

Post by stephen_usher » Tue Jun 25, 2019 1:48 pm

From what I remember the original TOS FAT12 is incompatible with MSDOS's version in subtle ways. One is the unique floppy ID, whichisn't unique on the ST. I thought that TOS 1.4 had fixed most of the original issues though.

Are you sure it's not a head alignment problem? i.e. one drive is at one edge of the accesptable limit and the other at the orther, taking them out of their respective limits.
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
exxos
Site Admin
Site Admin
Posts: 7425
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Floppy corrupted when used on ST and PC won't read it ?

Post by exxos » Tue Jun 25, 2019 2:10 pm

Both drives are new MPF920s in the PC and ST in fact. I did even swap them around a few weeks ago with other new drives and didn't change anything.

Its just nuts, I can copy loads of files over from the PC.. they all run fine on the ST.. .save a file on the ST , and PC won't read the disk again, I have to format it and start again.. its getting a bit annoying :roll:

I guess I could do some sectors views on the floppy to see what changes, but I don't want to get side-tracked onto something else again :roll:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

tzok
Posts: 125
Joined: Sat Dec 30, 2017 2:27 pm

Re: Floppy corrupted when used on ST and PC won't read it ?

Post by tzok » Tue Jun 25, 2019 11:12 pm

Was it a true DD floppy or a HD floppy formatted to 720kB? With the latter ones, I had the same problem.

User avatar
exxos
Site Admin
Site Admin
Posts: 7425
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Floppy corrupted when used on ST and PC won't read it ?

Post by exxos » Wed Jun 26, 2019 12:01 am

Proper 720k formated as 720k on PC.

. I'll try a 1.44 tomorrow.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7425
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Floppy corrupted when used on ST and PC won't read it ?

Post by exxos » Wed Jun 26, 2019 9:25 am

Quick test of a 1.44 and the PC read the disk after saving desktop on the ST... very strange.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

tzok
Posts: 125
Joined: Sat Dec 30, 2017 2:27 pm

Re: Floppy corrupted when used on ST and PC won't read it ?

Post by tzok » Wed Jun 26, 2019 2:29 pm

So exactly opposite to my issue, but somehow expected - I was using a true DD drive in Atari and a DD formatted HD diskette together with a HD drive in PC. It is not as bad as with 5,25" disks, but HD drives dislike DD disks and opposite way around too. It works when formatted, saved and read in the same drive, but slight timing differences between systems seem to corrupt such cross-formatted disks.

User avatar
exxos
Site Admin
Site Admin
Posts: 7425
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Floppy corrupted when used on ST and PC won't read it ?

Post by exxos » Wed Jun 26, 2019 3:09 pm

Makes me wonder if the 8mhz clock being more like 8.2mhz is enough to screw up the floppy.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7425
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Floppy corrupted when used on ST and PC won't read it ?

Post by exxos » Wed Jun 26, 2019 9:17 pm

Only just got home, but changed my HD GAL to generate 8MHz from the onboard 16MHz OSC.. Though 720K is still acting up :(

Possible the floppies could be bad (but all of them ?) Or the drives simply don't like 720K much. :shrug:

I will try and do a sector dump and see if anything changes in the floppy ident next...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7425
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Floppy corrupted when used on ST and PC won't read it ?

Post by exxos » Wed Jun 26, 2019 9:32 pm

I had to use floimg to read the floppy on the PC.. image on left is the floppy after writing desktop.inf on the ST... image on the right is right after formatting it on the PC...

So basically, no change.... but the PC can't read it again :roll:

2.jpg
2.jpg (358.49 KiB) Viewed 298 times

EDIT:

Just for the hell of it, I wrote the .ST file back to floppy.. now the PC can read it.. but desktop.inf isn't there... but it shows on the ST :stars:

EDIT2:

Now its showing up on the PC :WTF:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply