Speccy repair

Atari talk, or the life and the universe and things. Just keep it clean!
User avatar
IngoQ
Posts: 475
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Speccy repair

Post by IngoQ » Thu Jan 11, 2018 3:24 pm

I have recently bought a non working ZX Spectrum 128 (toast rack) and I am struggling with the repair since. Maybe someone here has repair experience with these and has some ideas how to proceed...

It was pretty much dead when it arrived, but after changing the 5V regulator and TR4/TR5 it showed some life signs. To be safe I swapped all electrolytic capacitors as well.

From the symptoms it looked like some RAM chips were gone, to help in locating these I used the diagnostic ROM by Retroleum. It signaled a couple of malicious RAMs and I swapped them as well. It all worked well until I came to IC10 that should be responsible for Bit 3. I swapped it and nothing changed. On every test cycle I run it always shows this IC as faulty. Of course I swapped with (several) other chips, double checked the soldering even swapped the socket again just to be sure.

I checked continuity on the adress lines and looked at the data line, it all looks okay to me. Voltages are fine as well.

Two additional strange things:

1. Upper Ram tests completely fine.
2. a different diagnostic ROM shows bits 7,6,5,4 faulty... WTF?

The screen is garbled and barely readable, sound output looks fine. The ROM reacts as it should, but nevertheless I swapped the CPU, just to be safe. No change.

Right now I have swapped and socketed all RAM chips, the CPU and the ROM. All caps are replaced, as well as TR4, TR5 and the 7805.

What puzzles me, is that upper RAM works fine, only lower RAM seems to be faulty. When I look at the schematic, data busses are identical, so these are most likely not the fault. Has to be addressing then, and there seem to be two chips involved: the ZX8401 multiplexer and the ULA.

Both are hard to come by, so I hesitate to simply swap them without being sure.

So if anyone here has some ideas about this, it would be a great help :)
Ingo :geek:

“Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.” - Antoine de Saint-Exupéry

User avatar
exxos
Site Admin
Posts: 2035
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Speccy repair

Post by exxos » Thu Jan 11, 2018 3:26 pm

All I can suggest is contacting Gadget UK... He does the hell of a lot of retro computer repairs.. So is probably the best person to ask about this sort of thing..

https://www.youtube.com/user/GadgetUK164/videos

I did mention this forum to a while ago in fact..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
IngoQ
Posts: 475
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Re: Speccy repair

Post by IngoQ » Thu Jan 11, 2018 3:31 pm

Thanks, I know his videos, although I sometimes struggle in understanding him ;)
Ingo :geek:

“Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.” - Antoine de Saint-Exupéry

stephen_usher
Posts: 35
Joined: Mon Nov 13, 2017 7:19 pm

Re: Speccy repair

Post by stephen_usher » Thu Jan 11, 2018 9:34 pm

If you're going to send it away definitely use Mutant Catapillar:
http://www.mutant-caterpillar.co.uk/sho ... ts_id=3481

As for the problem, check all the resistors! I had a similar problem with my +128K and one of the problems was a resistor which looked OK but crumbled as soon as it was touched.

User avatar
IngoQ
Posts: 475
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Re: Speccy repair

Post by IngoQ » Fri Jan 12, 2018 11:56 am

Thanks Stephen, I took your post as a challenge to recheck the mainboard very carefully for undiscovered faults.

When doing this I re-checked the address lines, and what can I say... found a nicked trace on A0 well hidden under a ceramic cap, separating IC10,11,12 and 13.

Lesson learned: Sometimes continuity check can be be wrong... supposedly when there is still charge in some caps :roll:

Now let's see why the AY is silent...
Ingo :geek:

“Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.” - Antoine de Saint-Exupéry

User avatar
IngoQ
Posts: 475
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Re: Speccy repair

Post by IngoQ » Sun Jan 21, 2018 12:33 pm

Finally working :) AY was okay, just very weak. Applied a stereo upgrade with better mixing and separate output and now it sounds fine :)

And here it is in all its glory:
speccy1.jpg
speccy1.jpg (280.04 KiB) Viewed 326 times
speccy2.jpg
speccy2.jpg (478 KiB) Viewed 326 times
Ingo :geek:

“Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.” - Antoine de Saint-Exupéry

User avatar
exxos
Site Admin
Posts: 2035
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Speccy repair

Post by exxos » Sun Jan 21, 2018 12:43 pm

Nice :) A friend when I was at school had a speccy.. Remember playing "heart broken" a lot back then.. think it was the only game I could get to load :lol:

Might have played bombjack as well, though ST version was better ;)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
DrF
Posts: 208
Joined: Thu Aug 17, 2017 1:18 pm

Re: Speccy repair

Post by DrF » Sun Jan 21, 2018 9:08 pm

A proper Spectrum game :

https://en.wikipedia.org/wiki/Chaos:_Th ... of_Wizards

Absolutely blew our little minds spent hours on it, our copy was off a cover tape, I recall something about Ninja Hamsters too.
We had Amiga/ST versions which I think we're unofficial and well crap :lol:

User avatar
IngoQ
Posts: 475
Joined: Tue Aug 22, 2017 8:38 am
Location: Germany

Re: Speccy repair

Post by IngoQ » Mon Jan 22, 2018 9:13 am

Thanks :)
exxos wrote:
Sun Jan 21, 2018 12:43 pm
A friend when I was at school had a speccy
Speccys were not that common here in Germany, this was pretty much C64-land back then. There were some although, but obtaining one now is not easy. Especially the toast rack, which was the last model made by Sinclair, before Amstrad took over is usually only available in GB, and quite pricey. So I am glad I finally got one, even if I had to repair it.

Same thing with the Acorn 3010/3020 which is still on my wishlist: Almost none available here in Germany, and only rarely available in GB. Most likely due to the onboard-battery. And they are pricey. And for some reason shipping costs from UK to Germany are quite hefty, which makes buying in UK often not that attractive... but that might as well be a question of how desperate I get ;)
DrF wrote:
Sun Jan 21, 2018 9:08 pm
A proper Spectrum game :
https://en.wikipedia.org/wiki/Chaos:_Th ... of_Wizards
Absolutely blew our little minds spent hours on it
Thanks, I still have to discover the Speccys software-world. I just had a glimpse at some things that were on the DivMMC. The graphics abilities were a lot weaker compared to other 8-Bit machines of that time, but that is part of the charm of that device and I really like it.

Interestingly the ZX Spectrum 128 shares one detail with the STs: It has the same soundchip (AY-3-8910) ;)
Ingo :geek:

“Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.” - Antoine de Saint-Exupéry

User avatar
exxos
Site Admin
Posts: 2035
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Speccy repair

Post by exxos » Mon Jan 22, 2018 11:02 am

IngoQ wrote:
Mon Jan 22, 2018 9:13 am
And for some reason shipping costs from UK to Germany are quite hefty, which makes buying in UK often not that attractive... but that might as well be a question of how desperate I get ;)
Yeah, once you get over 2KG now, prices shoot up from like £15 to £60 :roll:


IngoQ wrote:
Mon Jan 22, 2018 9:13 am
Interestingly the ZX Spectrum 128 shares one detail with the STs: It has the same soundchip (AY-3-8910) ;)
Nice :) A lot of the motherboards I repaired in my old job used to be Z80 based, most had the same sound chip as well.

If you ever see/look at older fruit machines, you can hear the sounds the reels make when spinning.. they sound "ST like" basically because they are and use the same sound chip :)

Hard to exactly remember, but if you google "maygay m1b board" or "project board pc92" then you get the idea of the stuff I used to work on :)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply