Spectre GCR "fun"

Atari talk, or the life and the universe and things. Just keep it clean!
Post Reply
stephen_usher
Posts: 95
Joined: Mon Nov 13, 2017 7:19 pm

Spectre GCR "fun"

Post by stephen_usher » Sat Jul 07, 2018 1:29 am

Seeing as I got the STE down to test a couple of games for people on here I also got the Spectre GCR cartridge down.

I've not tried to use it since the early 90s on my slightly upgraded 520STM (2.5MB RAM) with a Third Coast Technologies 27MB hard disk. Well, the hard disk died long ago (but not the case and ICD Advantage Plus host adapter).

Anyway, it still works, though I'm going to have to find another floppy cable as the original is temperamental to say the least. I've another couple up stairs so it's not a problem.

So, I boot into Mac mode and put into the drive what I thought was my Spectre format MacOS System 6 System Disk... but it won't boot. I then try the GCR encoded one... still no go. All very strange.

After a couple of hours trying everything I accidentally open the drive with the "Spectre" system disk in the drive and... a window opens with Atari files in it.

It seems that I reformatted all my Mac system disks in antiquity! *SOB*

Post Reply