Quick hello from Croatia

New user? Tell us about yourself!
Post Reply
StealthGunner385
Posts: 6
Joined: Tue Jul 13, 2021 7:35 am

Quick hello from Croatia

Post by StealthGunner385 » Tue Jul 13, 2021 7:54 am

Hi, everyone, I've been lurking around the forums for a while, but I've just decided to join up after ordering an H5 C1.

I actually became an Atari owner by accident! Two years ago, a coworker of mine went digging through the attic and found an old 1040STF his dad used for music production. He wasn't sure if it worked, so he handed it off to me due to my ongoing collection of 80s computers (all of the non-Atari variety, up to that point).

The board was DOA - it just showed a glittering checkerboard pattern on boot, and no amount of cleaning the sockets and the like helped.
A local computer repair shop owner invited me to bring it over for a repair, as he had owned and modded his own 520ST back in the day.
Sadly, his diagnostic came up with a delaminated motherboard - he could get the machine to boot by flexing the motherboard, but that wasn't doing it any favors. The machine remained broken, yet still contained in the casing.

Now that I finally caught the "train" to a replacement STF motherboard, I look forward to actually using it for music production (I have a few MIDI gadgets laying around). All I need to do now is figure out which BOM parts I'm missing and get those from the shop as well.

Definitely looking forward to posting more here, possibly even the build process. :mrgreen:

User avatar
PhilC
Moderator
Moderator
Posts: 4237
Joined: Fri Mar 23, 2018 8:22 pm

Re: Quick hello from Croatia

Post by PhilC » Tue Jul 13, 2021 7:59 am

:welcomewave:
If it ain't broke, test it to Destruction.

User avatar
JezC
Posts: 1144
Joined: Mon Aug 28, 2017 11:44 pm

Re: Quick hello from Croatia

Post by JezC » Tue Jul 13, 2021 8:04 am

:swave:

Welcome to the forum!

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 4143
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Quick hello from Croatia

Post by rubber_jonnie » Tue Jul 13, 2021 9:10 am

:welcomewave:

Sounds like the H5 will be the ideal replacement for the dead mainboard :)

It is possible that the board is either delaminated or there is damage to one or more VIAs due to board flex (I had this with a Mega), however the PLCC sockets are often in need of adjustment as I described here: viewtopic.php?f=17&t=1484&hilit=plcc

Whilst you're building the H5 you could have a look at tweaking the sockets to see if it makes a difference until you are in a position to to swap the parts over, as it's be nice to see if it runs. What you've described does seem like memory, but it could be a bad connection at the MMU, or a bad MMU. If it's RAM, well that isn't much of an issue as you won't be using it in the H5.

As for damaged VIAs, this can be fixed using bodge wires to recreate the damaged path(s), but finding the problem to fix it would likely be pretty time consuming.

Good luck with the build :)
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

stephen_usher
Posts: 1879
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: Quick hello from Croatia

Post by stephen_usher » Tue Jul 13, 2021 9:42 am

:welcomewave:
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

StealthGunner385
Posts: 6
Joined: Tue Jul 13, 2021 7:35 am

Re: Quick hello from Croatia

Post by StealthGunner385 » Tue Jul 13, 2021 11:23 am

Thank you all for the warm welcome. Good to see a thriving community here. :D
rubber_jonnie wrote:
Tue Jul 13, 2021 9:10 am
:welcomewave:

...

Good luck with the build :)
Thanks for the suggestions about the donor board. The EE who took it into the shop tried everything from recapping (one of the PSU caps was noticeably bulging, as were some of the caps on the board itself) to resoldering sockets - I believe he even tried reflowing the board, but it only brought up marginal improvements. The board would sometimes boot into TOS, but it couldn't be kept flexed just the right way forever.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 4143
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Quick hello from Croatia

Post by rubber_jonnie » Tue Jul 13, 2021 11:44 am

@StealthGunner385

I plugged an adapter into my Mega 4 Megabus socket and it just stopped working, and 2 data lines had got broken, fractured VIAs I believe. It was an easy fix, but really shows how fragile boards are getting now.

Unfortunately the older these boards get, the easier they are to damage, so it's great the H5 and it's earlier relations (I have a built H4 and 2 H4 boards to build) have come along.

Not only do they improve things electrically, but they also give us some of the options sadly missing on the originals.

BTW, you know it's obligatory to post build photos so we can see how you're getting on :)
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

Post Reply

Return to “INTRODUCE YOURSELF”