Hello from the Pacific Northwest!

New user? Tell us about yourself!
Post Reply
robdaemon
Posts: 3
Joined: Thu Jul 05, 2018 6:39 pm

Hello from the Pacific Northwest!

Post by robdaemon » Thu Jul 05, 2018 6:48 pm

Hi all,

I'm Rob, and I'm a few miles west of Seattle in the Pacific Northwest of the US.

I was a Atari 800XL user back in the 80s but never got into the ST world until recently - everyone I knew went to Amigas. Been working on upgrading / refurbishing my 1040STe and Mega ST 2 lately. The STe is in a pretty good state, or will be even better once I get the Exxos PSU in it.

The Mega ST 2 is not as good... The Wizztronics 2.06 upgrade I attempted didn't go so well. Maybe one of the Mega ST Booster v2.2 kits is in my future for that machine!

User avatar
exxos
Site Admin
Site Admin
Posts: 4572
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Hello from the Pacific Northwest!

Post by exxos » Thu Jul 05, 2018 6:58 pm

:welcomewave:

Feel free to open a topic in the blog of your upgrade progress, always good to see stuff coming together :)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply