Page 4 of 4

Re: Maximum 520STfm TOS version Etc

Posted: Thu Aug 15, 2019 11:04 pm
by AtariFox
good news, it works, loads up 1.04 without issue, although there seems to be something strange with the floppy disk. It'll stop refreshing the disks i put in, and doesnt check for new disks, also the little orange light is flashing rapidly at super low brightness.

Re: Maximum 520STfm TOS version Etc

Posted: Thu Aug 15, 2019 11:13 pm
by exxos
AtariFox wrote:
Thu Aug 15, 2019 11:04 pm
good news, it works, loads up 1.04 without issue, although there seems to be something strange with the floppy disk. It'll stop refreshing the disks i put in, and doesnt check for new disks, also the little orange light is flashing rapidly at super low brightness.
The light flashing is normal. AFAIK all tos versions do that.

As for refresh, you should always press ESC to refresh the floppy contents. Media change has always been buggy . I added a fix onto my 1.44 floppy kit to help with just that. But when you change a floppy, its just good practice to press ESC to refresh it. In fact it should be less buggy with 104 than other for versions. Then flashing floppy light is TOS polling then drive to see if a disk has changed. Even the floppy drive itself could be a cause.

I hardly used tos1 or 102, but I half recall pressing ESC didn't even refresh the disk. Are you sure your for board is set to 104 ? If you see a animated rainbow in desktop info then its 104. If its black, its 102.

Re: Maximum 520STfm TOS version Etc

Posted: Thu Aug 15, 2019 11:23 pm
by AtariFox
I dont have a colour monitor, but im pretty sure this is running in 1.04 mode, as sys-info says it is.
but yeah, even ESC doesnt work checking to refresh the disk contents, oh well.

Re: Maximum 520STfm TOS version Etc

Posted: Thu Aug 15, 2019 11:37 pm
by exxos
Can't really comment on that issue, I've never had any issues with 104.

Re: Maximum 520STfm TOS version Etc

Posted: Thu Aug 15, 2019 11:40 pm
by exxos
I would suggest you do this mod. viewtopic.php?f=12&t=428

Re: Maximum 520STfm TOS version Etc

Posted: Fri Aug 16, 2019 12:44 am
by AtariFox
exxos wrote:
Thu Aug 15, 2019 11:40 pm
I would suggest you do this mod. viewtopic.php?f=12&t=428
I'll keep that in mind for future reference.
Thank you for your help!

Re: Maximum 520STfm TOS version Etc

Posted: Fri Aug 16, 2019 8:49 am
by rubber_jonnie
Did the floppy drive work before the TOS upgrade?

Also worthwhile rechecking the data cable to the FDD in case it was disturbed during the ROM swap.

I have seen these cables appear to be plugged in, yet only have one row of pins actually plugged in.

Do you have another FDD you can test with?

Re: Maximum 520STfm TOS version Etc

Posted: Sat Aug 17, 2019 6:24 am
by AtariFox
rubber_jonnie wrote:
Fri Aug 16, 2019 8:49 am
Did the floppy drive work before the TOS upgrade?

Also worthwhile rechecking the data cable to the FDD in case it was disturbed during the ROM swap.

I have seen these cables appear to be plugged in, yet only have one row of pins actually plugged in.

Do you have another FDD you can test with?

Yeah the floppy works fine. It formats and reads floppys.
Just does'nt refresh or something for some reason. I never knew about the esc to refresh before i changed the two rom chips, so i don't know, it works fine however, since it'll boot from the language disk no problems and read other atari disks like cubuse. I've not really got any other actuall atari disks.

I have a bunch of DSDD 720k disks and such. It'll just go "cant read disk or such" if its not the right format. It is a 720k drive.

Didnt 1.04 give support for standard windows FAT?

Re: Maximum 520STfm TOS version Etc

Posted: Sat Aug 17, 2019 9:49 am
by exxos
Floppies formated on the PC will work on 104. I swap them all the time while testing stuff out.