Tos 2.06 mod, startup delay begone.

Upgrade or replace the ROM.
Post Reply
guus.assmann
Posts: 60
Joined: Sat Sep 23, 2017 8:52 pm
Location: Ede Netherlands

Tos 2.06 mod, startup delay begone.

Post by guus.assmann » Sun Dec 10, 2017 3:20 pm

Hello,

Once uppon a time, I saw some notes on how to get rid of the startup delay in Tos 2.06.
I mean the delay that's needed for a HD to spinn up.
As I'm using Ultrasatan or a CF-card as a drive replacement, this delay is not needed and it annoys me.
And now, I'd like to find this again.
But it keeps eluding me.
Any help is appreciated.

BR/
Guus

Bikerbob
Posts: 62
Joined: Fri Nov 10, 2017 7:30 pm

Re: Tos 2.06 mod, startup delay begone.

Post by Bikerbob » Sun Dec 10, 2017 4:43 pm

only mod I know is the space bar.. ;) sorry no help there. I too find it annoying though, as I have been servicing the machines the last few weeks so off and on many times,

James

User avatar
exxos
Site Admin
Site Admin
Posts: 4542
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Tos 2.06 mod, startup delay begone.

Post by exxos » Sun Dec 10, 2017 7:41 pm

Only person who may know is pepra I think..

Other than bashing space bar as said already, the only other way would be to patch TOS. At least as far as I am aware..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

troed
Trusted Guru
Trusted Guru
Posts: 448
Joined: Mon Aug 21, 2017 10:27 pm

Re: Tos 2.06 mod, startup delay begone.

Post by troed » Sun Dec 10, 2017 9:09 pm

Boot from a disk with Atari's noroach: http://vezz.it/atari/auto/noroach.zip

/Troed

Petari
Software Moderator
Software Moderator
Posts: 560
Joined: Tue Nov 28, 2017 1:32 pm

Re: Tos 2.06 mod, startup delay begone.

Post by Petari » Tue Dec 12, 2017 8:38 am

Yep, I did some simple patch what skips those delays after booting TOS 2.06.
If someone needs it, let me know - I need to dig it out.
There is 2 kind of people: one thinking about moving to Mars after here becomes too bad, the others thinking about how to keep this planet habitable.

guus.assmann
Posts: 60
Joined: Sat Sep 23, 2017 8:52 pm
Location: Ede Netherlands

Re: Tos 2.06 mod, startup delay begone.

Post by guus.assmann » Tue Dec 12, 2017 5:51 pm

Hello Petari,

I would really like to have that, as a patch in the Tos. (I have a flashable Tos anyway, so it's convenient to get that in.)
So please, it you can find it, It would make me happy.
Thanks in advance.

BR/
Guus

Post Reply