Page 1 of 1

Strange TOS 1.04 Issue

Posted: Mon May 07, 2018 4:08 pm
by graz
I have been trying to upgrade my 520ST from TOS 1.02 to 1.04. It had six NEC D27256D EPROMs in it containing the old TOS and were working fine. I erased said EPROMs in a real EPROM eraser (none of this leaving them in the sun business) and then programmed them with a QG-4X programmer which I've used many times before. Of course, I did a blank check before, double write, and verify after.

I got the image from http://www.avtandil.narod.ru/tose.html, "TOS 1.04 - Rainbow TOS" as the American 192K image. That image works fine in Steem. I split it into 3 64K chunks using WinHex, then split those chunks into even/odd pairs, giving 6 files in total - L0, L1, L2, H0, H1, H2. Burned those to the EPROMs, read them back and verified. All is good.

I stuck those ROMs into the system - no booting. On composite, I see green and purple junk all over the screen. No bombs. No reboots. Nothing.

So then I tried using ROMSPLIT on an emulated ST inside Steem to re-split the ROMs. Those produced identical content to the files I produced with WinHex. Further, when loading into the files produced with ROMSPLIT the programmer and then re-verifying the content of the ROMs I burned, the results are identical.

Testing the ST with Atari Diagnostic Cart 4.4 (containing similar EPROMs burned with the same programmer and working fine) shows TOS 1.4 USA NTSC. OS ROM checksum test fails with CRC error on L2/H2 and CS error on H0/L0. The machine otherwise passes all tests.

So... the ROMS seem to have bad data and indeed, don't run. However, they're identical to the images online, which work in Steem, and produced by splitting both with WinHex and ROMSPLIT. EPROMs are burned and tested good, and these exact chips were working in this machine with an earlier TOS version. But the machine doesn't even get as far as bombing when they're installed, even though the Diagnostic cart runs fine.

Any ideas? I'm lost.

Re: Strange TOS 1.04 Issue

Posted: Mon May 07, 2018 4:15 pm
by exxos
Can you post the ROM files you are trying and I will take a look at them..

Re: Strange TOS 1.04 Issue

Posted: Mon May 07, 2018 4:31 pm
by graz
Attached. TOS104US.{LO0/LO1/LO2/HI0/HI1/HI2}. Original 192K image from tos104us.zip from the above site. Those ones were split with ROMSPLIT on Steem and verified as identical to the burned ROMs.

Re: Strange TOS 1.04 Issue

Posted: Mon May 07, 2018 4:40 pm
by exxos
The files are correct..

I would check you have not got a bent pin, as it can happen easily without noticing.. Also clean the pins on the chips with IPA.

Is possible the PSU could be failing so if you can power the board from a benchtop PSU and it will help to rule that out..

Speed and brand of ROM can also be a factor. Texas ROMs for some reason are terrible , I do not know why.. But I generally stick to ST brand 120,150,100ns types.

Re: Strange TOS 1.04 Issue

Posted: Mon May 07, 2018 4:47 pm
by Petari
Most likely EPROMs are not good (fast) enough for ST . Programmer reads them with much less speed.

Re: Strange TOS 1.04 Issue

Posted: Mon May 07, 2018 4:48 pm
by frank.lukas
I think the Atari Diagnostic Cart need the TOS 1.04 in two Chips ...

Re: Strange TOS 1.04 Issue

Posted: Mon May 07, 2018 5:22 pm
by graz
Thanks to everyone for the suggestions.

As I said, those EPROMs were in the machine when I got it and worked with the older TOS. I have to assume they're rated fast enough, but I can't actually find any information about NEC D27256D and don't know what speed they are actually rated for. I have another set of TOS 1.0 original mask ROMs, which work and test fine in the diagnostics. The diagnostic test shows a message about 6 ROMs being shown but only two may be present, so I assume it at least knows about 6-chip sets.

Maybe the EPROMs are just too old and an erase-program cycle finished them off. The old labels said they were burned in August 1988 - almost 30 years ago. These things are getting pretty crusty these days.

I don't have six other EPROMs to try right now. I have a big order of ST 120ns chips on the way. I suppose I'll wait a few days and try again when they arrive, now that I know the images are good (thanks exxos).

Thanks again.