Floppy failure fix - WIP

Various tweaks and fixes from video ghosting to audio fixes etc.
Post Reply
User avatar
exxos
Site Admin
Site Admin
Posts: 7614
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Floppy failure fix - WIP

Post by exxos » Fri Nov 30, 2018 10:23 pm

While there can be a lot of reasons for the floppy drive to fail, such as bad PSU, bad drive etc. If a drive works in a PC but not a STE for example, then its possible the machine may need the fix below.

The short version of this fix , is that the original Atari floppy drives had internal pull ups on some of the signals, drives like the MPF920 do not. So its possible (and likely) All non-original drives will need this modification. It is possible original drives could suffer as well, but this is a very new fix and the "bug" has only just been found.

This issue can cause the drive not to be found, intermittent read/write issues etc This issue is likely present on any machine with a 1772/Ajax floppy controller using a LS06 type buffer. IIRC the MSTE had 1 of these resistors fitted, I need to look into that again..


Below, the points in red need a 1K resistor connecting to 5V.

stemod.JPG
stemod.JPG (146.09 KiB) Viewed 607 times

I did a quick example below...

IMG_3634.JPG
IMG_3634.JPG (6.27 MiB) Viewed 607 times
IMG_3635.JPG
IMG_3635.JPG (5.64 MiB) Viewed 607 times
IMG_3636.JPG
IMG_3636.JPG (5.42 MiB) Viewed 607 times
IMG_3637.JPG
IMG_3637.JPG (4.97 MiB) Viewed 607 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply