Page 1 of 1

STE DAC NOISE FIX - BETA

Posted: Mon Aug 21, 2017 9:13 am
by exxos
dacfixfi.jpg
dacfixfi.jpg (105.69 KiB) Viewed 1096 times
I have heard many reports that the STE DAC playback has bad noise and high pitch whistles so I was asked to look into it. My own STE machine did not suffer from these problems, but the PSU is likely the first cause of noise also.

I originally made a small batch of these a while ago and people came back saying it improved or eliminated their audio problems. While the audio path can suffer from noise in various parts of the circuit, this board only solves the noise generated in the DAC IC itself.

If the PSU hasn't been updated or one of my own branded PSU's used, then likely the STE will suffer from power supply noise which first needs to be rectified before doing the following fix. Its worth noting that the audio system likely suffers from various noise throughout the audio path, so this "fix" should help reduce the problems a great deal, but won't fix problems elsewhere in the audio path.

I have not had a audio fault on my STE's, So I was unable to test to see if this fix solves problems personally. I have however talked with 2 guys some months ago who have tried this fix, and they reported a great improvement with audio quality. So this little PCB was designed which soldered ontop of the DAC IC's which covers all previously tried modifications.

This design is a WIP (Work in Progress) modification where people who try this fix, please report back your findings. If the fix is proven to help, then I will produce some more of these boards. Currently I only manufactured a limit number (about 10 sets at the time of typing) as the final results are still somewhat unknown.

So far I have heard that is does help overall but there hasn't been enough testing done by people to see what it solves and does not solve noise wise yet.

DAC FIX STORE LINK
https://www.exxoshost.co.uk/atari/last/storenew/#0071

DAC FIX HOMEPAGE
http://www.exxoshost.co.uk/atari/last/S ... /index.htm

PSU
https://www.exxoshost.co.uk/atari/last/storenew/#0029

..wrap..

Re: STE DAC NOISE FIX - BETA

Posted: Sun Aug 05, 2018 1:12 pm
by Steve
I would just like to report that these worked perfectly on my TT (as the TT uses the same DACs as the STe) I had electrical whiny noise from the sound output beforehand, with these installed it went away.