exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
exxos
Site Admin
Site Admin
Posts: 9338
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Tue Feb 11, 2020 8:05 pm

One thing I never thought about was the location of the Jtag header :lol: :roll: So the next board I should probably make the PCB a little longer.

IMG_4882.JPG
IMG_4882.JPG (138.63 KiB) Viewed 197 times

IMG_4884.JPG
IMG_4884.JPG (139.42 KiB) Viewed 197 times

I think finally I have it behaving kinda..

A lot of the time the machine does not seem to come out of reset, but I think there is a bad connection somewhere causing this, but oddly when I power down the machine for 30 seconds and turned back on again, it will fail to boot, so this seems like one of those wake-up state issues again... But I never had those issues with the V2.2 booster..

I also kept on seeing a glitch in the switching on the CPU clock.. This isn't actually new, but mostly I gave up and corrected this with a Schmitt buffer on everything else in the past. But oddly this problem was back again, maybe because the PLD is a lot faster than the 22V10's.. So now I have totally rewritten the switching code and the glitches gone and currently it seems to be all running okay..

IMG_4885.JPG
IMG_4885.JPG (104.89 KiB) Viewed 197 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 9338
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Feb 17, 2020 11:23 am

Been having error code 0x80092004 on Windows 7 64bit for ages and not been able to download updates for the past couple of months :roll:

Came across this link, something to do with SHA-2 code signing support.As to why and how this didn't it set up before, I have no idea.

https://www.ghacks.net/2019/08/15/if-yo ... 2-do-this/

So the direct links to the update catalogue are below, probably more for my own referrals in the future...

http://www.catalog.update.microsoft.com ... =kb4474419
http://www.catalog.update.microsoft.com ... =KB4490628

And To save me hassle in the future I dumped these two updates in the zip below.

win7_64-SHA2_fix.zip
(62.37 MiB) Downloaded 1 time
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 1709
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: exxos blog - random goings on

Post by rubber_jonnie » Mon Feb 17, 2020 1:09 pm

@exxos Don't forget Windows 7 is officially over as of 14th January, see here: https://support.microsoft.com/en-gb/hel ... ry-14-2020

So updates will disappear, unless you have an enterprise environment and are paying for extended support. I guess it depends on how much you view this as a security risk.

I use Win 10 on my main machines now, but quite a few of my secondary machines are Win7 as I like it a lot and don't really use them for anything other than things like a print server for my 3d Printer and stuff like that.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

Atarian Computing
Posts: 357
Joined: Tue Aug 22, 2017 4:27 am

Re: exxos blog - random goings on

Post by Atarian Computing » Mon Feb 17, 2020 1:13 pm

rubber_jonnie wrote:
Mon Feb 17, 2020 1:09 pm
@exxos Don't forget Windows 7 is officially over as of 14th January, see here: https://support.microsoft.com/en-gb/hel ... ry-14-2020

So updates will disappear, unless you have an enterprise environment and are paying for extended support. I guess it depends on how much you view this as a security risk.

I use Win 10 on my main machines now, but quite a few of my secondary machines are Win7 as I like it a lot and don't really use them for anything other than things like a print server for my 3d Printer and stuff like that.
We managed to switch over 10K+ Win7 computers to Win10 with months to spare. What a hassle though...

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 1709
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: exxos blog - random goings on

Post by rubber_jonnie » Mon Feb 17, 2020 1:16 pm

Atarian Computing wrote:
Mon Feb 17, 2020 1:13 pm

We managed to switch over 10K+ Win7 computers to Win10 with months to spare. What a hassle though...
We're still in the process and AFAIK have extended support due to the number of VDIs.

I'm lucky, I came straight in on Win10, but I don't envy the teams doing the migration. Good job in getting them switched over.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

Atarian Computing
Posts: 357
Joined: Tue Aug 22, 2017 4:27 am

Re: exxos blog - random goings on

Post by Atarian Computing » Mon Feb 17, 2020 1:27 pm

rubber_jonnie wrote:
Mon Feb 17, 2020 1:16 pm
Atarian Computing wrote:
Mon Feb 17, 2020 1:13 pm

We managed to switch over 10K+ Win7 computers to Win10 with months to spare. What a hassle though...
We're still in the process and AFAIK have extended support due to the number of VDIs.

I'm lucky, I came straight in on Win10, but I don't envy the teams doing the migration. Good job in getting them switched over.
Although I am in the same IT organization as the guys doing the upgrades (some are in my team), I don't touch hardware. I certainly didn't envy the guys that had to be on the road for a week at a time every second week, travelling and upgrading. Damn...

I'm the script kiddy here. You name it, I'll code it and then automate it. Or do tools and shit. Fun stuff. Want a personalized welcome message to new users in their own language from the CEO himself after making sure the user is licensed? You got it. Latest is a script that runs every 5 mins and emails new locked users and details to a MS Teams channel and then creates stats for the previous day and previous month and emails them separately. That actually helped me crack the culprit for the increasing lockouts. I'm kept pretty busy.

User avatar
exxos
Site Admin
Site Admin
Posts: 9338
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Feb 17, 2020 1:48 pm

So after installing updates, my desktop wallpaper went totally black, I could change it to a Windows built-in theme, but not a custom image any more :roll: I tried multiple ways, but I could only really set it to black or a Windows theme. The picture I selected even showed up in the desktop wallpaper box it just was simply not showing up on the desktop itself.

In a feat of desperation I changed the "Picture position" box to "FILL" (it was selected on stretch before) and my desktop image appeared! total madness!
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 9338
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Feb 17, 2020 1:50 pm

rubber_jonnie wrote:
Mon Feb 17, 2020 1:16 pm
Atarian Computing wrote:
Mon Feb 17, 2020 1:13 pm

We managed to switch over 10K+ Win7 computers to Win10 with months to spare. What a hassle though...
We're still in the process and AFAIK have extended support due to the number of VDIs.

I'm lucky, I came straight in on Win10, but I don't envy the teams doing the migration. Good job in getting them switched over.
Do any you guys know how to actually get the extended support for win 7 ? I did look online and it seemed the right rigmarole of installing stuff :roll:

Nothing even shows up now that Windows is reminding me is no longer supported, clicking on the learn more button basically tells you to upgrade to Windows 10... I personally would have thought Microsoft would have given people the option up front to extend the Windows 7 support even if people are paying for it, I think they are going to lose a lot of revenue by not giving people the option :roll:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 9338
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Feb 17, 2020 1:57 pm

rubber_jonnie wrote:
Mon Feb 17, 2020 1:09 pm
So updates will disappear, unless you have an enterprise environment and are paying for extended support. I guess it depends on how much you view this as a security risk.
Right :roll: Frankly fed up of reinstalling windows, mean I have pretty much gone right from the start, DOS - WIN 3.11.. WIN 95, WIN98SE, XP, WIN7... I am just not doing it again... Not only that, much of my programs are old, it was a miracle they ran in XP (a lot didn't) but thankfully things still running win7... But the problem is I seriously doubt the software I am running will work in Windows 10..

For example, some of the software is registered to my old motherboard (dual core pc in loft now) use a program which fakes the motherboard serial number on my new motherboard to allow this software to run. I'm just going to assume right from the start that Windows then is just not going to allow such things to run or happen.. There is not just that but a load of other funky things going on and reinstalling software is a right pain.. I really just do not have the time or patience to go through all that again.. I think I said before, even if I did try windows 10, if all my software did not run, are pretty much have to give up with developing all the stuff I do. I just have a really bad feeling as well of where Windows 10 is going is well.

EDIT:

There is a security risk, but going by the amount of security flaws already found a Windows 10, I saw Somehow feel safer in Windows 7 currently :lol: :roll: This is the problem as to how serious the problem really is versus the scare stories. On one hand Windows 7 isn't being updated, on the other hand hackers are probably spending their efforts on hacking windows 10 because it is new and likely to have new floors than win7 has.

I guess the bottom line is, if the £86 I have in my bank account disappears, I will probably just install UBUNTU on my laptop and use that for Internet stuff instead.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 1709
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: exxos blog - random goings on

Post by rubber_jonnie » Mon Feb 17, 2020 3:51 pm

@exxos I haven't looked at extended support myself, but I expect MS may charge a lot for it, and only agree for large businesses because of the $'s they can rake in doing it.

I suspect they won't do support for a single user, but I don't know for sure.

I guess the question is what applications are you using that still need an MS O/S? If you can't do without them and Win10 will kill them, like you say keep Win7 and have another machine running Linux for any online based activities. You may even find replacements in Linux for the software you need.

I've been right there since DOS myself, but I can't really migrate to Linux easily, though I guess we'll see what delaights the next version of Windows delivers.

My move to Win10 was not a happy one, though now I have a much modern/powerful laptop it's fine. As for work, I can't use anything else.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

Post Reply

Return to “MEMBER BLOGS”