STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Blogs & guides and tales of woo by forum members.
PeteW
Posts: 69
Joined: Wed Jul 25, 2018 8:09 pm

STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by PeteW » Fri Jul 27, 2018 6:10 pm

I have just received my 4meg ram upgrade from Chris. I decided to go with this one as I like how neat it is once installed.

https://www.exxoshost.co.uk/atari/last/storenew/#0020

I'm working from home today, so at lunchtime I decided to start desoldering the existing ram chips from the motherboard:
20180727_174835.jpg
20180727_174835.jpg (4.3 MiB) Viewed 504 times
So far it's been pretty easy. The ST motherboards seem to be good quality and cope with the heat from desoldering pretty well. I'd say the key to it is not rush and do it one chip at a time. I'm a vaguely competent solderer but by no means professional, however in my experience so far, to desolder chips without butchering them or the board, some basic rules are worth following:

1. Resolder the chip before you desolder it. It sounds counter intuitive and I don't know why, but new solder is easier to remove than old solder

2. Use a solder sucker twice per pin. If the solder still remains, add more solder and start again

3. Make sure that the hole is clear of solder top and bottom

4. Remove solder from the top of the board using solder wick. If that doesn't work, flip the board over, add more solder and start all over again

5. When the holes are clear, you might still need to apply a very small amount of leverage to the chip to get it to move, but not much

Anyone got any extra or better rules?!

User avatar
exxos
Site Admin
Site Admin
Posts: 4528
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by exxos » Fri Jul 27, 2018 6:31 pm

PeteW wrote:
Fri Jul 27, 2018 6:10 pm
Anyone got any extra or better rules?!
Cut the pins first, a lot easier... like I did in my video...


4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

PeteW
Posts: 69
Joined: Wed Jul 25, 2018 8:09 pm

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by PeteW » Fri Jul 27, 2018 6:58 pm

Thanks Chris that's really useful. I don't own any side cutters but it looks like I probably should!

troed
Trusted Guru
Trusted Guru
Posts: 448
Joined: Mon Aug 21, 2017 10:27 pm

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by troed » Sat Jul 28, 2018 8:24 am

I used a hot air station, boiled the solder topside, pulled the chips out one by one with a plier - and all chips still worked afterwards and have been used for subsequent 520ST piggyback RAM upgrades.

But yes, you "shouldn't" hot air through-hole etc, but in my experience the ST motherboards can handle a lot of abuse ... I cleaned up the holes with solder wick afterwards.

PeteW
Posts: 69
Joined: Wed Jul 25, 2018 8:09 pm

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by PeteW » Sat Jul 28, 2018 9:18 am

I'm halfway through and have managed to get 8 out so far - hopefully they all still work :)

Because my motherboard is a 520 st, I need to put resistors in r71-73. I understand they're supposed to be 68r, but I only have 47 and 120. Will either of those do the job or shall I order myself a few 68s. They're not expensive, just take time to arrive.

troed
Trusted Guru
Trusted Guru
Posts: 448
Joined: Mon Aug 21, 2017 10:27 pm

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by troed » Sat Jul 28, 2018 9:31 am

PeteW wrote:
Sat Jul 28, 2018 9:18 am
I'm halfway through and have managed to get 8 out so far - hopefully they all still work :)

Because my motherboard is a 520 st, I need to put resistors in r71-73. I understand they're supposed to be 68r, but I only have 47 and 120. Will either of those do the job or shall I order myself a few 68s. They're not expensive, just take time to arrive.
I've seen both 33 and 68Ohm resistors used, can't imagine you'd have any issues with 47.

User avatar
exxos
Site Admin
Site Admin
Posts: 4528
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by exxos » Sat Jul 28, 2018 9:57 am

47R should be fine. I use 33R in my 4 MB MMU kit , higher value resistors won't work in that case as the DRAM are 50ns or 60ns. 68R is "to slow" for the DRAM. But in case of 70ns or higher it doesn't really matter.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Atarian Computing
Posts: 259
Joined: Tue Aug 22, 2017 4:27 am

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by Atarian Computing » Sat Jul 28, 2018 4:01 pm

troed wrote:
Sat Jul 28, 2018 8:24 am
I used a hot air station, boiled the solder topside, pulled the chips out one by one with a plier - and all chips still worked afterwards and have been used for subsequent 520ST piggyback RAM upgrades.

But yes, you "shouldn't" hot air through-hole etc, but in my experience the ST motherboards can handle a lot of abuse ... I cleaned up the holes with solder wick afterwards.
I do this as well when I need to use the extracted chip. Never had issues.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 568
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by rubber_jonnie » Sat Jul 28, 2018 11:13 pm

exxos wrote:
Sat Jul 28, 2018 9:57 am
47R should be fine. I use 33R in my 4 MB MMU kit , higher value resistors won't work in that case as the DRAM are 50ns or 60ns. 68R is "to slow" for the DRAM. But in case of 70ns or higher it doesn't really matter.
Hmm, interesting, I used 33R resistors in my first upgrade to 1MB on a C070789 mainboard, and it worked fine, but I changed to 68R for later boards, I had all sorts of trouble, wondering if a swap to 33R might help, and it's an easy job to do.
Collector of old Atari things:
800XL + Ape Warp mod, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg) + Gotek, 1040STFM + Vortex ATOnce + Gotek, 1040STF long button floppy, 4160 STE with Gotek and ROM switcher, 4160STE with 32Mhz booster, ROM switcher and CosmosEx, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

PeteW
Posts: 69
Joined: Wed Jul 25, 2018 8:09 pm

Re: STFM 4MB SIMM ADAPTER KIT INSTALL BLOG

Post by PeteW » Sun Jul 29, 2018 2:04 pm

Next question. I've removed C49 (blue capacitor on the right hand side of the Ram on the motherboard)

My motherboard is slightly different to the one in the 'how to' guide. Can someone confirm that where I've indicated in red is where I should reposition it to? Continuity tester appears to say yes, but I'd like a second opinion :)

Apologies for the pic - taken and edited on my phone!
Attachments
20180729_142014.jpg
20180729_142014.jpg (6.55 MiB) Viewed 313 times

Post Reply