exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
Icky
Moderator
Moderator
Posts: 1315
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: exxos blog - random goings on

Post by Icky » Sun Jul 28, 2019 12:57 am

:cheer: :cheer: :cheer:

User avatar
exxos
Site Admin
Site Admin
Posts: 7643
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Sun Jul 28, 2019 11:17 am

It looks like the main bottleneck is linking the DRD lines from the shifter to RAM.. No so easy to route on the VCC layer as the GLUE is already routed there :(

Capture.PNG
Capture.PNG (287.38 KiB) Viewed 652 times
The only way it could be done is if I routed it on the GND layer :shock: Though splitting the GND between the CPU & Shifter could actually be a advantage, as it may help keep some noise from the CPU away from the shifter GND...


Also going to have to be careful of the PSU holes.. as if the metal feet of the PSU bracket may overhang the holes and short the via's out :roll:

Capture.PNG
Capture.PNG (71.38 KiB) Viewed 652 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1726
Joined: Fri Mar 23, 2018 8:22 pm

Re: exxos blog - random goings on

Post by PhilC » Sun Jul 28, 2019 11:25 am

You could insist that the front feet are insulated with something like a fibre washer but still use the rear slotted mounting for earthing etc?
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7643
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Sun Jul 28, 2019 11:35 am

PhilC wrote:
Sun Jul 28, 2019 11:25 am
You could insist that the front feet are insulated with something like a fibre washer but still use the rear slotted mounting for earthing etc?
Its better for the PSU plate to be connected to GND.. But as people never read instructions, someone would put the PSU on the board and blow the thing up :lol: :roll: Its fixable, just will take a bit more time.

I'm thinking if I shove the SMT GLUE over to the left more, it will free up room to the right of the SMT GLUE and have space on the VCC layer to route the shifter datalines back to the RAM.. If I route those lines close to the PSU holes (which will have to be anyway) the autorouter won't be able to place via's there because there will be tracks in the way.. It should also free up the mash of tracks and route a whole lot better afterwards.. so win win win ;)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7643
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Jul 29, 2019 2:52 pm

Started routing the shifter data lines.. I was using the auto route tool to try and speed things up, but it just ended up putting millions of vias everywhere :roll: So I started manually moving stuff around and that is why it looks terrible on the routing so far. Though I have managed to remove all the vias, so I just need to tidy it up now :)

Capture.JPG
Capture.JPG (156.98 KiB) Viewed 606 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7643
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Jul 29, 2019 4:18 pm

Sometime later...

1.png
1.png (923.49 KiB) Viewed 596 times


Next up to see where the next bottleneck is on the PCB..

Last time it routed in 1698 via's.. so be interesting to see what it routes with this time...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rpineau
Site Admin
Site Admin
Posts: 490
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: exxos blog - random goings on

Post by rpineau » Mon Jul 29, 2019 5:02 pm

Nicely done !
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
exxos
Site Admin
Site Admin
Posts: 7643
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon Jul 29, 2019 5:49 pm

Ironically it seems 46% of the PCB has already been rooted manually so far :lol: :roll:

Is looking pretty good so far...

Capture.JPG
Capture.JPG (266.52 KiB) Viewed 585 times

BUT..

:WTF:


I am hoping this sort itself out later...

Basically the top layer is being jumped over with via's over a tray switches on the vcc layer..

So its like starting on the top layer,Jumping over tracks which are on a different layer, and then jumping back to the top layer :? :? :? I seriously think this autorouter is on LSD or something..

wtf.jpg
wtf.jpg (175.04 KiB) Viewed 585 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7643
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Tue Jul 30, 2019 11:46 am

Finally got Trudie fitted in with the mods done..

Now to figure out some firmware...

IMG_4476.JPG
IMG_4476.JPG (225.53 KiB) Viewed 546 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7643
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Tue Jul 30, 2019 3:16 pm

So far not going well... seems to be a crash screen generator.. so some bad joints somewhere to track down..

IMG_4478.JPG
IMG_4478.JPG (112.84 KiB) Viewed 524 times
IMG_4480.JPG
IMG_4480.JPG (73.17 KiB) Viewed 524 times

bypassed the PLD so its basically a CPU adapter PCB at the moment...

IMG_4481.JPG
IMG_4481.JPG (141.12 KiB) Viewed 524 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply