exxos blog - random goings on

Blogs & guides and tales of woo by forum members.
User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Thu May 16, 2019 9:35 pm

Busy testing more Falcon RAM boards :)

https://www.exxoshost.co.uk/atari/last/storenew/#0086

IMG_4168.JPG
IMG_4168.JPG (121.95 KiB) Viewed 425 times

IMG_4169.JPG
IMG_4169.JPG (76.36 KiB) Viewed 425 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Fri May 17, 2019 9:27 pm

All the Falcon RAM boards done, some more 16MB simms tested. Loads of STE DUAL TOS ROM's done today as well.

Eagle still hanging like f*ck trying to route the remake board. I'm allow it to use the VCC layer.. probably regret it...

Now doing a bit more to the PSU bracket.. Making thing a bit stronger and adding the recess holes for the support posts...

rs.jpg
rs.jpg (13.19 KiB) Viewed 401 times
1.jpg
1.jpg (56.6 KiB) Viewed 401 times

Will probably have to make the "wings" a bit wider as the hole is getting pretty close to the edge...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Fri May 17, 2019 10:04 pm

Made some tweaks like making the "front to back" support thinner. The PSU PCB will hold it all firm anyway, so it doesn't need to be as thick as it was.

Wings have been bulked up a fair bit and the support posts have been created. So Monday will print it out again :)

2.jpg
2.jpg (48.37 KiB) Viewed 394 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Sat May 18, 2019 1:06 am

Autorouter finally finished after maxing out 8 cores for 10 hours straight :roll: it did not do much routing on the vcc layer and there was some nice huge slabs of copper still, but unfortunately it broke several vcc pins :( I'm really not surprised. It used about 800 vias at best , over about 1200 on 2 layers.

So what I will do is manually route the SMT glue & MMU together on the vcc layer , along with the expansion sockets. Then it should basically route as before on 2 layers.

It can all route on 2 layers anyway but its a bloody mess. Way to many close traces , which will be a pain if we need to do any track cutting again in places etc.

So will make a start on that on Monday :)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1274
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: exxos blog - random goings on

Post by Icky » Sat May 18, 2019 5:18 pm

exxos wrote:
Fri May 17, 2019 10:04 pm
Made some tweaks like making the "front to back" support thinner. The PSU PCB will hold it all firm anyway, so it doesn't need to be as thick as it was.

Wings have been bulked up a fair bit and the support posts have been created. So Monday will print it out again :)
Looking good :)

User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon May 20, 2019 10:56 am

Now printing :)

Capture.JPG
Capture.JPG (86.44 KiB) Viewed 335 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon May 20, 2019 12:46 pm

Really starting to hate Eagle these days..

Its also annoying that every route I try and do, it moans about layers not being active ( because I don't want it to use them!) and I have to click the box away every time I route a wire.. its a huge waste of time :roll:

Capture.JPG
Capture.JPG (282.94 KiB) Viewed 330 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon May 20, 2019 1:35 pm

Waiting for it to cool down :)

Actually just realised, the middle support at the back ( right-hand support of the mains socket) Does not need to be that wide. So I have reduced its width to match the left-hand side support..

IMG_4170.JPG
IMG_4170.JPG (184.35 KiB) Viewed 326 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon May 20, 2019 2:08 pm

Not bad so far...

I need to make the spaces longer more than anything.. I need to make the recess part a little bit longer as well..

The front holes are not totally aligned to the motherboard, so I need to do something about them...

The bottom of the plastic frame is actually resting on top of the ROM chip.. of course I had to make this thicker than the original metal.. But I will see if I can add 1mm on the top side, and take away 1mm from the bottom to give the ROM chips a tiny bit of clearance.

IMG_4171.JPG
IMG_4171.JPG (347.02 KiB) Viewed 324 times
IMG_4172.JPG
IMG_4172.JPG (343.07 KiB) Viewed 324 times
IMG_4173.JPG
IMG_4173.JPG (207.95 KiB) Viewed 324 times

EDIT:

I do not have the correct screws for this at the moment.. But they do seem to fit extremely well in the plastic even though it hasn't even got the nuts on yet...

IMG_4174.JPG
IMG_4174.JPG (498.29 KiB) Viewed 320 times
IMG_4175.JPG
IMG_4175.JPG (427.88 KiB) Viewed 320 times
IMG_4177.JPG
IMG_4177.JPG (347.55 KiB) Viewed 320 times
IMG_4178.JPG
IMG_4178.JPG (392.34 KiB) Viewed 320 times
IMG_4179.JPG
IMG_4179.JPG (350.07 KiB) Viewed 320 times

I have added some recesses so the nuts will grip better..
o.jpg
o.jpg (10.86 KiB) Viewed 320 times
Also done the same on the bottom..

I have also made the spacers about 1mm wider (thicker) as I did not think there was very strong as they was.. So I had to make the recess in the plastic base little wider as well, but I cannot go any more without widening the wings again.

Also made the bottom of the base 1 mm smaller, and increase the top section of the base 1 mm.. So basically there will be 1mm clearance above the ROM's how they are currently.. But there is also now 1mm less space between the base and the solder side of the power supply.. Of course with my own design power supplies, this spacing somewhat irrelevant anyway.. What I basically did was take away some of that "solder side gap" to make the plastic thicker, and also lowered the bottom of the frame to also make it thicker, but this is also the reason there is not much space above the ROMs now.. Obviously the original power supply base was 1mm thick.. and now it is 4mm thick..

I also just realised the switch mounts on the rear of the fixings ( not the front as I have in the image).. So I need to actually move that section backwards about 1mm otherwise the screw heads will push on the rear of the atari case.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: exxos blog - random goings on

Post by exxos » Mon May 20, 2019 4:46 pm

New print underway.

This one uses 50% infill (was 15% before) see if its any stronger or not...Certainly taking a lot longer to print...

(The fill does not show up very well on the image :( )

IMG_4181.JPG
IMG_4181.JPG (179.57 KiB) Viewed 314 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply