Stuff and Things.

Blogs & guides and tales of woo by forum members.
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2954
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Wed Sep 23, 2020 10:48 am

Bit of a project status update, have got moving on some stuff at least:

1. Greaseweasel build. Just need the time to build. It's built and get's power, but isn't recognised by my PC. Got a programmer on the way to see if I can connect to it that way
2. Amiga A1200 recap. I have the kit, just need the time. Hopefully this will be done over the next weekend
3. Test out my Atari 8Bit UNO cart. This could be a game changer by having multiple carts on an SD card, especially with my SIO2SD as well. More time required. Works just fine, but have some problem ROMs, so having found new images I need to give it another go. MAC65 is one I really want to get going. Unfortunately doesn't work with Space Harrier, as the ROM is too large
4. Amstrad Alt386 - I think this needs some bodge wires to fix due to a leaky battery, plus a capacitor or two on the mainboard. Pretty much salvageable IMHO. Fixed and working just fine, next I want to get it hooked up to my network and get Win 3.11 installed :)
5. Mac Classic. Repairs in progress but looking a bit desperate :(
6. Build my 2nd H4! No rush on this as waiting for the HDMI adapter.
7. Build my TF536. Where did all the time go....
8. Build my 2nd EPROM emulator from Mr Morley.
9. NetUSBee. When I have the inclination and funds... I may press on with this, as my tax code has changed and I have some more cash available

In addition I have a slew of 8Bit upgrades to do, which I will document. My 65XE is getting an Ultimate 1MB and a VBXE, my 800XL is getting a VBXL, and both are getting spangly new PSUs from Lotharek. Should keep me busy in the weeks/months ahead!
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2954
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Sat Sep 26, 2020 5:34 pm

Latest in from @exxos, a Mega (Looks like the base MB is the same as my Mega 1), with an unusual RAM expander:

IMG_20200926_133719.jpg
IMG_20200926_133719.jpg (190.99 KiB) Viewed 406 times
IMG_20200926_133554.jpg
IMG_20200926_133554.jpg (161.75 KiB) Viewed 406 times

Based on the chip sizes, I think it has 2.5MB of RAM, with space for another half MB, so including onboard RAM I think it's 3.5MB total, unless it needs the extra 4 chips to take it to 3MB extra and 4MB total.

I shall investigate once I've finished recapping my A1200.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
exxos
Site Admin
Site Admin
Posts: 12239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Stuff and Things.

Post by exxos » Sat Sep 26, 2020 5:53 pm

I did test it out already, with missing chips 4MB viewtopic.php?f=11&t=3358
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2954
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Sat Sep 26, 2020 7:16 pm

exxos wrote:
Sat Sep 26, 2020 5:53 pm
I did test it out already, with missing chips 4MB viewtopic.php?f=11&t=3358
Since I posted I've come to the conclusion it must be 4MB total, 1MB on board, the 16 511000 chips are another 2MB, and the 4 4256 are not quite a full bank, it needs another 4 chips to make it complete, so I need to find some 4256 chips. I may have some, definitely have some 41256's. I do have some 511000s.

Very nicely made upgrade I have to say, and the method of connection is very nice too.

Reset button in busted though, so expect an order soon once I've worked out what re-cap kits my spare PSUs need.

:)
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2954
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Sun Sep 27, 2020 11:52 pm

exxos wrote:
Sat Sep 26, 2020 5:53 pm
I did test it out already, with missing chips 4MB viewtopic.php?f=11&t=3358
Fired up this evening, thinks it has 4MB, but goes belly up in the ram test. Typically, all the RAM I have is 41256(I have probably 50-60 of these!), so I need to get some 4256s lined up.

Also boots to desktop, which is nice, apart from it being French, which I'm not. I'll likely drop in some more sockets as I have a ton of 27C256s, some already programmed with TOS 1.04 patched for IDE, which is handy on account of the spare Megabus IDE adapter I have.

All I need now is a case!!

Project updates too!!

1. Greaseweasel build. Just need the time to build. Well, the programmer arrived, and it sees theSTM32, and I can program it, but it won't even run the 'Blink' diagnostic prog. I think I'll return it to Keir F to see if he can fix, and also buy a ready built one in case its a lost cause. :(
2. Amiga A1200 recap. I have the kit, just need the time. Completed and running lovely, but I have found a dodgy key, so next I'll have a closer look at the membrane, see if I can fix in the same way as I did my MSTE CTRL key.
3. Test out my Atari 8Bit UNO cart. Got a bunch of different images and much more works, including MAC 65 :) Space Harrier is still to big, but I have a SIDE 3 coming from Lotharek (Amongst other things :) ) which should cover that. I will have some more 8 Bit upgrades to share soon too!
4. Amstrad Alt386 - Still running great, but at present the only medium I have to transfer Win 3.1.1 is floppies, and it isn't reading 1.44MB disks properly. Ho Hum, I'll have to pull the FDD out and give it a clean!
5. Mac Classic. Repairs in progress but looking a bit desperate :( Very desperate indeed.
6. Build my 2nd H4! No rush on this as waiting for the HDMI adapter.
7. Build my TF536. Where did all the time go....
8. Build my 2nd EPROM emulator from Mr Morley. Pending....

Here is the post recap A1200:

A1200_Done.jpg
A1200_Done.jpg (149.69 KiB) Viewed 364 times

Luckily I caught this JUST in time. 2 or 3 of the electrolytics had started to leak, but thankfully no damage done. Luckily the A1200 has no battery, though I did note my 68030 accelerator board doe have one, so I think that will have to go soon. I have some rechargeable CR2032 batteries, so that will probably be a good swap to get done.

Overall a good weekend, especially since the new tips for my soldering iron have change it's performance massively, so I think i unlikely I'll need to buy a new one right now.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2954
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Tue Sep 29, 2020 11:30 pm

Ok, so I'm trying to figure out the RAM on this board here:

IMG_20200926_133554.jpg
IMG_20200926_133554.jpg (170.44 KiB) Viewed 323 times
The existing RAM on the mainboard is 4256, which is 256k x 4 bit. So 2 chips = 256kbx8bit, 4 chips = 512kbx8bit, 8chips =1Mbx8bit. So 1 MB on board.

The expansion board has 4x4256, so 512kbx8bit.

In addition, the expansion board has 511000s, which I know are 1MBx1bit, so 8 are needed for 1MB. There are 16 on the expansion board, adding up to a further 2MB, therefore the expansion board has 2.5MB in total, the mainboard has 1MB,so total Ram is 3.5MB.

Is my maths looking right there?

What seems weird is that even when I remove the 4256 chips from the expansion board, it still reports 4MB RAM and the RAM test fails at the same locations. I guess I should try getting some additional 4256s, see if taking the expansion board to 3MB changes the result, otherwise there may be a fault in the other RAM, and working out the banks may be a little trickier than on a standard Mega 4. I do have some spare 511000s so hopefully I can work out whats what and get it running. Otherwise I might have to figure out a way of reverting to the base 1MB without completely removing the expansion board so I can test just the one bank that's installed on the mainboard.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
exxos
Site Admin
Site Admin
Posts: 12239
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Stuff and Things.

Post by exxos » Wed Sep 30, 2020 12:27 am

It is a odd board. I added those missing chips and it tests 4MB fine. I just had to borrow them out of a STFM which used the same chips.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2954
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Wed Sep 30, 2020 9:09 am

exxos wrote:
Wed Sep 30, 2020 12:27 am
It is a odd board. I added those missing chips and it tests 4MB fine. I just had to borrow them out of a STFM which used the same chips.
Annoyingly, 4256 are the one RAM chip I don't have, I have some coming so will wait and see what happens when the slots are filled.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2954
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Sat Oct 03, 2020 12:28 pm

It's been a good weekend for PC upgrades so far :D

Main laptop got an upgrade to a 1tb SSD and an upgrade to 32GB RAM, and I found some RAM I'd forgotten about in the bottom of of a drawer (Typical, I was looking for something else, which I still haven't found!) so managed to get my workbench PC up to 32GB as well.

Must try and get my A1200 keyboard fixed and reassemble it, and burn my EmuTOS 1.0 / 2.06 to drop into my Mega 4.

Sadly looks like my other retro deliveries won't be here until Wednesday ish.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

Tomswork
Posts: 418
Joined: Fri Nov 22, 2019 10:05 pm

Re: Stuff and Things.

Post by Tomswork » Sat Oct 03, 2020 7:12 pm

@rubber_jonnie

Well I recapped my mac classic board and analog board and it works once again. Now to fix the floppy drive 💾. Then see about a scsisd setup

Tom

Post Reply

Return to “MEMBER BLOGS”