Stuff and Things.

Blogs & guides and tales of woo by forum members.
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 3009
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Thu Oct 29, 2020 9:21 am

Hmm, some weirdness with my SIO2SD, it just stopped working after I plugged it in to my 1050 to test it at the end of the chain , just gave me a row of blocks on the display.

Quick check and 5V from the Atari is fine and reaching the board, so I reflowed the pins of the microcontroller and it sprang back into life!! Fingers crossed I'll have my SDRIVE MAX soon to replace it, and my dual POKEY remake is on the way too, which will give me stereo out of the 13 pin video socket, and then I'll have a spare POKEY to do the same with my XE, well so long as I can find the schematics to do it as it doesn't look like Lotharek does the dual adapter any more.

My vLA81 is still in the post, hopefully that'll be here soon (It is coming form NZ to be fair), and in the meantime I need to look at that Mega board again, see if I can figure out what's what with the RAM. I may look at temporarily removing the RAM upgrade, it seems to be plugged in bar a single connection to the MMU, so I can at least check the onboard RAM.

Got a few minor things going on too, like some adapter builds and a recap for an ST PSU.

EDIT: The vLA81 spent 7 days in 'international departures' but it literally just got on a plane! Very exciting to have it on the way here! I guess once the ZX81 is running, I need to fix my dead Spectrum!
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

stephen_usher
Trusted Guru
Trusted Guru
Posts: 1108
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: Stuff and Things.

Post by stephen_usher » Thu Oct 29, 2020 12:20 pm

Stuff does take an age to get from NZ!

I've forgotten what's wrong with your Speccy.
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 3009
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Thu Oct 29, 2020 1:18 pm

stephen_usher wrote:
Thu Oct 29, 2020 12:20 pm
Stuff does take an age to get from NZ!

I've forgotten what's wrong with your Speccy.
Actually, other than it being dead, could be just power or something more serious. I don't know, so once I clear the decks a bit, I'll get it out and have a proper look. I do have a second Speccy, one with a built in tape deck, which worked last time I checked. The dead one is one of the type with keys like the QL, but not a toast rack as I recall.

Got to have a closer look at the zx81 PSU too, there is a hot melty spot on the case, looks like the regulator was working overtime before I got it and replaced the reg. Just want to be sure it's not running at too high a voltage.

Also got my 7800 comp mod to do too, maybe this weekend I'll get some time in and drag the Speccy out, though I have been concentrating on getting the retro corner set up of late, it's nearly done so I can get soldering again.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

atari030
Posts: 155
Joined: Mon Feb 12, 2018 12:43 pm

Re: Stuff and Things.

Post by atari030 » Thu Oct 29, 2020 1:31 pm

From home (NZ) to here, usually only takes a week. ;-)

I've been on the hunt for a 7800 for a while, trying to find an unmolested one to molest isn't easy.

stephen_usher
Trusted Guru
Trusted Guru
Posts: 1108
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: Stuff and Things.

Post by stephen_usher » Thu Oct 29, 2020 1:50 pm

rubber_jonnie wrote:
Thu Oct 29, 2020 1:18 pm
stephen_usher wrote:
Thu Oct 29, 2020 12:20 pm
Stuff does take an age to get from NZ!

I've forgotten what's wrong with your Speccy.
Actually, other than it being dead, could be just power or something more serious. I don't know, so once I clear the decks a bit, I'll get it out and have a proper look. I do have a second Speccy, one with a built in tape deck, which worked last time I checked. The dead one is one of the type with keys like the QL, but not a toast rack as I recall.
That's just a 48K in a fancy case then. It could even be a 48K transplanted form the original case if the Spectrum+ case has "Upgraded" on the underneath of the edge connector port.
Got to have a closer look at the zx81 PSU too, there is a hot melty spot on the case, looks like the regulator was working overtime before I got it and replaced the reg. Just want to be sure it's not running at too high a voltage.
On the ZX81 or the PSU? The early PSUs were known to melt down, which is why Sinclair did a recall on the early Spectrum ones. I just replaced the thermal fuse with a bit of wire back in the day when it failed. ;-)
Also got my 7800 comp mod to do too, maybe this weekend I'll get some time in and drag the Speccy out, though I have been concentrating on getting the retro corner set up of late, it's nearly done so I can get soldering again.
:)
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 3009
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Thu Oct 29, 2020 2:39 pm

stephen_usher wrote:
Thu Oct 29, 2020 1:50 pm

That's just a 48K in a fancy case then. It could even be a 48K transplanted form the original case if the Spectrum+ case has "Upgraded" on the underneath of the edge connector port.

On the ZX81 or the PSU? The early PSUs were known to melt down, which is why Sinclair did a recall on the early Spectrum ones. I just replaced the thermal fuse with a bit of wire back in the day when it failed. ;-)
Yep, looks like a standard 48k PCB to me, as you say, in a fancy case.

As for the ZX81, I mean the computer itself has a melty spot over the top of the REG. The PSU itself looks fine, but it is actually a ZX80 PSU and voltages seem a little high, hence why I think the REG got a bit warm and melted the ZX81 case a smidge.

If the PSU failed, then it may also be due to the board getting higher voltages than it should. I will test it properly using my bench PSU once the vLA81 arrives and until the PSU is verified as ok.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 3009
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Mon Nov 02, 2020 12:28 am

Well, my vLA81 is still in transit, so in the meantime I dropped a Composite MOD into my Atari 7800:

7800.jpg
7800.jpg (129.52 KiB) Viewed 1004 times

Kit came from TFW8BIT and picture quality is very nice :) And yes, that is hot glue, but it is the Atari way when all said and done!

Also had my SDrive-Max arrive:

S-_Drive_Max.jpg
S-_Drive_Max.jpg (48.76 KiB) Viewed 1004 times

It's a lot easier to use than my SIO2SD and very nice build quality.

Another good weekend, will get back to my Mega soon :)
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1401
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: Stuff and Things.

Post by PaulJ » Mon Nov 02, 2020 12:50 am

@rubber_jonnie , been pretty quiet lately...? Thought maybe you had been attacked by that vicious soldering iron of yours and unable to type because of burnt fingers...


:girldance:

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 3009
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Stuff and Things.

Post by rubber_jonnie » Mon Nov 02, 2020 9:46 am

PaulJ wrote:
Mon Nov 02, 2020 12:50 am
@rubber_jonnie , been pretty quiet lately...? Thought maybe you had been attacked by that vicious soldering iron of yours and unable to type because of burnt fingers...


:girldance:
Yeah, I have really been focusing a bit more on my 8 Bit Ataris of late and getting some of my other stuff caught up. Still here, just working on other stuff. I may do a write up on the 800XL once my POKEY Max arrives and I have to pull it apart again to fit it.

I still need to do the Oscilloscope basics too, but I've decided that will happen when I get onto the Mega I got recently. Just need to get the ZX81 put to bed, and a couple of other really quite small projects such as a PSU recap and some smaller minor quickie jobs.

Also been trying to get my retro corner into some sort of order, and nearly there. I have my 800XL permanently set up with 1050 FDD, my Dreamcast, my original Xbox, my Wii and Gamecube. Of course the 800XL and 65XE are interchangeable, and I have the 7800 ready to plug in at a moments notice. I do also need to look at my Spectrums and Oric Atmos as I want to be in the position of being able to just pull out the 800XL and drop them into it's space as and when I want to. Oh, and nearly forgot the NES, though it is a modern fake, but it does take carts.

I do want to have a crack at 6502 assembly language too, so been working out how I can get that all working on the 800XL with my SIDE3 cart.

So pretty busy, but nothing hugely interesting. Of course now the weather is turning, it is heading into my winter project time, which means hopefully I'll get more and more done and write a bit more up.

Didn't help this weekend that I had to replace the keyboard on my laptop. It was quite a time suck due to the unfeasible number of screws to A) Take apart the laptop to get to the keyboard B) The number of screws actually holding the keyboard in!

No burns, but a few near misses :)

:girldance:

Oh and of course still working!!
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 1401
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: Stuff and Things.

Post by PaulJ » Mon Nov 02, 2020 3:14 pm

@rubber_jonnie , I don’t recall.... you did buy an H5? Hate to see ya fall behind. :coffee:

Post Reply

Return to “MEMBER BLOGS”