Life, the universe & everything...Atari (well, mostly)

Blogs & guides and tales of woo by forum members.
JezC
Posts: 281
Joined: Mon Aug 28, 2017 11:44 pm

Life, the universe & everything...Atari (well, mostly)

Post by JezC » Thu Feb 27, 2020 10:33 pm

Well, in a brief burst of enthusiasm I've decided to try and record my general (lack of) progress with the retro stuff. :D

It's probably going to be of little or no real interest to anybody else :lol: but that's not the primary reason for doing it ;)

This is mostly Atari STs and my Falcon but also quite a few synths/keyboards/expanders/samplers etc. (Roland, Yamaha, Korg, Akai, Kawai) & a couple of BBC micros plus peripherals..and far too many old PCs to ever admit to owning :oops:

The main reason for staring today is a series of apparently unrelated events:
- populated H4 boards finally reach exxos - yay!
- my separate orders for some 27C4096 EPROMs and the adaptors to fit them into my TL866 both arrived at work this afternoon despite being ordered a month apart
- I finally remembered to bring my desoldering tool home from work (where it arrived about a week ago)

So, I'm hoping to gradually record any bits of progress or lessons learned as I work through the massive backlog of electronics to repair/refurb & then actually use!

I think my first set of tasks will be to:
- program up some 27C256 EPROMs I bought a few months ago (so that I can upgrade some old 6 ROM STF/STFMs from TOS 1.0 to 1.04 (and prove that the TL866 is working as expected in the process)
- check if the 44 pin PLCC adaptor that arrived toady works as-is or whether it needs some extra wire links adding for the 0v connections (as detailed by @rubber_jonnie somewhere)...so that I can program up an EPROM for my populated H4 (when that arrives)
- test the DIAGROM images I programmed into a pair of 27C512 EPROMs in a working 2 ROM STFM & sort out the serial cable for debugging
- then use the DIAGROM EPROMs to fault find the 3 or 4 STs which won't boot to the desktop at present & choose one or more as the donor for my second (unpopulated) H4 board

Well, if I get any of that done before Easter I'll be happy :D (and very surprised) :shock: :lol:

User avatar
exxos
Site Admin
Site Admin
Posts: 9597
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Life, the universe & everything...Atari (well, mostly)

Post by exxos » Thu Feb 27, 2020 10:43 pm

JezC wrote:
Thu Feb 27, 2020 10:33 pm
It's probably going to be of little or no real interest to anybody else :lol:
Ahh same here.. googlebot accounts for 90% of my readers :lol: :roll:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Tomswork
Posts: 114
Joined: Fri Nov 22, 2019 10:05 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by Tomswork » Fri Feb 28, 2020 3:15 am

Just wondering if you know were I can find the article on the tl866 using the 44plcc adapter. I was thinking of burning a diagrom for testing the h4
Found this adp-017
Screenshot_20200227-221052_Samsung Internet.jpg
Screenshot_20200227-221052_Samsung Internet.jpg (86.84 KiB) Viewed 892 times
Ebay uk has some

Tom

JezC
Posts: 281
Joined: Mon Aug 28, 2017 11:44 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by JezC » Fri Feb 28, 2020 8:08 am

I'll dig out rubber_jonnie's post later today...ran out of time last night.

I think his post covers the missing connections on the adaptor he got with his programmer, so that should be a good guide on what to check.

I bought my adaptors is eBay and they came from China...took about a month even with the current problems.

Edit:
Link for the modified adaptor below
viewtopic.php?f=73&t=1640&p=20619&hilit=plcc#p20619

Looking at your photo more closely, it does suggest it supports the 27C4096 so it may just work as-is... :D ...but maybe check the power & ground connections between the DIL pins & the PLCC pins to be sure...and maybe the programming voltage pin.

You can usually get away with having the other pins connected wrong (but us paranoid engineers generally check everything at least twice...to try and avoid letting out the expensive smoke... :shock: ...or is that the OCD showing again?) :lol: :roll:

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2002
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Life, the universe & everything...Atari (well, mostly)

Post by rubber_jonnie » Fri Feb 28, 2020 8:25 am

@JezC Good stuff, I hope to get some diags done on my H4 this weekend. Based on the diags done for my Mega 4 I should be in a good place to get moving. I suspect ROM is the problem due to my ham-fisted installation of the LS11. Bit of a mess as I should have done it first, doing it with the rest of the parts installed was not fun. Hope all your stuff goes well.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

JezC
Posts: 281
Joined: Mon Aug 28, 2017 11:44 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by JezC » Fri Feb 28, 2020 9:14 am

@rubber_jonnie good luck fixing the H4... you need to get that done before all those assembled ones are posted out :D

Yes (and thanks), hope to get some retro time over the weekend but doubt that I'll get more than one or two knocked off the list :cry:

Wondering if I should prioritise the H4-related tasks for the assembled one or just do the quickest ones to make room for all the other work that needs doing :roll:

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2002
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Life, the universe & everything...Atari (well, mostly)

Post by rubber_jonnie » Fri Feb 28, 2020 9:45 am

@JezC BTW, where did you get your DiagROM images from? I have a diag cart but am interested in other diagnostics.

I am ordering a diag cable set and cart from Olivier at gossuin.be when his store reopens.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

JezC
Posts: 281
Joined: Mon Aug 28, 2017 11:44 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by JezC » Fri Feb 28, 2020 10:07 am

rubber_jonnie wrote:
Fri Feb 28, 2020 9:45 am
@JezC BTW, where did you get your DiagROM images from? I have a diag cart but am interested in other diagnostics.
@rubber_jonnie I downloaded them from terriblefire's GitHub repo.
Will add a link in a moment (via my PC... replying via phone atm).
I did have to trim the binaries to fit in a pair of 27C512s but he's put a text string at the end of the actual image (I think)... I've not yet tried the images I blew into the EPROMs but hope to get to that over the weekend.

Edit: Link to the forum topic...
viewtopic.php?f=72&t=1201

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2002
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Life, the universe & everything...Atari (well, mostly)

Post by rubber_jonnie » Fri Feb 28, 2020 1:31 pm

@JezC Cool, thanks very much and good luck!

Temptes to get some more 27C4096s and put them on that.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

Tomswork
Posts: 114
Joined: Fri Nov 22, 2019 10:05 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by Tomswork » Fri Feb 28, 2020 3:43 pm

Thanks for the link on the dip mod.

Tom

Post Reply

Return to “MEMBER BLOGS”