Life, the universe & everything...Atari (well, mostly)

Blogs & guides and tales of woo by forum members.
User avatar
PhilC
Moderator
Moderator
Posts: 2503
Joined: Fri Mar 23, 2018 8:22 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by PhilC » Thu Mar 12, 2020 7:07 pm

rubber_jonnie wrote:
Thu Mar 12, 2020 1:25 pm
exxos wrote:
Wed Mar 04, 2020 2:04 pm

I spam the forum all the time, I think people mostly just skip over it all.
@exxos If it's your own forum, are you really spamming it?
Hes not wrong, I think I just did.
If it ain't broke, test it to Destruction.

JezC
Posts: 281
Joined: Mon Aug 28, 2017 11:44 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by JezC » Fri Mar 13, 2020 10:16 am

:cheers:
Think I've found the second donor system while testing another STFM last night...not booting to the desktop but showing a black centre with white borders.

I'm hoping that points to a ram fault but that's probably not an issue for one of my H4s.

I also managed to win the bidding on a Falcon ram board last night, so that will be useful for the second H4 (when the ram arrives)... almost makes up for missing out on the Mega 1

Of course this just means that I am running out of excuses for not finishing the first H4
:lol: :roll:

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2002
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Life, the universe & everything...Atari (well, mostly)

Post by rubber_jonnie » Fri Mar 13, 2020 10:57 am

JezC wrote:
Fri Mar 13, 2020 10:16 am
:cheers:
Think I've found the second donor system while testing another STFM last night...not booting to the desktop but showing a black centre with white borders.

I'm hoping that points to a ram fault but that's probably not an issue for one of my H4s.

I also managed to win the bidding on a Falcon ram board last night, so that will be useful for the second H4 (when the ram arrives)... almost makes up for missing out on the Mega 1

Of course this just means that I am running out of excuses for not finishing the first H4
:lol: :roll:
@JezC Yeah, sounds like a RAM problem, just got to ID the offending chip. Or chips!

As for the H4, well you better get rolling, even mine is running now :girldance:
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

JezC
Posts: 281
Joined: Mon Aug 28, 2017 11:44 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by JezC » Fri Mar 13, 2020 3:09 pm

Well, I do have the DiagROM EPROMS programmed and both donor boards are 2 chip TOS so that could be a plan.

I guess I need to prove that I have a working serial cable with a working ST first & then see what faults there are on each board!

I feel no pressure to rush the H4s :D as I have already set my target to be done by Christmas :lol:

User avatar
exxos
Site Admin
Site Admin
Posts: 9597
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Life, the universe & everything...Atari (well, mostly)

Post by exxos » Fri Mar 13, 2020 3:20 pm

rubber_jonnie wrote:
Fri Mar 13, 2020 10:57 am
@JezC Yeah, sounds like a RAM problem, just got to ID the offending chip. Or chips!

As for the H4, well you better get rolling, even mine is running now :girldance:
Indeed, we all can now start picking on @JezC to get finished now :lol: :twisted: :twisted: :chairsmack:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2002
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Life, the universe & everything...Atari (well, mostly)

Post by rubber_jonnie » Fri Mar 13, 2020 3:28 pm

Yeah @JezC get moving!
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

JezC
Posts: 281
Joined: Mon Aug 28, 2017 11:44 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by JezC » Fri Mar 13, 2020 3:49 pm

That's what I love about this forum...all the wonderful non-judgemental forum members
:lol: :roll:

Seriously though, I will be making slow progress on the first as I don't have a soldering iron at home ATM so it will all be done in fits and starts after work
:shock: :o

So be nice & play fair please!
:D

User avatar
exxos
Site Admin
Site Admin
Posts: 9597
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Life, the universe & everything...Atari (well, mostly)

Post by exxos » Fri Mar 13, 2020 3:59 pm

JezC wrote:
Fri Mar 13, 2020 3:49 pm
Seriously though, I will be making slow progress on the first as I don't have a soldering iron at home
:chairsmack: :smackbum:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Tomswork
Posts: 114
Joined: Fri Nov 22, 2019 10:05 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by Tomswork » Fri Mar 13, 2020 5:08 pm

I'm going to take my h4 to work to use the fancy heat gun on them it has a vacum and temp laser probe on. I will be by myself in a hugs lab because everyone is taking time off for spring break and the covid scare

:cheer:

Tom

JezC
Posts: 281
Joined: Mon Aug 28, 2017 11:44 pm

Re: Life, the universe & everything...Atari (well, mostly)

Post by JezC » Sun Mar 15, 2020 5:31 pm

Managed to squeeze in a few minutes of retro-activity between DIY chores this afternoon...
:D

So I now know my 2x 27C512 EPROMs programmed up with my split & chopped Diag ROM image are working OK in a different 520 STFM.

Next task (hopefully this evening) is to find a suitable null modem cable to connect it to a PC so I can try to diagnose the ram fault on one of the donor boards (and possibly also what is stopping the other donor board even booting to show any activity on the display if time allows).

Will probably try GhostLink to prove the cable operation between PC and working ST & then with DiagROM in the donor(s)...

Post Reply

Return to “MEMBER BLOGS”