Brett's STE - Repair thread

Blogs & guides and tales of woo by forum members.
Post Reply
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 5453
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Brett's STE - Repair thread

Post by rubber_jonnie » Wed Jan 12, 2022 1:31 pm

Many of you have seen the posts relating to the STE belonging to @BrettRogersUK.

The machine has a certain amount of sentimental value as Brett has owned it for a long time now.

Unfortunately there were a few desoldering problems during a TOS switcher upgrade, and the machine no longer boots properly, just landing on a white screen.

The white screen can often mean that there is a problem accessing the ROMs, and given there is trace damage in that area, that's where I'll be looking first in order to try and figure out what the problem is.

I'll be sure to add lots of pictures to the thread so everybody can see what I'm up to, and fingers crossed, with the help of my working STEs, I can figure out what the problem is and get it running again.

Fingers crossed, it'll be with me tomorrow ready for an assessment of what I need to do.
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...

User avatar
Icky
Site Admin
Site Admin
Posts: 3310
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Brett's STE - Repair thread

Post by Icky » Wed Jan 12, 2022 1:55 pm

Looking forward to the thread @rubber_jonnie and hopefully @BrettRogersUK will get his beloved STE back and on its feet.

User avatar
JezC
Posts: 1415
Joined: Mon Aug 28, 2017 11:44 pm

Re: Brett's STE - Repair thread

Post by JezC » Wed Jan 12, 2022 2:42 pm

I'll be following this with interest as I have 3x STE's waiting for me to fit the exxos ROM switchers into.

Also hoping that I don't cause any damage to them in the process (though one needs the SIMM sockets replacing before I do any other changes!)

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 5453
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Brett's STE - Repair thread

Post by rubber_jonnie » Wed Jan 12, 2022 3:01 pm

Icky wrote:
Wed Jan 12, 2022 1:55 pm
Looking forward to the thread @rubber_jonnie and hopefully @BrettRogersUK will get his beloved STE back and on its feet.
Cheers, I'm quite looking forward to the challenge :)
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 5453
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Brett's STE - Repair thread

Post by rubber_jonnie » Wed Jan 12, 2022 3:01 pm

JezC wrote:
Wed Jan 12, 2022 2:42 pm
I'll be following this with interest as I have 3x STE's waiting for me to fit the exxos ROM switchers into.

Also hoping that I don't cause any damage to them in the process (though one needs the SIMM sockets replacing before I do any other changes!)
Well, I hope this'll be helpful :)
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...

User avatar
exxos
Site Admin
Site Admin
Posts: 17150
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Brett's STE - Repair thread

Post by exxos » Wed Jan 12, 2022 3:02 pm

Looking forward to its resurrection and diagnosis :thumbup: oh and bodge wires :excited: :excited: :excited:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 5453
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Brett's STE - Repair thread

Post by rubber_jonnie » Wed Jan 12, 2022 3:05 pm

exxos wrote:
Wed Jan 12, 2022 3:02 pm
Looking forward to its resurrection and diagnosis :thumbup: oh and bodge wires :excited: :excited: :excited:
Me too!!
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...

BrettRogersUK
Posts: 69
Joined: Wed Sep 15, 2021 12:48 am

Re: Brett's STE - Repair thread

Post by BrettRogersUK » Wed Jan 12, 2022 3:35 pm

exxos wrote:
Wed Jan 12, 2022 3:02 pm
Looking forward to its resurrection and diagnosis :thumbup: oh and bodge wires :excited: :excited: :excited:
Already quite a few bodge wires on it in the TOS roms area on the underside of the board.

I'd like to thank @rubber_jonnie for looking at it for me as I don't have the necessary test equipment to diagnose the fault.

I'm looking forward to following this thread and looking forward (hopefully) to having it working again.

Thanks to everyone involved!

Regards,

Brett

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 5453
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Brett's STE - Repair thread

Post by rubber_jonnie » Wed Jan 12, 2022 3:52 pm

BrettRogersUK wrote:
Wed Jan 12, 2022 3:35 pm
exxos wrote:
Wed Jan 12, 2022 3:02 pm
Looking forward to its resurrection and diagnosis :thumbup: oh and bodge wires :excited: :excited: :excited:
Already quite a few bodge wires on it in the TOS roms area on the underside of the board.

I'd like to thank @rubber_jonnie for looking at it for me as I don't have the necessary test equipment to diagnose the fault.

I'm looking forward to following this thread and looking forward (hopefully) to having it working again.

Thanks to everyone involved!

Regards,

Brett
We'll get there Brett :)
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 5453
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Brett's STE - Repair thread

Post by rubber_jonnie » Thu Jan 13, 2022 8:58 am

Ok, the board arrived when I was having breakfast, so I will try and get it unboxed and onto the workbench sometime today for an initial assessment and some photos :)
Collector of many retro things!
800XL and 65XE both with Ultimate1MB,VBXL/XE & PokeyMax, SIDE3, SDrive Max, 2x 1010 cassette, 2x 1050 one with Happy mod, 3x 2600 Jr, 7800 and Lynx II
Approx 20 STs, including a 520 STM, 520 STFMs, 3x Mega ST, MSTE & 2x 32 Mhz boosted STEs
Plus the rest, totalling around 50 machines including a QL, 3x BBC Model B, Electron, Spectrums, ZX81 etc...

Post Reply

Return to “MEMBER BLOGS”