PCB Build - Progress - Post your Pics here :-)

Open source STF clone project.
User avatar
exxos
Site Admin
Site Admin
Posts: 4089
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: PCB Build - Progress - Post your Pics here :-)

Post by exxos » Sat Sep 08, 2018 8:58 am

kodak80 wrote:
Sat Sep 08, 2018 1:18 am
Australian boards have arrived safely.
:bravo:


See here.. viewtopic.php?f=19&t=1171
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Trusted Guru
Trusted Guru
Posts: 498
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: PCB Build - Progress - Post your Pics here :-)

Post by Icky » Sat Sep 08, 2018 11:20 am

I have a day set out for soldering today am actually looking forward to working on this great Exxos board.

I have been looking at some alignments on matching the rom cartridge port up with the STFM donor board I have. The rom port and MIDI connectors are in line but It looks like the top side of the Alpha board is slightly taller.

IMG_3004.png
IMG_3004.png (1.84 MiB) Viewed 312 times

How does this look in the case. All the ports along the back line up except the floppy connector is slightly out.

IMG_3009.png
IMG_3009.png (1.63 MiB) Viewed 312 times

Forgottenmyname
Trusted Guru
Trusted Guru
Posts: 422
Joined: Fri Mar 23, 2018 8:22 pm

Re: PCB Build - Progress - Post your Pics here :-)

Post by Forgottenmyname » Sat Sep 08, 2018 11:56 am

Looks pretty good to me. I'm at the small component stage now, which is going to take a while.

Got the MMU ram board all ready to go but can't for the life of me find my second 6850.

I am aiming at doing the bare minimum so far to get the board up and running, so things like the serial port and falcon ram port will likely get done later.

I am however going to put the cartridge port in, in case I need to use the diagnostic board.

What are you guys doing with the reset switch? As you know, the pins don't line up.

User avatar
Icky
Trusted Guru
Trusted Guru
Posts: 498
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: PCB Build - Progress - Post your Pics here :-)

Post by Icky » Sat Sep 08, 2018 12:19 pm

Forgottenmyname wrote:
Sat Sep 08, 2018 11:56 am
What are you guys doing with the reset switch? As you know, the pins don't line up.
Thats an interesting one. For the MIDI ports I am thinking of drilling two new holes for the wider ground pins. I think there is only the ground plane underneath. I was just going to bridge to the actual holes with solder.

For the reset - I wonder if we could do the same. Centre on the centre pin and drill some holes slightly off of the outside pins to align and bridge. Same for the lugs drill. Am just afraid there are some tracks under there.

Thoughts?

User avatar
exxos
Site Admin
Site Admin
Posts: 4089
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: PCB Build - Progress - Post your Pics here :-)

Post by exxos » Sat Sep 08, 2018 12:25 pm

Drilling might be a bad idea as 5v & 0v are middle layers..

IMHO I wouldn't bother trying to fit this board to a case, there are no case holes even, its a test board literally to see if it all works :)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Trusted Guru
Trusted Guru
Posts: 498
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: PCB Build - Progress - Post your Pics here :-)

Post by Icky » Sat Sep 08, 2018 12:34 pm

exxos wrote:
Sat Sep 08, 2018 12:25 pm
Drilling might be a bad idea as 5v & 0v are middle layers..

IMHO I wouldn't bother trying to fit this board to a case, there are no case holes even, its a test board literally to see if it all works :)
Indeed - you are right this is a functional board but seeing it in the case gives a sense of the achievement you have made Exxos.

:bravo:

User avatar
exxos
Site Admin
Site Admin
Posts: 4089
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: PCB Build - Progress - Post your Pics here :-)

Post by exxos » Sat Sep 08, 2018 12:37 pm

Icky wrote:
Sat Sep 08, 2018 12:34 pm

Indeed - you are right this is a functional board but seeing it in the case gives a sense of the achievement you have made Exxos.

:bravo:
If you can post what needs fixing in the to fix topic, then it helps keep track of what needs to be done on the next board :)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Trusted Guru
Trusted Guru
Posts: 498
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: PCB Build - Progress - Post your Pics here :-)

Post by Icky » Sat Sep 08, 2018 1:28 pm

exxos wrote:
Sat Sep 08, 2018 12:37 pm
If you can post what needs fixing in the to fix topic, then it helps keep track of what needs to be done on the next board :)
Will do

Forgottenmyname
Trusted Guru
Trusted Guru
Posts: 422
Joined: Fri Mar 23, 2018 8:22 pm

Re: PCB Build - Progress - Post your Pics here :-)

Post by Forgottenmyname » Sat Sep 08, 2018 2:00 pm

I might put some header pins into the pcb and then put the reset switch on its side.

Will post a pic if that works out ok

Atarian Computing
Posts: 251
Joined: Tue Aug 22, 2017 4:27 am

Re: PCB Build - Progress - Post your Pics here :-)

Post by Atarian Computing » Sat Sep 08, 2018 3:07 pm

Had a productive day. Missing the floppy cable and a 7402 and the Blitter (oh and the reset switch). Also need a RAM card. Other than that it's pretty much done. I haven't inspected my soldering. I can already see problems. I had soooo much flux goo that I had to clean it with IPA. So I'll go through everything carefully a couple of times. That was so much fun!
IMG_0286.jpg
IMG_0286.jpg (2.56 MiB) Viewed 280 times
IMG_0280.JPG
IMG_0280.JPG (2.52 MiB) Viewed 280 times

Post Reply