Video driver thoughts

All information relating to the Alpha plus all the WIP threads etc.
Post Reply
User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Video driver thoughts

Post by exxos » Thu Sep 27, 2018 9:33 pm

I thought about this before basically I think the conclusion was that it was hard to get any simple video DACs now..I do have a huge stack of the Falcon ones though..

It is a six bit input, so likely the STF would have to tie 2 inputs together.. But it would probably work.. I don't think there is any advantage to this other than being less parts. I guess I could do a small adapter PCB to plug into the video buffer area to try it out one day..

fvd.jpg
fvd.jpg (77.57 KiB) Viewed 1482 times

EDIT:

There are ones like this...

https://www.mouser.co.uk/new/Analog-Dev ... v7125-dac/

But really huge overkill for this stuff... we only really need 3 bit inputs, 4 tops, these are 8 bit..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rpineau
Site Admin
Site Admin
Posts: 491
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: Video driver thoughts

Post by rpineau » Thu Sep 27, 2018 9:56 pm

You also need the dot clock (ICLK).. I'm not sure that's the 32MHz clock there as on the Falcon it's generated by the VIDEL.
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Video driver thoughts

Post by exxos » Thu Sep 27, 2018 10:09 pm

rpineau wrote:
Thu Sep 27, 2018 9:56 pm
You also need the dot clock (ICLK).. I'm not sure that's the 32MHz clock there as on the Falcon it's generated by the VIDEL.
Yeah, can use any clock on this board.. Though not sure why its there really in the first place, unless its a sampling clock.. in which case just run as fast as possible... I not looked at the datasheet for it yet.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Stimpy
Posts: 25
Joined: Tue Apr 03, 2018 9:19 pm

Re: Video driver thoughts

Post by Stimpy » Fri Sep 28, 2018 8:45 am

I used a falcon video DAC when I did my ST, as it was what i had kicking about. It worked off 32MHz in all resolutions. I just used the MSBs and tied lower bits to ground like any DAC or ADC. I do remember it getting pretty hot though, it was mounted with kynar wire to stripboard so no real thermal stuff and driving RGB down 50 or 75 ohm loads is pretty hard going. Must be better solutions, maybe that is just HDMI....

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Video driver thoughts

Post by exxos » Fri Oct 19, 2018 12:53 pm

Another thing the video suffers is when the floppy drive is accessed, it causes a momentary drop in voltage which you can see on the monitor as the white border dimming.. Of course a lot of this is down to the power supply.. Could actually be improved and I have done just that the test before in the past..

I took this reading off the remake board just..

dip.png
dip.png (3.12 KiB) Viewed 1370 times

Of course I'm only powering it my bench power supply isn't exactly ideal to start with.. Shows the issue clearly..

Fix I did previously was to cut the 5V from the shifter and RGB drivers, and run them by their own regulator powered from the 12 V rail. This helps considerably..

I talked about not needing 12 V on the remake board in the future, but if we seemed it was still going to have 12 V on the power supply then the next revision of motherboard can run the video circuit its own 5 V regulator.

I have noticed a little bit of wavy lines video of the remake board, this is probably down to the missing capacitors on the RGB lines.. So likely those will be added on the next board..

Of course we still have the option of using the video DAC from the Falcon... But this needs to be tested first... So likely what I will have to do is design small shifter adapter board to use this DAC and see how well it performs..


EDIT:
After upping the brightness on the RGB drivers, I don't think I even noticed this problem now.. But still my thoughts still remain about improving the circuit..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Video driver thoughts

Post by exxos » Fri Oct 19, 2018 9:11 pm

exxos has been at the lib editor again (everyone should be afraid and run and hide)


Basically idea is a shifter break out board. This board plugs into the shifter socket, then the shifter plugs into this board.

The RGB outputs from the shifter (digital) Go to the video DAC. The output of the DAC will need 3 jumper wires going to the video socket.. This can be done relatively easily as there are 33R resistors which can be lifted to isolate the original RGB circuit and patching in the new one.

Technically the lower un-used bits on the DAC can probably have some jumpers for a crude brightness select.

Still have some more wiring up to do yet though..

s1.jpg
s1.jpg (48.26 KiB) Viewed 1342 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1358
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Video driver thoughts

Post by Icky » Fri Oct 19, 2018 9:14 pm

exxos wrote:
Fri Oct 19, 2018 9:11 pm
exxos has been at the lib editor again (everyone should be afraid and run and hide)
Piggy back board time again :D

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Video driver thoughts

Post by exxos » Fri Oct 19, 2018 9:16 pm

Icky wrote:
Fri Oct 19, 2018 9:14 pm
Piggy back board time again :D
Gotta keep you all busy ;)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rpineau
Site Admin
Site Admin
Posts: 491
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: Video driver thoughts

Post by rpineau » Fri Oct 19, 2018 9:21 pm

the unused input (R,G,B) should be grounded or you'll get weird interferences in the colors :)
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
exxos
Site Admin
Site Admin
Posts: 7832
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Video driver thoughts

Post by exxos » Fri Oct 19, 2018 9:24 pm

rpineau wrote:
Fri Oct 19, 2018 9:21 pm
the unused input (R,G,B) should be grounded or you'll get weird interferences in the colors :)
yep, just doing that now, putting jumper on input for a brightness control.. see what effect it has :)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “ALPHA DEVELOPMENT INFO”