Video driver thoughts

Super ST Project. Lets create a awesome new ST! Fix all the bugs and add more cool stuff!
User avatar
Icky
Moderator
Moderator
Posts: 1274
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Video driver thoughts

Post by Icky » Thu Nov 29, 2018 9:47 pm

Icky wrote:
Thu Nov 29, 2018 9:23 pm
exxos wrote:
Thu Nov 29, 2018 9:17 pm
@ Icky, I wonder if you can try the normal RGB circuit, but lift out the BLACKing didoes D1,D2,D3 ?
Just in the process of getting the video uploaded of the motherboard driver circuit in play.

Then I may get time to lift the blanking diodes - non-Atari duties are calling tonight.
Well I did say it was dark - didn't realise how dark until I filmed it


User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Video driver thoughts

Post by exxos » Thu Nov 29, 2018 9:52 pm

Who is awesome :D :D :D

IMG_3622.JPG
IMG_3622.JPG (64.57 KiB) Viewed 712 times

IMG_3623.JPG
IMG_3623.JPG (78.78 KiB) Viewed 712 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1274
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Video driver thoughts

Post by Icky » Thu Nov 29, 2018 9:54 pm

exxos wrote:
Thu Nov 29, 2018 9:52 pm
Who is awesome :D :D :D
Exxos is awesome - How did you do that :cheer: :cheer: :cheer:

User avatar
sandord
Trusted Guru
Trusted Guru
Posts: 596
Joined: Mon Aug 13, 2018 10:08 pm
Location: The Netherlands
Contact:

Re: Video driver thoughts

Post by sandord » Thu Nov 29, 2018 9:55 pm

exxos wrote:
Thu Nov 29, 2018 9:52 pm
Who is awesome :D :D :D

IMG_3622.JPG

IMG_3623.JPG
It's Chris Norris!! :yay2: :dualthumbup:

User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Video driver thoughts

Post by exxos » Thu Nov 29, 2018 9:58 pm

Icky wrote:
Thu Nov 29, 2018 9:54 pm
Exxos is awesome - How did you do that :cheer: :cheer: :cheer:

I lifted that highlighted pin which, and linked to small wire from it to the BLANKing line...

So when BLANK is high, it selects D-RGB mode, when BLANK is low it selects A-RGB mode...

Technically the A-RGB lines are floating, but at this time of night I did not care, and it works anyway so :cheer: :cheer:

i1.jpg
i1.jpg (42.38 KiB) Viewed 705 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
Icky
Moderator
Moderator
Posts: 1274
Joined: Sun Sep 03, 2017 10:57 am
Location: UK

Re: Video driver thoughts

Post by Icky » Thu Nov 29, 2018 10:00 pm

exxos wrote:
Thu Nov 29, 2018 9:58 pm
Icky wrote:
Thu Nov 29, 2018 9:54 pm
Exxos is awesome - How did you do that :cheer: :cheer: :cheer:

I lifted that highlighted pin which, and linked to small wire from it to the BLANKing line...

So when BLANK is high, it selects D-RGB mode, when BLANK is low it selects A-RGB mode...

Technically the A-RGB lines are floating, but at this time of night I did not care, and it works anyway so :cheer: :cheer:
Brilliant so it was blanking related :D

Question now is to compare original circuit against new DAC circuit to see improvement.

User avatar
exxos
Site Admin
Site Admin
Posts: 7416
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Video driver thoughts

Post by exxos » Thu Nov 29, 2018 10:06 pm

Icky wrote:
Thu Nov 29, 2018 10:00 pm
Question now is to compare original circuit against new DAC circuit to see improvement.
Sadly it looks the same :roll:

Mostly I was trying to get rid of the vertical noise lines in the drag bar but they are still there... Only now they seem to be flickering a little bit...

I do have some 40R resistors in series with the RGB outputs with 47pF on them.. so its not like its noise there...


Gave myself permission to upload a high res shot to illustrate this...

IMG_3626.JPG
IMG_3626.JPG (4.91 MiB) Viewed 698 times

The thing is, I don't think I saw this on the Falcon video.. and its the same chip now :roll:

BTW - the jumper does up the brightness a little, not a great deal...
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

stephen_usher
Posts: 312
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: Video driver thoughts

Post by stephen_usher » Thu Nov 29, 2018 10:08 pm

So, is this a similar issue to the “front porch”/“back porch” video generation issues that the early ZX81 ULAs had?

Basically in that case the ULA didn’t produce a “back porch” on the video signal so the TV/monitor circuitry couldn’t determine the base level of the signal. In the case of the ZX81 color TVs took the “white” level to be black and dimmed the display accordingly.

I guess that in this case the monitor could be taking a floating value as the black level, when the border is white. When it’s black then it emulates a back porch.
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
PhilC
Moderator
Moderator
Posts: 1643
Joined: Fri Mar 23, 2018 8:22 pm

Re: Video driver thoughts

Post by PhilC » Thu Nov 29, 2018 10:09 pm

Well done guys. Looking better and better.

You'll get there with the quality thing Exxos, just take a bit of tweaking is all.

Will lift the pin tomorrow and catch up yet again, lol.

Still didn't fix the floppy drive problem, too busy with Fallout 76.
If it ain't broke, test it to Destruction.

stephen_usher
Posts: 312
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: Video driver thoughts

Post by stephen_usher » Thu Nov 29, 2018 10:09 pm

exxos wrote:
Thu Nov 29, 2018 10:06 pm
Icky wrote:
Thu Nov 29, 2018 10:00 pm
Question now is to compare original circuit against new DAC circuit to see improvement.
Sadly it looks the same :roll:

Mostly I was trying to get rid of the vertical noise lines in the drag bar but they are still there... Only now they seem to be flickering a little bit...

I do have some 40R resistors in series with the RGB outputs with 47pF on them.. so its not like its noise there...


Gave myself permission to upload a high res shot to illustrate this...


IMG_3626.JPG


The thing is, I don't think I saw this on the Falcon video.. and its the same chip now :roll:

BTW - the jumper does up the brightness a little, not a great deal...
It looks like your display is doing a great deal of “sharpening”. Lots of nasty halos!
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

Post Reply