Page 5 of 8

Re: MMU SMT ADAPTERS - WIP

Posted: Thu Mar 28, 2019 9:13 pm
by exxos
Could also be a missing RAS/CAS line I guess...

22222.jpg
22222.jpg (73.55 KiB) Viewed 898 times

Re: MMU SMT ADAPTERS - WIP

Posted: Thu Mar 28, 2019 9:32 pm
by PhilC
Mad8 is certainly soldered. I'll check the other lines on Saturday Afternoon as Grandparent duties are called for tomorrow night and Saturday morning.

Which schematic did you base it on? I can at least meter/scope it out to the ram chips, glue etc when I plug it back in.

Re: MMU SMT ADAPTERS - WIP

Posted: Thu Mar 28, 2019 10:34 pm
by exxos
PhilC wrote:
Thu Mar 28, 2019 9:32 pm
Which schematic did you base it on? I can at least meter/scope it out to the ram chips, glue etc when I plug it back in.
SMT MMU
viewtopic.php?f=31&t=149


PLCC MMU
http://dev-docs.exxoshost.co.uk/520ST_Schematic.pdf


My schematic..
mmu.png
mmu.png (298.59 KiB) Viewed 894 times

Re: MMU SMT ADAPTERS - WIP

Posted: Sat Mar 30, 2019 4:33 pm
by PhilC
I've checked all of the MAD lines and they go where they are supposed to go.
I've also checked your schematic and as expected it goes where it's supposed to go.

I'll pop the SMT MMU back into my Mega but I'm wondering if its a connection problem similar to that on the STE plug in booster and that I need to 3d print a spacer to keep the pins in place when there is no MMU in the socket.

Re: MMU SMT ADAPTERS - WIP

Posted: Sat Mar 30, 2019 4:53 pm
by exxos
Bummer. I guess you could scope out the row of ram resistors and see if any lines are not switching..

I'll have to get some more boards made and try them out.. I lost all the others :(

Re: MMU SMT ADAPTERS - WIP

Posted: Sat Mar 30, 2019 4:58 pm
by PhilC
Will do, need to fix my patch wire first though.

Re: MMU SMT ADAPTERS - WIP

Posted: Sat Mar 30, 2019 6:09 pm
by PhilC
Thats the wire patched to MAD9 for my 4mb but I'm now only showing 2mb with my original MMU. The good news is the SMT MMU is also showing 2MB, so it looks like my socket is broken! Will try cleaning it up and see what happens then with the SMT and normal MMU

Re: MMU SMT ADAPTERS - WIP

Posted: Sat Mar 30, 2019 6:27 pm
by PhilC
So, my MMU socket on this Mega is a bit dodgy. I've finally managed to get it running again with the original MMU at 4mb.

Although, in my messing around trying to get the SMT MMU working I've managed to free the magic black smoke from inside it.

I'll locate another SMT MMU this week and will try again. I am reaqsonably confident that this mod works fine but will probably want a spacer / blank put into the MMU socket to stop the socket pins flexing too far to make contact with the header pins.

This does look a great mod installed. The green PCB even matches well .
20190330_182715.jpg
20190330_182715.jpg (526.89 KiB) Viewed 865 times

Re: MMU SMT ADAPTERS - WIP

Posted: Sun Mar 31, 2019 10:16 pm
by exxos
PhilC wrote:
Sat Mar 30, 2019 6:27 pm
Although, in my messing around trying to get the SMT MMU working I've managed to free the magic black smoke from inside it.
Your released the terrible fire! :fire: :fire: :fire:

Re: MMU SMT ADAPTERS - WIP

Posted: Sun Mar 31, 2019 10:16 pm
by exxos
Lookies what I just found while looking for something else (which I didn't find :lol: :roll: )

IMG_3930.JPG
IMG_3930.JPG (54.42 KiB) Viewed 849 times