MMU SMT ADAPTERS - WIP

Super ST Project. Lets create a awesome new ST! Fix all the bugs and add more cool stuff!
User avatar
PhilC
Moderator
Moderator
Posts: 1729
Joined: Fri Mar 23, 2018 8:22 pm

Re: MMU SMT ADAPTERS - WIP

Post by PhilC » Wed Apr 03, 2019 5:49 pm

And we're back in action.

And with an unusual problem.

It seems that CAS is high all of the time on U44 to U47 on my Mega, hence only seeing the 2mb of ram when using the SMT MMU. Plug the old MMU back in and its back to 4mb right away. Continuity to pins 17 and 18 from the ram chips is fine. I'm just wondering if it's anything to do with the type of ram that I'm using. I've got the SOJ20 to 20pin DIL adaptors with 514400 ram installed.

Edit 1

Just looking at the ST schematic in comparison to what I have and the resistors on the schematic for the CAS lines show 68ohm. I'm measuring 35ohm on all 4 connections. Now to try and track down a C103277 Rev 2.2 schematic

Edit 2

And 33ohm is what its supposed to have. on /WE /RAS /CAS etc. /OE is low on all ram chips and /WE is high, so at the mo I have no idea. when I plug the PLCC MMU back in it works straight away at 4mb. This is also the second SMT MMU i've used and its exactly the same.

@exxos, when you checked your MMU, was it on a 4mb ST?
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7649
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: MMU SMT ADAPTERS - WIP

Post by exxos » Wed Apr 03, 2019 8:01 pm

PhilC wrote:
Wed Apr 03, 2019 5:49 pm
@exxos, when you checked your MMU, was it on a 4mb ST?
It was a 1MB machine. But I will try and get it tested on my 4MB one tomorrow.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1729
Joined: Fri Mar 23, 2018 8:22 pm

Re: MMU SMT ADAPTERS - WIP

Post by PhilC » Wed Apr 03, 2019 8:19 pm

exxos wrote:
Wed Apr 03, 2019 8:01 pm
PhilC wrote:
Wed Apr 03, 2019 5:49 pm
@exxos, when you checked your MMU, was it on a 4mb ST?
It was a 1MB machine. But I will try and get it tested on my 4MB one tomorrow.
Can you also try booting a floppy with it please? My Gotek wont boot with that MMU installed but once again, put the old one back in and it boots.

This Mega has had all the floppy patches btw.
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7649
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: MMU SMT ADAPTERS - WIP

Post by exxos » Wed Apr 03, 2019 9:53 pm

PhilC wrote:
Wed Apr 03, 2019 8:19 pm
Can you also try booting a floppy with it please? My Gotek wont boot with that MMU installed but once again, put the old one back in and it boots.

This Mega has had all the floppy patches btw.
I always use floppy.. So its working fine :) In fact I have been testing 1772 chips most of yesterday, so formatting 1.44 floppies loads all day. No issues.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1729
Joined: Fri Mar 23, 2018 8:22 pm

Re: MMU SMT ADAPTERS - WIP

Post by PhilC » Wed Apr 03, 2019 9:58 pm

It might be my Ram playing up AGAIN. I'll have a look at this over the next few days but I think my Ram was ok, until I did the usual playing around to double check all the connections for/OE etc, so would still be cool if you can rule out the 4mb thing. At least I'll know I have to find ANOTHER day joint in my Ram circuit then.

Old Ataris. Who in their right mind would have one!
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7649
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: MMU SMT ADAPTERS - WIP

Post by exxos » Wed Apr 03, 2019 10:41 pm

Just got home, tried my 4MB machine and it sees and tests 4MB fine. So the SMT MMU board is good.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
PhilC
Moderator
Moderator
Posts: 1729
Joined: Fri Mar 23, 2018 8:22 pm

Re: MMU SMT ADAPTERS - WIP

Post by PhilC » Thu Apr 04, 2019 6:36 am

Ok thanks. More repairs needed.

I think I may just dump the ram and fit a 4mb upgrade, bypass all the old stuff.
If it ain't broke, test it to Destruction.

User avatar
PhilC
Moderator
Moderator
Posts: 1729
Joined: Fri Mar 23, 2018 8:22 pm

Re: MMU SMT ADAPTERS - WIP

Post by PhilC » Thu Apr 04, 2019 9:11 am

Will try it in my Alpha board later on but I'm quite sure it works.

Not bragging but I did some of my best SMT work when I soldered the replacement chip in.

Then time to fix the Mega, put a TF534 in it and leave it alone :D
If it ain't broke, test it to Destruction.

User avatar
PhilC
Moderator
Moderator
Posts: 1729
Joined: Fri Mar 23, 2018 8:22 pm

Re: MMU SMT ADAPTERS - WIP

Post by PhilC » Thu Apr 04, 2019 3:05 pm

Amusingly my Mega now works again, thanks to a dodgy pin on a socket and with the original MMU I see 4mb. Still only see 2mb with the new one.

I'll dig out the STF Remake and try it on there. Going to leave this poor old fragile Mega alone now (at least until I get my pak back or put a TF534in it )
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7649
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: MMU SMT ADAPTERS - WIP

Post by exxos » Thu Apr 04, 2019 3:09 pm

Think that MEGA is very poorly!
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply