Server updates

Latest Atari related news.
User avatar
derkom
Trusted Guru
Trusted Guru
Posts: 627
Joined: Sun Jul 29, 2018 6:45 pm

Re: Server updates

Post by derkom » Sat Feb 20, 2021 3:53 pm

exxos wrote:
Sat Feb 20, 2021 3:44 pm
Getsll has replied and looking into it.. I think he's a bit puzzled as well..
Good to hear that you got a quick response there. If they are puzzled, that bodes well for a solution. :mrgreen:

User avatar
exxos
Site Admin
Site Admin
Posts: 13713
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Server updates

Post by exxos » Sun Feb 21, 2021 12:21 am

So apache is still loading the old cert dispite me putting in the new certs... BUT.. I'm wondering if I've done something dumb...

In the sites enabled folder, does anyone know if apache loads *all* files in there, or just the ones ending in .conf? Because I was putting XXX on the end of some to disable them ( reloading apache ) but I can only think apache is still loading them which has the old certs listed.. Its the only place I can see apache is getting the old info from...

I've deleted the files, but I can't restart the server until I get back home... Meanwhile does apache load site info from anywhere else, other than apache.conf that is ?
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
derkom
Trusted Guru
Trusted Guru
Posts: 627
Joined: Sun Jul 29, 2018 6:45 pm

Re: Server updates

Post by derkom » Sun Feb 21, 2021 7:05 am

exxos wrote:
Sun Feb 21, 2021 12:21 am
In the sites enabled folder, does anyone know if apache loads *all* files in there, or just the ones ending in .conf? Because I was putting XXX on the end of some to disable them ( reloading apache ) but I can only think apache is still loading them which has the old certs listed.. Its the only place I can see apache is getting the old info from...
This is under the control of your main apache2.conf* file. Typically it'll include a line like "IncludeOptional sites-enabled/*.conf", which as you can imagine will load only files ending in ".conf". You should have a look at your own apache2.conf to verify, but this is probably what you have as well.

Sometimes if I want to be very sure that a config file isn't getting loaded, but for some reason I don't wish to simply move it out of the directory, I'll gzip it. Nothing is going to read a gzipped config file, so at worst I'll get an error if it tries to parse it anyway. Then I can be sure the file isn't being loaded, and I don't have to figure out later on where I stashed it.
I've deleted the files, but I can't restart the server until I get back home... Meanwhile does apache load site info from anywhere else, other than apache.conf that is ?
Again this is under the control of that master configuration file. Look for "Include" and "IncludeOptional" lines in your master apache2.conf, and do bear in mind these commands can cascade, so if any included files contain their own Include directives, you need to follow the tree on down.

* Your main configuration file may be called something different, depending on your specific installation.

stephen_usher
Trusted Guru
Trusted Guru
Posts: 1263
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: Server updates

Post by stephen_usher » Sun Feb 21, 2021 9:38 am

derkom wrote:
Sat Feb 20, 2021 3:22 pm
stephen_usher wrote:
Sat Feb 20, 2021 12:34 pm
Certbot changed their distribution and install method, which only supports a very small number of "blessed" Linux distributions. They broke it for all other distros and operating systems.
Really? Looking at https://certbot.eff.org/, I see a whole slew of Linux distros supported, including "other Linux" (which unfortunately requires installing snapd, but it's an option at least), as well as FreeBSD, OpenBSD, macOS, and Windows.
Indeed, it's snapd which is the issue, as that only supports a small subset of distributions.
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

User avatar
derkom
Trusted Guru
Trusted Guru
Posts: 627
Joined: Sun Jul 29, 2018 6:45 pm

Re: Server updates

Post by derkom » Sun Feb 21, 2021 10:04 am

stephen_usher wrote:
Sun Feb 21, 2021 9:38 am
Indeed, it's snapd which is the issue, as that only supports a small subset of distributions.
Gotcha. I have managed so far to avoid going down that path... :D

User avatar
exxos
Site Admin
Site Admin
Posts: 13713
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Server updates

Post by exxos » Sun Feb 21, 2021 11:30 am

derkom wrote:
Sun Feb 21, 2021 7:05 am
This is under the control of your main apache2.conf* file. Typically it'll include a line like "IncludeOptional sites-enabled/*.conf", which as you can imagine will load only files ending in ".conf". You should have a look at your own apache2.conf to verify, but this is probably what you have as well.
Yeah , its not those files :( I may brute-force it all and just rename the lets encrypt folder so Apache simply can't load the certs, then see what errors and trace it that way.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
derkom
Trusted Guru
Trusted Guru
Posts: 627
Joined: Sun Jul 29, 2018 6:45 pm

Re: Server updates

Post by derkom » Sun Feb 21, 2021 1:05 pm

exxos wrote:
Sun Feb 21, 2021 11:30 am
I may brute-force it all and just rename the lets encrypt folder so Apache simply can't load the certs, then see what errors and trace it that way.
The words of a man with a lot of experience working with cantankerous retro hardware. Halt and catch fire. :lol:

User avatar
exxos
Site Admin
Site Admin
Posts: 13713
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Server updates

Post by exxos » Sun Feb 21, 2021 1:41 pm

derkom wrote:
Sun Feb 21, 2021 1:05 pm
The words of a man with a lot of experience working with cantankerous retro hardware. Halt and catch fire. :lol:
:lolbig:

Yeah, crash and burn all the way baby :lol:

Expect the forum to die around 9pm tonight :lol: :roll:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
exxos
Site Admin
Site Admin
Posts: 13713
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Server updates

Post by exxos » Sun Feb 21, 2021 9:08 pm

Sooo

all variations of exxoshost.co.uk (www / http etc) *should* now load , and *should* have a cert which expires in 3 months time...

The problem was indeed the files I had in sites-enabled, I have like domain-ssl.confXXX where XXX I thought would stop apache from loading them.. but how wrong I was! I deleted the files instead and now apache seems to be loading the new certs!
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
exxos
Site Admin
Site Admin
Posts: 13713
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Server updates

Post by exxos » Mon Feb 22, 2021 3:06 pm

My store was erroring relating to the chain.crt missing in my apache config.. so I was getting order payment emails, but no actual orders...

There was only 1 order today which got "lost" (and now fixed) , so nobody needs to worry about missing orders..
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

Post Reply

Return to “NEWS & ANNOUNCEMENTS”