Lightning VME open Order

Latest Atari related news.
User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 626
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: Lightning VME open Order

Post by PaulJ » Thu Feb 28, 2019 12:26 am

I want one for a Mega STE. Thanks for the effort guys. :) :) :)

tuxie
Posts: 153
Joined: Thu Aug 24, 2017 11:51 am

Re: Lightning VME open Order

Post by tuxie » Thu Feb 28, 2019 8:53 am

Please send an mail to thunderstorm@tuxie.de

stephen_usher
Posts: 309
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: Lightning VME open Order

Post by stephen_usher » Thu Feb 28, 2019 12:01 pm

officer960 wrote:
Wed Feb 27, 2019 10:27 pm
My Lightning VME arrived yesterday and after having the same tight fit as @troed the device was installed. I installed the drivers on my
MSTE, TOS 2.06, 4mb, UltraSatan.

I got a USB mouse to work. My computer would acknowledge most of the USB thumb drives, a SD card and USB floppy drive in USB.ACC

However, when I “Install Device” I can not get any of the USB thumb drives, SD cards or floppies to work properly. They show they are empty (there are files on them) and I can not copy files from the MSTE to any of them.
The USB.ACC also recognizes my DVD RW Drive but ExtenDOS 4 does not see it.

I have verified multiple times that XBoot is running the Lightning drivers in the order listed on the WIKI (ExtenDOS after STORAGE.PRG, etc).

What am I doing wrong?
Are your USB thumb drives formatted for the Atari? i.e. an Atari format partition table and FAT16 partitions?
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

Steve
Posts: 265
Joined: Fri Sep 15, 2017 11:49 am

Re: Lightning VME open Order

Post by Steve » Thu Feb 28, 2019 3:49 pm

Yeah TOS can only see fat16 TOS specific partitions. You need to partition them with an atari partitioner.
Falcon ct60e 060 - 256mb ram - phantom bus and dsp accel // Atari TT - Thunder and Storm IDE 64mb ram - Lightning VME - USB LAN - Ati Mach64 2mb // Atari STM 4160 - 4MB ram - 16Mhz exxos 1.5 booster - Ultrasatan

officer960
Posts: 11
Joined: Sun Jul 22, 2018 9:42 pm

Re: Lightning VME open Order

Post by officer960 » Thu Feb 28, 2019 6:00 pm

Thanks to those who responded. I tried FAT16 formatted on PC.

Last night I used HDDRIVER and partitioned a 128mb thumb drive TOS/DOS compatible. It spit out a notice that the partition is only Mint compatible - I'm using plain 2.06 so if anyone has any insight on proper settings I'd appreciate it. I attempted to copy a small file to that thumb drive and after twenty minutes of busy bee, gave up for the evening. I am going to try again tonight with a few different smaller thumb drives and SD cards in readers.

Still no luck with DVD reader being recognized by ExtenDOS 4. the USB .ACC recognized the device but not being found during the ExtenDOS search for devices.
Atari 1040 STFM, Atari Mega ST2, Atari STE (4mb), Atari Mega STE (4mb), Atari Falcon 030, Amiga 2000 V2+, Amiga 2000 Video Toaster GVP030, Amiga 500, Amiga 500+ 030, Amiga 1200 030, MiST

tuxie
Posts: 153
Joined: Thu Aug 24, 2017 11:51 am

Re: Lightning VME open Order

Post by tuxie » Tue Mar 05, 2019 7:13 am

Create Partition on that USB drive, with partitions upto 512MB, before this go to compatibility and check Tos and Windows Compatible (no Byteswap).

Then the stick is usabel using TOS and Windows (Windows 10 supports more then one partition on USB Drives)

officer960
Posts: 11
Joined: Sun Jul 22, 2018 9:42 pm

Re: Lightning VME open Order

Post by officer960 » Fri Mar 08, 2019 9:09 pm

tuxie wrote:
Tue Mar 05, 2019 7:13 am
Create Partition on that USB drive, with partitions upto 512MB, before this go to compatibility and check Tos and Windows Compatible (no Byteswap).

Then the stick is usabel using TOS and Windows (Windows 10 supports more then one partition on USB Drives)
I used a new USB thumb drive and it worked. Thanks. I'll try another DVD or CD drive and see what happens.
Atari 1040 STFM, Atari Mega ST2, Atari STE (4mb), Atari Mega STE (4mb), Atari Falcon 030, Amiga 2000 V2+, Amiga 2000 Video Toaster GVP030, Amiga 500, Amiga 500+ 030, Amiga 1200 030, MiST

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 626
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: Lightning VME open Order

Post by PaulJ » Wed Mar 20, 2019 10:27 pm

Well, I recieved my Lightning VME board last night and installed it this morning. Its a very tight install on a MSTE. There's a Gal in a socket that sits right in from of the plug in area. Had to remove the Gal and it was still really tight. Also getting the Gal back in was also challenging. Once the lightning is plugged in it leaves a tunnel you push the Gal down. You carefully align it with some small screw drivers and carefully push it into the socket. The Gal doesn't appear to have standard leads... there really wimpy and not ridget at all. I was successful and the Lightning works well. Tries a usb mouse, Logitech wireless mouse, some thumb drives. Need to order a ethernet adaptor with the correct chip next. :) :) :)

Also got a Nova card and haven't found a usable isa video card yet. Didn't realize those old isa video cards were made of gold. I'll come up with something.. :mrgreen: :mrgreen: :mrgreen:

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 626
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: Lightning VME open Order

Post by PaulJ » Sat Mar 23, 2019 4:05 pm

Have installed the Lightning VME card and have storage, mouse, and the ethernet driver working I believe. Run uiptool and it completes successfully. However after setting up sting using the control panel saving the sting port setup it corrupts the video even after a could start. Anyone having sting running on a MSTE? A ping to loopback does work.

After saving sting.prt from the sting port setup I have to nuke the auto folder and rebuild from scratch to get things running normally again. Anyone have sting running or seen this behavior?
sting.jpg
sting.jpg (229.82 KiB) Viewed 484 times

User avatar
PaulJ
Trusted Guru
Trusted Guru
Posts: 626
Joined: Sun Apr 08, 2018 1:14 am
Location: USA

Re: Lightning VME open Order

Post by PaulJ » Sun Mar 24, 2019 3:16 pm

Been playing with the Lightning VME with usb ethernet adaptor. Have put the sting package on the back burner because the control panel plugins appear to broken and corrupt the system when used. However I have been playing with uip.tos and it appears to be 100% functional serving a web page but it will not accept writes 98% of the time, they just sit there queued. Once in a while attempting to write a small file say less than 300 bytes it will transfer when dropped on the webpage. All most always it will hang as queued?? Ether it doesn't like ethernet adaptor or the software has an issue. Does anyone know if the uip.tos app source is available. Is there any documentation anywhere? Does anyone with a Lightning have the ethernet working? As you can see from the attachment when I drag and drop it almost always says queued and nothing beyond that ever happens. If you drop more files they just stack up as queued.

My guess is it might work better with a multitasking os?
clogged.png
clogged.png (54.26 KiB) Viewed 467 times

Post Reply