Dead 1040 STf

Problems with your machine in general.
User avatar
exxos
Site Admin
Site Admin
Posts: 4042
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Dead 1040 STf

Post by exxos » Sun Sep 02, 2018 12:17 am

Have you tried pulling and inserting the monitor cable when the problem happens ? Also might be idea to do a good long ram test just to be sure.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
sandord
Posts: 277
Joined: Mon Aug 13, 2018 10:08 pm
Contact:

Re: Dead 1040 STf

Post by sandord » Sun Sep 02, 2018 11:14 am

:roll: :roll: :roll: Aargh! I suddenly realised I had been turning the VHold on de the monitor when my other ST was connected and suddenly had the screen go running exactly when starting a demo.

I guess the VHold setting SC1224 was just on the edge of correctness and crept out of it due to thermal force. At least I hope, not looking forward to do a recapping as I'm already working on a Commodore 1084S that has severe problems.

User avatar
exxos
Site Admin
Site Admin
Posts: 4042
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Dead 1040 STf

Post by exxos » Sun Sep 02, 2018 11:34 am

ah yep.. That really is oldskool issues! I've not used a CRT for really long time.. all those pots get dirty and odd things start to happen. I think most of us are used to TFT stuff these days..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
sandord
Posts: 277
Joined: Mon Aug 13, 2018 10:08 pm
Contact:

Re: Dead 1040 STf

Post by sandord » Sun Sep 02, 2018 10:36 pm

exxos wrote:
Sun Sep 02, 2018 11:34 am
ah yep.. That really is oldskool issues! I've not used a CRT for really long time.. all those pots get dirty and odd things start to happen. I think most of us are used to TFT stuff these days..
I'm still struck by the nostalgic picture of those good old CRTs. Getting one increased the joy of running my ST by at least 70% 😉

KyleB
Posts: 99
Joined: Tue Jul 31, 2018 7:08 pm

Re: Dead 1040 STf

Post by KyleB » Mon Sep 03, 2018 1:30 am

I hate running LCD on these old machines, never looks right. Scaling problems and just odd having a 30 year old computer with a new telly sat on it.

Post Reply