Degraded video quality with 1040 STF (C070523-001 REV.D)

Problems with your machine in general.
User avatar
sandord
Trusted Guru
Trusted Guru
Posts: 594
Joined: Mon Aug 13, 2018 10:08 pm
Location: The Netherlands
Contact:

Degraded video quality with 1040 STF (C070523-001 REV.D)

Post by sandord » Wed Sep 05, 2018 12:18 pm

My 1040 STF (motherboard revision: C070523-001 REV.D) shows degraded video quality.

The signal isn't as sharp as my other ST (an STFM) and there's a faint vertical bar pattern visible, most noticeable when on a white background.

The ST has a recapped ASP34-2 PSU so that shouldn't be the problem.

The cable or the monitor can't be the problem since it gives a perfect picture with my STFM.

What part should a look at first to fix this? Could the caps near the left of the monitor connector be causing this?
IMG_20180905_125930.jpg
IMG_20180905_125930.jpg (3.55 MiB) Viewed 1077 times

User avatar
exxos
Site Admin
Site Admin
Posts: 8586
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Degraded video quality with 1040 STF (C070523-001 REV.D)

Post by exxos » Wed Sep 05, 2018 12:39 pm

Most stf machines I have seen seem to suffer from bad video. I think its just a inherent problem on those machines :(
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
sandord
Trusted Guru
Trusted Guru
Posts: 594
Joined: Mon Aug 13, 2018 10:08 pm
Location: The Netherlands
Contact:

Re: Degraded video quality with 1040 STF (C070523-001 REV.D)

Post by sandord » Wed Sep 05, 2018 12:43 pm

exxos wrote:
Wed Sep 05, 2018 12:39 pm
Most stf machines I have seen seem to suffer from bad video. I think its just a inherent problem on those machines :(
Hmm, that's not very promising. Luckily, the other two STFs that I've had on my bench lately were perfectly fine. Any chance that recapping the motherboard will improve things or are you saying that they've probably been bad straight from the factory?

User avatar
exxos
Site Admin
Site Admin
Posts: 8586
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Degraded video quality with 1040 STF (C070523-001 REV.D)

Post by exxos » Wed Sep 05, 2018 12:47 pm

I've never seen good video on any stf, are they all the same revision of board ?

I think I did look into it ages ago... You could try changing the shifter... I think the only thing which helped was running the shifter direct from a 7805 regulator driven from 12v rail.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
sandord
Trusted Guru
Trusted Guru
Posts: 594
Joined: Mon Aug 13, 2018 10:08 pm
Location: The Netherlands
Contact:

Re: Degraded video quality with 1040 STF (C070523-001 REV.D)

Post by sandord » Wed Sep 05, 2018 12:51 pm

exxos wrote:
Wed Sep 05, 2018 12:47 pm
I've never seen good video on any stf, are they all the same revision of board ?
C070523-001 REV.D: bad
CO70789-001 REV. C1: good
C103088 REV. 2.A: good

User avatar
exxos
Site Admin
Site Admin
Posts: 8586
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Degraded video quality with 1040 STF (C070523-001 REV.D)

Post by exxos » Wed Sep 05, 2018 12:55 pm

sandord wrote:
Wed Sep 05, 2018 12:51 pm

C070523-001 REV.D: bad
CO70789-001 REV. C1: good
C103088 REV. 2.A: good
Ahh yep. Its those silly style boards which be the bad ones.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
sandord
Trusted Guru
Trusted Guru
Posts: 594
Joined: Mon Aug 13, 2018 10:08 pm
Location: The Netherlands
Contact:

Re: Degraded video quality with 1040 STF (C070523-001 REV.D)

Post by sandord » Wed Sep 05, 2018 1:01 pm

exxos wrote:
Wed Sep 05, 2018 12:55 pm
sandord wrote:
Wed Sep 05, 2018 12:51 pm

C070523-001 REV.D: bad
CO70789-001 REV. C1: good
C103088 REV. 2.A: good
Ahh yep. Its those silly style boards which be the bad ones.
Great, at least I don't have to worry about the other ones going bad.

What is it that makes the C070523-001 REV.D silly again?

User avatar
exxos
Site Admin
Site Admin
Posts: 8586
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Degraded video quality with 1040 STF (C070523-001 REV.D)

Post by exxos » Wed Sep 05, 2018 1:11 pm

sandord wrote:
Wed Sep 05, 2018 1:01 pm
What is it that makes the C070523-001 REV.D silly again?
Nothing other than me saying its a silly layout really..

The types with CPU at the front are best layouts.. The ones with CPU next to floppy drive are silly :p

But the 0789 types , all the chips are grouped around the PSU connector. On the 0523 the shifter is in between the power and CPU. So noise generated by the CPU gets passed around the shifter area generating noise.

If for arguments sake the shifter was next to the floppy drive and and the CPU in the middle, then noise generated by the shifter wouldn't effect the CPU.

Basically you don't pass higher current paths next to low current ones like the shifter. Shifter is of course sensitive to noise because of the rgb outputs. The CPU is digital and doesn't really care about rgb noise.

Subject can actually get pretty complicated..but really its just bad layout of parts. So I class them as silly. Plus harder to fit boosters as the cou is in a silly place next to the floppy drive..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
sandord
Trusted Guru
Trusted Guru
Posts: 594
Joined: Mon Aug 13, 2018 10:08 pm
Location: The Netherlands
Contact:

Re: Degraded video quality with 1040 STF (C070523-001 REV.D)

Post by sandord » Wed Sep 05, 2018 1:19 pm

exxos wrote:
Wed Sep 05, 2018 1:11 pm
Nothing other than me saying its a silly layout really..

The types with CPU at the front are best layouts.. The ones with CPU next to floppy drive are silly :p

But the 0789 types , all the chips are grouped around the PSU connector. On the 0523 the shifter is in between the power and CPU. So noise generated by the CPU gets passed around the shifter area generating noise.

If for arguments sake the shifter was next to the floppy drive and and the CPU in the middle, then noise generated by the shifter wouldn't effect the CPU.

Basically you don't pass higher current paths next to low current ones like the shifter. Shifter is of course sensitive to noise because of the rgb outputs. The CPU is digital and doesn't really care about rgb noise.

Subject can actually get pretty complicated..but really its just bad layout of parts. So I class them as silly. Plus harder to fit boosters as the cou is in a silly place next to the floppy drive..
Thanks, that's rather interesting stuff.

I'm thinking of making the CO70789-001 REV. C1 my favourite motherboard, since it has the best features:
- socketed glue/mmu (better upgrade compatibility)
- not silly so good rgb quality ;-)
- 6 ROM sockets so I can move my 6-chip TOS 1.04 from the silly board over to this one
- blitter solder pads, might fit a socket and a blitter in the future
- non j-leaded rams so better upgrade compatibility

User avatar
exxos
Site Admin
Site Admin
Posts: 8586
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: Degraded video quality with 1040 STF (C070523-001 REV.D)

Post by exxos » Wed Sep 05, 2018 1:36 pm

sandord wrote:
Wed Sep 05, 2018 1:19 pm
I'm thinking of making the CO70789-001 REV. C1 my favourite motherboard, since it has the best features:
The CO70789 type are my favorite styles. Versions without the modulator (STF) are same board, even ones with SMT DRAM, basically same board. So really any similar style board of the CO70789 should be a good one.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “HARDWARE ISSUES”