Page 1 of 1

FRAK/2 not working

Posted: Sat May 04, 2019 11:52 am
by ctirad
Hi. I have complete PAK68/3+Frak/1+pupla+panther2 in one of my Megas.
With Frak/1, the setup worked perfectly well at 50Mhz, video card and Ethernet.
The I decided to replace Frak/1 by Frak/2 and the issues started to come.

My PAK (030A revision) GALs were udapted to the latest versions needed for the Frak/2 and checked that required hardware mods are in place. The Frak gals were reprogrammed (just to be sure) and the board checked as well.

The problem is that after putting all together, the PAK still does work as expected, but no FastRAM is detected. The initial memory test just completely skips FastRAM test and continues to boot. I have bunch of proven 72pin SIMM of both types EDO/FPM, so I don't think the problem si there. Also I don't think it is caused by an unstaibility or similiar cause. I also tried to replace osciallator by 32Mhz and achieved the same result.

The worse is, that after PAK upgrade I'm not able to use PAK/1 any more. The machine immeditely crashes when it comes to initial FastRAM test.

Is there some systematic todo, how to debug the Frak? I'm owner of logic analyser and digital osciloscope.