C-Sync on 520ST C070115 REV.2B

Problems with your machine in general.
spbmlb10
Posts: 16
Joined: Sat Jun 22, 2019 7:06 am

C-Sync on 520ST C070115 REV.2B

Post by spbmlb10 » Sat Jun 22, 2019 8:04 am

Hi All,

Here is a few pictures of my 520ST. It has 4mb ram upgrade (very different i know) and 1.4 TOS addition/upgrade.
thumbnail_IMG_6995.jpg
thumbnail_IMG_6995.jpg (399.33 KiB) Viewed 1096 times
thumbnail_IMG_6994.jpg
thumbnail_IMG_6994.jpg (429.02 KiB) Viewed 1096 times
thumbnail_IMG_6993.jpg
thumbnail_IMG_6993.jpg (343.57 KiB) Viewed 1096 times
I'm wanting to know if the c-sync mod can be done on this board i have tried it with no success.

Parts used were from a 520 schematics but not exact revision as i cannot find schematics for it, i have uploaded picture.
sync.jpg
sync.jpg (324.48 KiB) Viewed 1096 times
I used my multimeter and checked I was using correct pins for voltage, ground, h-sync, v-sync and c-sync on pin 2 but no success. Am i doing something wrong?
thumbnail_IMG_6996.jpg
thumbnail_IMG_6996.jpg (277.46 KiB) Viewed 1096 times
I am wanting to use it on via scart out with my OSSC or into my commodore 1084 monitor but require c-sync.

Happy to hear from anyone who might know more

Thanks

User avatar
PhilC
Moderator
Moderator
Posts: 1804
Joined: Fri Mar 23, 2018 8:22 pm

Re: C-Sync on 520ST C070115 REV.2B

Post by PhilC » Sat Jun 22, 2019 10:14 am

That memory upgrade is almost worthy of being called art work.

As for the composite mod, have s look at some of exxos work on the STF remake, it might make it clearer what's required but you'll still need to locate the tracks etc on your board obviously.

Oh and pop some stickers on the eprom windows, may she you having to burn some more roms in the long term.
If it ain't broke, test it to Destruction.

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: C-Sync on 520ST C070115 REV.2B

Post by exxos » Sat Jun 22, 2019 10:24 am

Can't really see have you wired it up from your image..
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

spbmlb10
Posts: 16
Joined: Sat Jun 22, 2019 7:06 am

Re: C-Sync on 520ST C070115 REV.2B

Post by spbmlb10 » Mon Jun 24, 2019 3:20 am

Hi gents, thanks for the replies.

Here are some more pictures of the mod that I have completed. Is that’s what you’re wanted to see? What’s my next steps? I really appreciate the help and want to get this to sync to my 1084s Commodore monitor as it’s hard to locate a colour Atari monitor here.
Attachments
DB2445F1-CB08-458F-ACA5-B998D23A2E04.jpeg
DB2445F1-CB08-458F-ACA5-B998D23A2E04.jpeg (717.02 KiB) Viewed 1050 times
A7F11FA9-19B7-4CE1-BCC6-3E2703DEC7FB.jpeg
A7F11FA9-19B7-4CE1-BCC6-3E2703DEC7FB.jpeg (659.47 KiB) Viewed 1050 times
D82E71FF-27F7-4CA0-8ED2-B3A824696F4B.jpeg
D82E71FF-27F7-4CA0-8ED2-B3A824696F4B.jpeg (584.99 KiB) Viewed 1050 times
8801D03F-2490-4521-ACAC-19885A12D253.jpeg
8801D03F-2490-4521-ACAC-19885A12D253.jpeg (482.9 KiB) Viewed 1050 times

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: C-Sync on 520ST C070115 REV.2B

Post by exxos » Mon Jun 24, 2019 8:19 am

Have you checked the H&V sync which you solder into the motherboard, actually go back to V&G on the GLUE ? Also checked 5V and 0V are present ?

You don't say where you got the MB pinout from, but I wouldn't assume its connected or even right.. trace back to the MMU and make double sure.. same with power rails etc.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 7836
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: C-Sync on 520ST C070115 REV.2B

Post by exxos » Mon Jun 24, 2019 11:53 am

V&H SYNC come from the glue..

You need to meter out those signals ad see if they actually go to the holes where you soldered them to on the motherboard..

The "black end" of the diodes as soldered to the motherboard, need to go to the GLUE's V&Hsync pins.. I have no idea if they even go to those holes on the MB or not.. so either they don't go there at all, or you have them in the wrong place.. so you need to check whats going where... and also check you have 5V and GND is where you soldered them to as well...

Capture.JPG
Capture.JPG (113.35 KiB) Viewed 1036 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

spbmlb10
Posts: 16
Joined: Sat Jun 22, 2019 7:06 am

Re: C-Sync on 520ST C070115 REV.2B

Post by spbmlb10 » Tue Jun 25, 2019 11:50 am

I’ll check it all over the next few days when I get time and report back my findings

spbmlb10
Posts: 16
Joined: Sat Jun 22, 2019 7:06 am

Re: C-Sync on 520ST C070115 REV.2B

Post by spbmlb10 » Sat Jun 29, 2019 1:37 am

Ok I’ve had time to buzz it out.

Both H Sync and Y sync from the glue had continuity to the new soldered diodes. Following H sync there appears to be no other paths besides to the display output pin 9. Y sync also diverts off to this area of the board at pin 12. There is also a spare area when following V Sync further Looking at the schematics would I be right in saying this would be the spot for the 100uf Capacitor?



I’m tracing V sync also to pin 51 of the U15 chip which is V-Sync on schematics. The only thing I can see on the schematics is a 100uf Cap and I’m guessing this is the spot. Can anyone confirm.
Attachments
E260D6A5-A461-4040-8CF4-FDEB991707B9.jpeg
E260D6A5-A461-4040-8CF4-FDEB991707B9.jpeg (740.74 KiB) Viewed 902 times

spbmlb10
Posts: 16
Joined: Sat Jun 22, 2019 7:06 am

Re: C-Sync on 520ST C070115 REV.2B

Post by spbmlb10 » Sat Jun 29, 2019 1:43 am

Can also confirm Voltage and Ground in correct positions

spbmlb10
Posts: 16
Joined: Sat Jun 22, 2019 7:06 am

Re: C-Sync on 520ST C070115 REV.2B

Post by spbmlb10 » Sat Jun 29, 2019 4:28 am

Looks like ive made a slight mistake, the area i have circled on the board is V-Sync line connecting trace would be to 5v. Would it be a resistor not a cap? cant see anything on the schematics or am i missing something. The cap is actually meant to be a 100 Picofarad on the H-sync line according to schematics but following Hsync from the glue to the circuit i've created and back to display port i cant see a cap anywhere?

Post Reply

Return to “HARDWARE ISSUES”