Page 1 of 1

Atari Mega ST 2 White Screen

Posted: Thu Jul 11, 2019 6:52 am
by mattsoft
Hi all -

Tonight we were playing some games on my Mega ST 2 and I noticed some horizontal lines on the screen. At first I though it was the monitor, but then I hit the reset button and the ST never came back. Instead, I just get a white screen -- no floppy access. The keyboard LED does light up though. I have not started troubleshooting yet, but plan to open her up soon and first check voltages on the PSU, then make sure all socketed chips are well-seated. After that, is there anything obvious? I don't have spare chips (GLUE, Shifter, etc...) to start chip swapping, but I'm hoping there is maybe something I could check with a logic probe.

Thanks!
-matt

Re: Atari Mega ST 2 White Screen

Posted: Thu Jul 11, 2019 8:00 am
by exxos
Could be the reset switch has broke if it was working before you pressed it ?

Re: Atari Mega ST 2 White Screen

Posted: Thu Jul 11, 2019 4:47 pm
by mattsoft
exxos wrote:
Thu Jul 11, 2019 8:00 am
Could be the reset switch has broke if it was working before you pressed it ?
Yeah, that could be possible. When I press the reset button, nothing seemingly happens.

UPDATE: this morning, approx. 12 hours after last use, I powered on and everything works fine now.

:shock:

Maybe having the ST run for 3 hours straight it was overheating? I still need to open it up and check for loose chips. Maybe something is expanding with heat and not seated properly.

Re: Atari Mega ST 2 White Screen

Posted: Thu Jul 11, 2019 4:53 pm
by exxos
If the PSU hasn't been recapped then that could be a issue.

Re: Atari Mega ST 2 White Screen

Posted: Fri Jul 12, 2019 4:19 pm
by mattsoft
exxos wrote:
Thu Jul 11, 2019 4:53 pm
If the PSU hasn't been recapped then that could be a issue.
It has not been recapped. I'll let it run some more and see if I can reproduce. If it acts up again, I'll measure PSU voltage and go from there. Thanks!