520STFM: After replacing memory: White screen of death.

Problems with your machine in general.
User avatar
rubber_jonnie
Moderator
Moderator
Posts: 2954
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: 520STFM: After replacing memory: White screen of death.

Post by rubber_jonnie » Sun Sep 27, 2020 11:02 am

My advice for anybody doing any sort of upgrades is to only do only one thing at a time. Easy to say retrospectively I know!

Upgrade the RAM, test and if all is well, add the Blitter socket. If it doesn't work then you only have one thing to try and troubleshoot.

I know how easy it is to get caught in the moment and do everything at once, I've been there myself. Glad to hear you've got there in the end :)
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

stephen_usher
Trusted Guru
Trusted Guru
Posts: 868
Joined: Mon Nov 13, 2017 7:19 pm
Location: Oxford, UK.
Contact:

Re: 520STFM: After replacing memory: White screen of death.

Post by stephen_usher » Sun Sep 27, 2020 1:11 pm

I know, I know... But the socket was a passive component... how could that possibly hurt? ;)
Intro retro computers since before they were retro...
ZX81->Spectrum->Memotech MTX->Sinclair QL->520STM->BBC Micro->TT030->PCs & Sun Workstations.
Added code to the MiNT kernel (still there the last time I checked) + put together MiNTOS.
Collection now with added Macs, Amigas, Suns and Acorns.

Post Reply

Return to “HARDWARE ISSUES”