1040 ste TROUBLESHOOTING

Problems with your machine in general.
Post Reply
Bikerbob
Posts: 62
Joined: Fri Nov 10, 2017 7:30 pm

1040 ste TROUBLESHOOTING

Post by Bikerbob » Tue Nov 21, 2017 4:10 pm

Hello all,

Buddy has a 1040ste - thing is mint.. looks barely used.

Had stock PSU and was getting VERY HOT - after so much time, disk access and directories were getting messed up. We thought bad psu.

So we swapped it out for an ATX wired up to fit the header. Power is not the issue.

After a couple of hours the same thing happens nothing hot, but the disk gets messed up and also the sound dies off to just barely audible with it up full volume.. but you do hear something.

Any ideas? think a diag cart would help here?

Open to suggestions.

James

User avatar
exxos
Site Admin
Posts: 2908
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 1040 ste TROUBLESHOOTING

Post by exxos » Tue Nov 21, 2017 6:08 pm

What simms are in there ? Also ATX PSU doesn't mean its "good" a lot of them have bad regulation anyway.

Try RAM tester for starters...

viewtopic.php?f=25&t=28
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Bikerbob
Posts: 62
Joined: Fri Nov 10, 2017 7:30 pm

Re: 1040 ste TROUBLESHOOTING

Post by Bikerbob » Tue Nov 21, 2017 7:02 pm

I remember he said he bought some Ram that was in an older MAC? is mac and ST ram difference? like ecc non ecc ram?

James

User avatar
exxos
Site Admin
Posts: 2908
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 1040 ste TROUBLESHOOTING

Post by exxos » Tue Nov 21, 2017 10:22 pm

Bikerbob wrote:
Tue Nov 21, 2017 7:02 pm
I remember he said he bought some Ram that was in an older MAC? is mac and ST ram difference? like ecc non ecc ram?
You need 70ns or slower, 2 or 8 chip normally.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Bikerbob
Posts: 62
Joined: Fri Nov 10, 2017 7:30 pm

Re: 1040 ste TROUBLESHOOTING

Post by Bikerbob » Sat Nov 25, 2017 8:09 pm

So, not the ram, because he said he was having this issue before he installed the aftermarket ram.

OK, others on other boards are suggesting bad DMA. your the DMA guy Chris? do you think its worth the try to just sub it out?

James

User avatar
exxos
Site Admin
Posts: 2908
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 1040 ste TROUBLESHOOTING

Post by exxos » Sat Nov 25, 2017 9:19 pm

You need to test the RAM and make sure the machine is actually operating correctly before going deeper. Starting with RAM, tests a lot of stuff out and you cannot skip this step just based on what some guy says.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply