Dead Atari STF - C070789 - 002 Rev.D

Problems with your machine in general.
wietze
Posts: 53
Joined: Sun Oct 07, 2018 5:27 pm

Dead Atari STF - C070789 - 002 Rev.D

Post by wietze » Wed Jan 13, 2021 9:21 pm

Hi guys,

In my attempts to upgrade the motherboard from 1 to 4 mb using an exxos I resulted in creating an Atari ST that provides a black screen when booting.
From this state I have soldered in sockets at the first rows of ram for further diagnosis. I am using RAM simms that I have succesfully tested using Yaart on another machine.
board.jpg
Picture of the board, yes it has a SACK Intel cpu attached :)
board.jpg (433.1 KiB) Viewed 271 times
During bootup, I get a black screen:
black.jpg
Black screen output
black.jpg (158.89 KiB) Viewed 271 times
When using the diag cartridge, I have the following screen:
diag.jpg
Diagnostics screen output
diag.jpg (283.53 KiB) Viewed 271 times
With the following output over RS232; wich are a combination of
I1 RAM/data line errors and
I2 RAM disturbance errors
rs232output.jpg
Diagnostics cartridge output over RS232
rs232output.jpg (439.7 KiB) Viewed 271 times
My first intended step is to consult the motherboard schematics to see if I can figure out if I can start testing continuity for all the related connected pins of the soldered in sockets.

I have no clue as to how to meaningfully interpret the Diagnostics cartrdige output to narrow down/focus/validate more specifically than mentioned approach. I would be oblidged to get pointers and feedback on my exploration :).

Kind regards,
Wietze

<edit> my current `diagnostics tools' consist of the cartridge and a multimeter.

User avatar
exxos
Site Admin
Site Admin
Posts: 13713
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Dead Atari STF - C070789 - 002 Rev.D

Post by exxos » Wed Jan 13, 2021 10:21 pm

Looks like bits 8 & 10 are bad. So if you trace on the schematic where D8 & D10 goto which chip and resolder it.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

wietze
Posts: 53
Joined: Sun Oct 07, 2018 5:27 pm

Re: Dead Atari STF - C070789 - 002 Rev.D

Post by wietze » Wed Jan 13, 2021 10:30 pm

exxos wrote:
Wed Jan 13, 2021 10:21 pm
Looks like bits 8 & 10 are bad. So if you trace on the schematic where D8 & D10 goto which chip and resolder it.
Thank you for your reply. How did you determine that bit 8 and 10 are bad? Id like to understand this.

In the meanwhile, I checked connectivity on all the soldered lines, by checking connectivity of the pin on corresponding pins on different sockets and unsocketed pins on the other rows. And from this I conclude that at least all pins are connected / the sockets are connected up with the board. I will see if I can trace the pins into the rest of the board; checking for continuity.

User avatar
exxos
Site Admin
Site Admin
Posts: 13713
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Dead Atari STF - C070789 - 002 Rev.D

Post by exxos » Wed Jan 13, 2021 10:35 pm

wietze wrote:
Wed Jan 13, 2021 10:30 pm
How did you determine that bit 8 and 10 are bad? Id like to understand this.
Just count the bits viewtopic.php?f=91&t=3143#p47751
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
DoG
Trusted Guru
Trusted Guru
Posts: 582
Joined: Sat Apr 07, 2018 12:26 pm

Re: Dead Atari STF - C070789 - 002 Rev.D

Post by DoG » Wed Jan 13, 2021 10:49 pm

See troubleshooting help.

But it look like bit 8 and 11. So after looking at schematics it is U44 and U27.

C070789.png
C070789.png (1.41 MiB) Viewed 232 times
EDIT: @exxos beat me to it. :)

User avatar
exxos
Site Admin
Site Admin
Posts: 13713
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Dead Atari STF - C070789 - 002 Rev.D

Post by exxos » Wed Jan 13, 2021 10:53 pm

DoG wrote:
Wed Jan 13, 2021 10:49 pm
EDIT: @exxos beat me to it. :)
Not really, you was more helpful ;)
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

wietze
Posts: 53
Joined: Sun Oct 07, 2018 5:27 pm

Re: Dead Atari STF - C070789 - 002 Rev.D

Post by wietze » Wed Jan 13, 2021 11:04 pm

Awesome guys! Thanks. Just to apply this knowledge (after reseating the simms):

So i ran the diagnostics a bit longer, just to see if I could make sense of it. And from the following shot I deduce:
diag2.jpg
Consistent I1 messages after a ton of I2 messages
diag2.jpg (447.89 KiB) Viewed 224 times
D12 (from first line)
D9 and D8 and D2 (from second line)
D7 (from 4th line)
D14 (from last row)

These I1 errors come steadily after a bunch of I2 RAM Disturbance.
Is detecting errors in memory for I1 and I2 messages the same?

wietze
Posts: 53
Joined: Sun Oct 07, 2018 5:27 pm

Re: Dead Atari STF - C070789 - 002 Rev.D

Post by wietze » Wed Jan 13, 2021 11:09 pm

To be honest, if I run the diag cart for longer, it seems that almost all D lines are bad. There is literally lines that are 16 times 0, followed by 16 times 1; but these do not show consistently. (e.g. for reach 16 0's entry a different mask of 01 combinatios are shown per line).

User avatar
exxos
Site Admin
Site Admin
Posts: 13713
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Dead Atari STF - C070789 - 002 Rev.D

Post by exxos » Wed Jan 13, 2021 11:15 pm

If your getting random bit errors, then it can be bad RAS/CAS lines or bad address bit...

I fell victim of that recently... viewtopic.php?f=18&t=1789&start=670#p37284
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

tzok
Posts: 272
Joined: Sat Dec 30, 2017 2:27 pm

Re: Dead Atari STF - C070789 - 002 Rev.D

Post by tzok » Wed Jan 13, 2021 11:19 pm

wietze wrote:
Wed Jan 13, 2021 9:21 pm
I am using RAM simms that I have succesfully tested using Yaart on another machine.
I see no SIMMs there (SIMMs are used in the STe, here you have just chips in DIP packages), but what I see is the AT-Speed hardware emulator. Have you tried removing it?

Post Reply

Return to “HARDWARE ISSUES”