Falcon sound problems (DSP)

Problems with your machine in general.
User avatar
kohli79
Posts: 21
Joined: Fri Feb 05, 2021 8:23 pm
Location: Saxony Anhalt, Germany

Falcon sound problems (DSP)

Post by kohli79 » Fri Feb 05, 2021 9:04 pm

Hello Atari friends,

i have a problem with one of my falcons.
As soon as I start ACE2 Tracker, the right loudspeaker of my audio system starts to crackle and rustle.
Only from the right one! If the internal loudspeaker in the Falcon is activated, you can hear it too. So if the DSP is working the problem is. Everything was okay in games and demos that I tested.
The fault is always no matter whether the Falcon is cold or warm.
I ran DMA2DSP, and I have a lot of red spikes on the lower green bar. The background was also completely red. My other Falcon shows everything in green on the bar.
The Falcon is REV B and still original.
Anyone have any idea where to start looking?
Thank you in advance!
Sorry for my English, I use google translator. :oops:

Greetings Uwe

mikro
Posts: 238
Joined: Mon Aug 28, 2017 11:22 pm
Location: Kosice, Slovakia
Contact:

Re: Falcon sound problems (DSP)

Post by mikro » Fri Feb 05, 2021 9:14 pm


User avatar
kohli79
Posts: 21
Joined: Fri Feb 05, 2021 8:23 pm
Location: Saxony Anhalt, Germany

Re: Falcon sound problems (DSP)

Post by kohli79 » Fri Feb 05, 2021 10:07 pm

Thanks, I knew the site. The PSU capacitors + NVRAM and the clock patch should be made soon. Let's see when the NVRAM is available again at exxos shop. 😉

User avatar
exxos
Site Admin
Site Admin
Posts: 14255
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: https://www.youtube.com/user/exxosuk
Contact:

Re: Falcon sound problems (DSP)

Post by exxos » Fri Feb 05, 2021 10:18 pm

kohli79 wrote:
Fri Feb 05, 2021 10:07 pm
Thanks, I knew the site. The PSU capacitors + NVRAM and the clock patch should be made soon. Let's see when the NVRAM is available again at exxos shop. 😉
Hopefully I will start next week :)
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?

User avatar
kohli79
Posts: 21
Joined: Fri Feb 05, 2021 8:23 pm
Location: Saxony Anhalt, Germany

Re: Falcon sound problems (DSP)

Post by kohli79 » Fri Feb 05, 2021 10:21 pm

exxos wrote:
Fri Feb 05, 2021 10:18 pm
kohli79 wrote:
Fri Feb 05, 2021 10:07 pm
Thanks, I knew the site. The PSU capacitors + NVRAM and the clock patch should be made soon. Let's see when the NVRAM is available again at exxos shop. 😉
Hopefully I will start next week :)
:dualthumbup:

User avatar
kohli79
Posts: 21
Joined: Fri Feb 05, 2021 8:23 pm
Location: Saxony Anhalt, Germany

Re: Falcon sound problems (DSP)

Post by kohli79 » Tue Feb 09, 2021 12:52 pm


User avatar
Steve
Trusted Guru
Trusted Guru
Posts: 901
Joined: Fri Sep 15, 2017 11:49 am

Re: Falcon sound problems (DSP)

Post by Steve » Tue Feb 09, 2021 1:50 pm

It is good you are working on your Falcon right now, as your custom chips are all working still. I bet if you left it any longer things would get worse. Let us know how you go :) By the way - be super careful and patient when removing the old NVRAM, as it is very easy to break a trace. Even if you have a de-soldering gun, afterwards apply flux and go over again with a regular soldering iron & wick. Then wiggle/feel every single leg with tweasers, make sure they are loose.
Repairs & Servicing for Atari & Amiga machines (and any other retro computers) Located in the West Midlands UK. PM me if you require assistance.
www.solidstatesociety.co.uk

User avatar
kohli79
Posts: 21
Joined: Fri Feb 05, 2021 8:23 pm
Location: Saxony Anhalt, Germany

Re: Falcon sound problems (DSP)

Post by kohli79 » Tue Feb 09, 2021 2:07 pm

Steve wrote:
Tue Feb 09, 2021 1:50 pm
It is good you are working on your Falcon right now, as your custom chips are all working still. I bet if you left it any longer things would get worse. Let us know how you go :) By the way - be super careful and patient when removing the old NVRAM, as it is very easy to break a trace. Even if you have a de-soldering gun, afterwards apply flux and go over again with a regular soldering iron & wick. Then wiggle/feel every single leg with tweasers, make sure they are loose.
Thanks for the information, I have a specialist who does all of this for me. 😉 In the past he had special equipment to test the Falcon, but unfortunately he no longer has it. The question is, do the problems disappear after installing the ClockPatch!? 🤔
We will see ...

User avatar
kohli79
Posts: 21
Joined: Fri Feb 05, 2021 8:23 pm
Location: Saxony Anhalt, Germany

Re: Falcon sound problems (DSP)

Post by kohli79 » Tue Mar 30, 2021 7:28 pm

Took a while but now the Falcon is back.
NVRAM + Clockpatch + PSU capacitors changed.
Unfortunately still the same problems as before. 😕
No idea what that could be, DMA chip maybe?

Greetings Uwe

User avatar
Steve
Trusted Guru
Trusted Guru
Posts: 901
Joined: Fri Sep 15, 2017 11:49 am

Re: Falcon sound problems (DSP)

Post by Steve » Tue Mar 30, 2021 9:32 pm

What clock patch did you use?
Repairs & Servicing for Atari & Amiga machines (and any other retro computers) Located in the West Midlands UK. PM me if you require assistance.
www.solidstatesociety.co.uk

Post Reply

Return to “HARDWARE ISSUES”