Exxos diagnostic cart help

Problems with your machine in general.
Post Reply
Rustynutt
Posts: 49
Joined: Fri Sep 29, 2017 8:24 am

Exxos diagnostic cart help

Post by Rustynutt » Wed May 26, 2021 8:00 am

Received my order for diagnostic carts and Falcon video adapters.
Cool stuff.
The diagnostic was already jumpered for T4.04, worked fine.
Wanted to see how GEMBENCH worked, even with the jumper position printed in the board, question if I have the correct settings.
Maybe someone could post a snap shot?
Also, I'm guessing once the correct setting is made, for GEMBENCH, the cart will show up as a device and can be installed from the desktop, right?

Thanks.

User avatar
exxos
Site Admin
Site Admin
Posts: 15323
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: Exxos diagnostic cart help

Post by exxos » Wed May 26, 2021 9:15 am

It shows up on desktop as a cartridge c:
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~

User avatar
rubber_jonnie
Moderator
Moderator
Posts: 4145
Joined: Thu Aug 17, 2017 7:40 pm
Location: Essex
Contact:

Re: Exxos diagnostic cart help

Post by rubber_jonnie » Wed May 26, 2021 11:44 am

If it doesn't immediately appear as a device on the desktop, then yes you need to add it.
Collector of old Atari things:
800XL + Ultimate 1MB, 2x 1010 cassette, 1050 + Happy mod, 65XE (128k +APE Warp) & XC12, SIO2SD, 2600jr, 7800 and Lynx II
Atari 520ST (1Meg), 1040STF long button floppy, 2x 1040 STFMs + Gotek, 2x 4160STE with 32Mhz booster, ROM switcher, Mega ST1, Mega ST4, not to mention various bare ST boards for testing including a PAK 68/2 :)
Plus the rest..
Amiga stuff, Mac stuff, Sinclair stuff etc...
www.electronicnothingness.co.uk

Rustynutt
Posts: 49
Joined: Fri Sep 29, 2017 8:24 am

Re: Exxos diagnostic cart help

Post by Rustynutt » Thu May 27, 2021 8:25 pm

Got it!
Just using a basic desktop with plain icons, missed it was installed as "C" :)
Thanks

FWIW, before the cart arrived using the disk based GEMBENCH for sometime, began receiving errors when loading saved profiles. Kept getting (not literally) can't find destination path/file on drive E (GEMBENCH was ran from C: and D:). Went as far as creating a directory on E: with the same structure as the error with same result. Reported error could see was from GEMBENCH as it relates to a .bas file in line (x).
Did the Atari thing, removed changes made until the problem was discovered.
Turned out, was due to Selectric's previous (20 years ago) configuration contained in it's .inf file. Don't recall exactly which convention it was, deleting the .inf file solved the problem :)

User avatar
exxos
Site Admin
Site Admin
Posts: 15323
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: Exxos diagnostic cart help

Post by exxos » Thu May 27, 2021 8:52 pm

I think the cart generates a virtual drive which it copies the files to.. (maybe E:). Though I guess you should always clean boot as I have no idea of side-effects when running 500+ different setups.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~

Rustynutt
Posts: 49
Joined: Fri Sep 29, 2017 8:24 am

Re: Exxos diagnostic cart help

Post by Rustynutt » Mon Jun 14, 2021 4:40 am

If it can be done wrong :lol:

I'd copied the files off the cart to HD, think that was the issue. It was looking in the right place, just wasn't there.
Downloaded the "disk version".

Another anomaly, EmuTos in ROM recognizes the Exxos cart set to diagnostic. It however must not be looking at the port for a storage device
as there's nothing to be installed.
Have to ask them about that.

500+
You wish :lol:

Update: It was Selectric File Selector.

User avatar
exxos
Site Admin
Site Admin
Posts: 15323
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: Exxos diagnostic cart help

Post by exxos » Mon Jun 14, 2021 9:22 am

I never thought anyone would try and copy stuff from the cart to hard drive. Certainly not tested.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~

User avatar
DoG
Posts: 746
Joined: Sat Apr 07, 2018 12:26 pm

Re: Exxos diagnostic cart help

Post by DoG » Mon Jun 14, 2021 10:46 am

I have other cartridges (can't remember any by name unfortunately) with same behaviour. That is that they appeare as "drive c" (not "C").

I can't remember specific TOS I ran it from either.

Sorry for so little help, but I can concur at least.

Oh yes, exxos cart I got "c" drive as well and ran from that.

User avatar
exxos
Site Admin
Site Admin
Posts: 15323
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
YouTube: exxosuk
Contact:

Re: Exxos diagnostic cart help

Post by exxos » Mon Jun 14, 2021 11:00 am

Yeah "c" is cartridge , that's normal in TOS. "C" is hard drive. Though IIRC it creates a virtual drive E: where the files are. So its best just to clean boot else it could conflict with actual drives I guess.
https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/store2/ - All my hardware mods for sale - Please help support by making a purchase.
viewtopic.php?f=17&t=1585 Have you done the Mandatory Fixes ?
Just because a lot of people agree on something, doesn't make it a fact. ~exxos ~

Post Reply

Return to “HARDWARE ISSUES”