1040 STF rolling screen

Problems with your machine in general.
Post Reply
juvuk1
Posts: 2
Joined: Wed May 23, 2018 10:45 am

1040 STF rolling screen

Post by juvuk1 » Wed May 23, 2018 4:09 pm

Hi all,

I have a 1040STF that has a rolling screen, i have tried a scart lead from retro cables and a compasite lead on two different TVs but still the screen just keeps on rolling, anyone have any idea why?


cheers, Justin

User avatar
exxos
Site Admin
Posts: 3549
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 1040 STF rolling screen

Post by exxos » Wed May 23, 2018 10:00 pm

Some scart cables use composite for the syncs, and the STF doesn't output composite.. Have you tried RF ?
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Neffers
Posts: 68
Joined: Thu Jan 25, 2018 12:25 am
Location: West Yorks.
Contact:

Re: 1040 STF rolling screen

Post by Neffers » Fri May 25, 2018 7:58 am

If you can, grab an Automation Disc (A_001 Onwards), and see if switching the frequency helps. 50 / 60hz is a bit of an issue, and seeing as you didn't mention where you are from, regionally, this could be a legitimate cause of the screen rolling.

Also, welcome 8-)
Resident idiot. (Qualified, got a Diploma and everything)

juvuk1
Posts: 2
Joined: Wed May 23, 2018 10:45 am

Re: 1040 STF rolling screen

Post by juvuk1 » Wed May 30, 2018 11:35 am

Hi all,

and thanks for the replies

I am in the UK and i have tried RF, scart and two TVs

the screen is completely white with no border and just constantly rolls, it never gets to the green os screen

the board looks to be fine, i have re-seated all the socket chips, i don't know what else to try :(

User avatar
exxos
Site Admin
Posts: 3549
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 1040 STF rolling screen

Post by exxos » Wed May 30, 2018 1:07 pm

If you never get to desktop then it suggests the machine isn't booting at all.. maybe bad reset switch ?
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

troed
Posts: 348
Joined: Mon Aug 21, 2017 10:27 pm

Re: 1040 STF rolling screen

Post by troed » Wed May 30, 2018 2:15 pm

Yeah that's an obvious 60Hz TOS-is-not-setting-50Hz screen. It means something is either holding RESET high or your TOS chips are faulty which means the computer doesn't even get through the first few instructions.

Post Reply