PC isses Port COM & Printer Parallel Port LPT

Problems with your machine in general.
Post Reply
walter_j64bit
Posts: 27
Joined: Thu Mar 22, 2018 1:34 am

PC isses Port COM & Printer Parallel Port LPT

Post by walter_j64bit » Fri Jul 20, 2018 3:26 pm

OK I have a Biostar a68n-5000, it has on board Port COM & Printer Parallel Port LPT but they seem to be useless, I've got new com port serial parallel header cable connection installed but I can't get any data from or to them. Here's the real kick in the pants Windows XP & Windows 10 see the on board Port COM & Printer Parallel Port LPT and both Windows say they are working :roll: but any way, anyone here have any ideas what I can do to fix this? Oh the "UBS to Com/LPT" isn't going to work for what I need. Thanks! Oh, I do have latest drivers for my pc.
Attachments
com_LPT.jpg
com_LPT.jpg (119.43 KiB) Viewed 740 times

User avatar
exxos
Site Admin
Site Admin
Posts: 3935
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: PC isses Port COM & Printer Parallel Port LPT

Post by exxos » Fri Jul 20, 2018 3:49 pm

PC software set to use COM1 ?

Motherboard COM ports disabled (if any) ?

Try renaming the port to COM10 and try again ?
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

walter_j64bit
Posts: 27
Joined: Thu Mar 22, 2018 1:34 am

Re: PC isses Port COM & Printer Parallel Port LPT

Post by walter_j64bit » Fri Jul 20, 2018 4:58 pm

exxos wrote:
Fri Jul 20, 2018 3:49 pm
PC software set to use COM1 ?

Motherboard COM ports disabled (if any) ?

Try renaming the port to COM10 and try again ?
Yes, and I've changed the PC software setting to match Com port when com port are changed to Com5,Com4 or Com 2.

No Motherboard Com ports are disabled.

Yes, I've tried Com5,Com4 and Com 2.

User avatar
exxos
Site Admin
Site Admin
Posts: 3935
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: PC isses Port COM & Printer Parallel Port LPT

Post by exxos » Fri Jul 20, 2018 5:05 pm

walter_j64bit wrote:
Fri Jul 20, 2018 4:58 pm
Yes, I've tried Com5,Com4 and Com 2.
Probably wont matter, but try a lot higher number like COM10..

I had issues on my XP setup years ago where failed installs of IO card causes like all the COM ports to not work, even though there was no ports listed in device manager. Sometimes it would refuse to even let me use anything below COM10, even though nothing was listed as using them. I ended up just renaming the port to COM10 and it worked after that.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

walter_j64bit
Posts: 27
Joined: Thu Mar 22, 2018 1:34 am

Re: PC isses Port COM & Printer Parallel Port LPT

Post by walter_j64bit » Fri Jul 20, 2018 5:38 pm

The app only use com1 to com8 but I did try out com8 with no luck.

User avatar
exxos
Site Admin
Site Admin
Posts: 3935
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: PC isses Port COM & Printer Parallel Port LPT

Post by exxos » Fri Jul 20, 2018 5:47 pm

Baud rate issues ? duff card ?
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

walter_j64bit
Posts: 27
Joined: Thu Mar 22, 2018 1:34 am

Re: PC isses Port COM & Printer Parallel Port LPT

Post by walter_j64bit » Fri Jul 20, 2018 5:54 pm

I'll look into Baud rates tomorrow, I have to get ready for work now but Thanks! :D

walter_j64bit
Posts: 27
Joined: Thu Mar 22, 2018 1:34 am

Re: PC isses Port COM & Printer Parallel Port LPT

Post by walter_j64bit » Sat Jul 21, 2018 4:54 pm

Changing the baud rates didn't do anything, I'll have to look at other options. Thanks anyway!

User avatar
DrF
Moderator
Moderator
Posts: 297
Joined: Thu Aug 17, 2017 1:18 pm

Re: PC isses Port COM & Printer Parallel Port LPT

Post by DrF » Wed Jul 25, 2018 12:57 pm

Had a issue like this before with some old Eprom programmers, it was found to be something to do with port polling and how it changed after Windows XP SP2 we tried everything, PCI cards, adaptors, convertors, ended up just keeping a old PC just for that job since it was found it was the OS being silly.

Might be worth a try if you tried everything else?

walter_j64bit
Posts: 27
Joined: Thu Mar 22, 2018 1:34 am

Re: PC isses Port COM & Printer Parallel Port LPT

Post by walter_j64bit » Fri Jul 27, 2018 1:29 pm

DrF wrote:
Wed Jul 25, 2018 12:57 pm
Had a issue like this before with some old Eprom programmers, it was found to be something to do with port polling and how it changed after Windows XP SP2 we tried everything, PCI cards, adaptors, convertors, ended up just keeping a old PC just for that job since it was found it was the OS being silly.

Might be worth a try if you tried everything else?
That makes sense, I've did some more homework on the app it doesn't work with ePCI cards to Port COM & Printer Parallel Port LPT so I'm going have to look into setting up an old laptop just for this app.

Post Reply