16BIT ROM CART THOUGHTS

General discussions or ideas about hardware.
User avatar
rpineau
Site Admin
Site Admin
Posts: 495
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: 16BIT ROM CART THOUGHTS

Post by rpineau » Wed Apr 04, 2018 10:42 pm

I updated my post with more info.
I found plenty of places where A15 is connected , as well as ROM4 and ROM3 , for 128K cartridge
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
exxos
Site Admin
Site Admin
Posts: 8543
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 16BIT ROM CART THOUGHTS

Post by exxos » Wed Apr 04, 2018 10:48 pm

rpineau wrote:
Wed Apr 04, 2018 10:42 pm
I updated my post with more info.
I found plenty of places where A15 is connected , as well as ROM4 and ROM3 , for 128K cartridge
Looking at the proper diag-cart, ROM4 is jumpered, ROM 3 isn't.. so for that cart ROM3 does not seem to be used.

There also jumpers for 64K/128K which is open... 256K is jumpered.. so need to check where that line is going..OK A13..

EDIT:
OK I think something is wrong with the edge connector.. on the proper cart ROM 4 is going 4 pins up from the bottom on top layer.. but on my cart top layer 4 pins up is A2 :roll: So I think the connector has layer order wrong :(

Its correct that 2 pin use gnd on the bottom end of the connector, but on mine its on the top layer, and should be bottom layer.. so its not wrong order of pins , just on wrong layer... but I dont get how this problem not show on the RTC boards :shrug:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rpineau
Site Admin
Site Admin
Posts: 495
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: 16BIT ROM CART THOUGHTS

Post by rpineau » Wed Apr 04, 2018 11:03 pm

So my connector is al wrong ?
I believe I followed this : http://info-coach.fr/atari/hardware/int ... _cartridge

I remember you making changes and sending it back to me .. did the 2 layer got swapped ?!
Rodolphe
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
rpineau
Site Admin
Site Admin
Posts: 495
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: 16BIT ROM CART THOUGHTS

Post by rpineau » Wed Apr 04, 2018 11:08 pm

Ok, loaded the lib in eagle, hide top layer, clock on first bottom layer left pin ... it says PIN 39 !!!!
39 should be on the top, 40 on the bottom !!
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
exxos
Site Admin
Site Admin
Posts: 8543
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 16BIT ROM CART THOUGHTS

Post by exxos » Wed Apr 04, 2018 11:10 pm

rpineau wrote:
Wed Apr 04, 2018 11:03 pm
So my connector is al wrong ?
I believe I followed this : http://info-coach.fr/atari/hardware/int ... _cartridge
pinout is correct I think on site, and your pinout follows that... but on the actual PCB part the layer order is wrong...

Site has pin 38 & pin 40 as GND.. and your schematic shows that...

11.jpg
11.jpg (4.96 KiB) Viewed 1587 times

But on actual PCB..

22.jpg
22.jpg (79.24 KiB) Viewed 1587 times

2 GND lines on the top layer 38&40 (should be bottom like on the site)

So no idea whats going on ? :shrug:
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rpineau
Site Admin
Site Admin
Posts: 495
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: 16BIT ROM CART THOUGHTS

Post by rpineau » Wed Apr 04, 2018 11:12 pm

Somehow the layer got swapped.
We need to put the top on the bottom and bottom on the top.
No idea how this happened.
I'm fixing the lib but that's why it's not working and we're lucky we did short GND and VCC
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
exxos
Site Admin
Site Admin
Posts: 8543
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 16BIT ROM CART THOUGHTS

Post by exxos » Wed Apr 04, 2018 11:16 pm

rpineau wrote:
Wed Apr 04, 2018 11:12 pm
Somehow the layer got swapped.
We need to put the top on the bottom and bottom on the top.
yes..
rpineau wrote:
Wed Apr 04, 2018 11:12 pm
No idea how this happened.
I know I had some confusion over this a while ago and you did edit the lib, but I put back to older version as I think after your edit, the 2 gnd wires were at the top, so it was "upside down".. but I never checked the layer orders.. I assume was OK as it worked with the RTC boards... The order of signals is correct as I checked that a lot.. but I never thought to check top and bottom layer order :(
rpineau wrote:
Wed Apr 04, 2018 11:12 pm
I'm fixing the lib but that's why it's not working and we're lucky we did short GND and VCC
Didn't I assume ? :) Yeah, well, I am using my own PSU, I shorted VCC & GND lots of times over the past year ;)
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
rpineau
Site Admin
Site Admin
Posts: 495
Joined: Thu Aug 17, 2017 6:08 pm
Location: USA
Contact:

Re: 16BIT ROM CART THOUGHTS

Post by rpineau » Wed Apr 04, 2018 11:24 pm

Ok, I fixed the lib , odd pin on top, even pin on bottom. I'm checking to make sure the pins are correct and will send you the new version.. and I guess I owe you now ;)
Rodolphe
Working ones : MegaSTE (68020) / TT030 / Falcon with AB040 & Eclipse / 1040STF
Need testing : Falcon with CT2

User avatar
exxos
Site Admin
Site Admin
Posts: 8543
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 16BIT ROM CART THOUGHTS

Post by exxos » Wed Apr 04, 2018 11:26 pm

rpineau wrote:
Wed Apr 04, 2018 11:24 pm
Ok, I fixed the lib , odd pin on top, even pin on bottom. I'm checking to make sure the pins are correct and will send you the new version..
:) Sleep time for me soon , so will look tomorrow :)
rpineau wrote:
Wed Apr 04, 2018 11:24 pm
and I guess I owe you now ;)
Nope :) My bad for not checking the layer order.
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

User avatar
exxos
Site Admin
Site Admin
Posts: 8543
Joined: Wed Aug 16, 2017 11:19 pm
Location: UK
Contact:

Re: 16BIT ROM CART THOUGHTS

Post by exxos » Thu Apr 05, 2018 1:11 pm

So updated lib used now.. I used the current design and flipped the layout order so I don't have to re-route the design.. have a few things to fix.. but now GND is twice on bottom layer (38 & 40) So should be good now :)

2A.JPG
2A.JPG (162.74 KiB) Viewed 1570 times
4MB STFM 1.44 FD- VELOCE+ 020 STE - 4MB STE 32MHz - STFM 16MHz - STM - MEGA ST - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - HxC - CosmosEx - Ultrasatan - various clutter

https://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
https://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.

Post Reply

Return to “HARDWARE DISCUSSIONS”